Hello

I have configured DNS on iSeries V5R3. DNS is working fine as I have
checked from outside using mahcine name "ping
machinename.domain.com"and also using IP Address.

I have also checked my web site over the internet and it is showing IBM
HTTP Sample Page.

Problem:-
After configured DNS Service, I tried to start my WebSphere Express
6.0 but its failed and it is encountering following error

[10/26/05 16:08:21:553 EDT] 0000000a WsServerImpl E WSVR0009E: Error
occurred during startup
META-INF/ws-server-components.xml
[10/26/05 16:08:22:163 EDT] 0000000a WsServerImpl E WSVR0009E: Error
occurred during startup
com.ibm.ws.exception.ConfigurationError:
com.ibm.ws.exception.ConfigurationError:
javax.naming.ConfigurationException: Cannot get canonical host name for
server.
at java.lang.Throwable.(Throwable.java:240)
at java.lang.Exception.(Exception.java:77)
at com.ibm.ws.exception.WsException.(WsException.java:87)
at
com.ibm.ws.exception.WsRuntimeFwException.(WsRuntimeFwException.java:33)
at
com.ibm.ws.exception.ConfigurationError.(ConfigurationError.java:41)
at
com.ibm.ws.runtime.WsServerImpl.bootServerContaine r(WsServerImpl.java:205)
I suspect the above error is encountering because websphere server is
not resolving my new domain.

http_plugin.log is also encountering following log:-

[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR: ws_transport: transportSetServerAddress: Failed to resolve
address [SATERIWS.SATERIDOM] and port [9080], error 6
[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR: ws_server: serverAddTransport: Failed to initialize server
address
[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR: lib_sxp: sxpParse: End element returned FALSE for Transport.
line 14 of
/QIBM/UserData/WebSphere/AppServer/V6/Base/profiles/default/config/cells/SATERIWS/nodes/IHS_SATERIWS_WEBSERVER_node/servers/IHS_SATERIWS_WEBSERVER/plugin-cfg.xml
[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR: ws_config_parser: configParserParse: Failed to parse the
config file
/QIBM/UserData/WebSphere/AppServer/V6/Base/profiles/default/config/cells/SATERIWS/nodes/IHS_SATERIWS_WEBSERVER_node/servers/IHS_SATERIWS_WEBSERVER/plugin-cfg.xml
[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR: ws_common: websphereUpdateConfig: Failed parsing plugin config
file:
[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR:
/QIBM/UserData/WebSphere/AppServer/V6/Base/profiles/default/config/cells/SATERIWS/nodes/IHS_SATERIWS_WEBSERVER_node/servers/IHS_SATERIWS_WEBSERVER/plugin-cfg.xml
[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR: The above file may not have correct authorities.
[Wed Oct 26 10:34:46 2005] 018708/QTMHHTTP/WEBSERVER 00000000 00000002
- ERROR: Do WRKLNK, Opt 9 on above file.

Note: SATERIES.SATERIDOM was my old domain. Now we have registered new
domain over the internet and I am configuring new DNS for http and
websphere to access website and application using naming convention.

I wondering why is still looking old domain.

Has anyone experience same problem? Can you please guide me how to
configure DNS on iSeries for http server.

I suspect "Cannot get canonical host name for server" error means
it is conflicting with old domain.

I got confused about CFGTCP Options 10 and Option 12.
Should I need to change host table entries as well as Domain Name
Service for configuring new DNS?

Please help me resolve the problem.