Hi all!

I have to following problem on my iSeries with the WAS 6.0.2.0:

I have installed it and run the Admin-HTTP-Server. I have created the
Applicationserver and an HTTP-Server for this, run the Administrative
Console, enable security and restart the Application Server.

After I restarted it, it is not possible anymore to join the
Administrative Console. the Browser shows me information about the
certificate and then it loads or better said: It does nothing anymore.

In the SystemErr.log I find the following Exception:

[13/10/05 07:50:24:862 CDT] 00000048 SystemErr R
java.lang.NoClassDefFoundError: javax/crypto/e at
java.lang.Throwable.(Throwable.java:195) at
java.lang.Error.(Error.java:49) at
java.lang.NoClassDefFoundError.(NoClassDefFoundError.java:40) at
javax.crypto.KeyAgreement.getInstance(Unknown Source) at
com.ibm.jsse2.o.a(Unknown Source) at com.ibm.jsse2.x.a(Unknown Source)
at com.ibm.jsse2.x.a(Unknown Source) at com.ibm.jsse2.v.a(Unknown
Source) at com.ibm.jsse2.bf.a(Unknown Source) at
com.ibm.jsse2.bf.unwrap(Unknown Source) at
com.ibm.ws.ssl.channel.impl.SSLUtils.handleHandsha ke(SSLUtils.java:482)
at
com.ibm.ws.ssl.channel.impl.SSLHandshakeIOCallback .complete(SSLHandshakeIOCallback.java:65)
at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.reque stComplete(WorkQueueManager.java:537)
at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.attem ptIO(WorkQueueManager.java:593)
at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.worke rRun(WorkQueueManager.java:946)
at
com.ibm.ws.tcp.channel.impl.WorkQueueManager$Worke r.run(WorkQueueManager.java:1038)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.j ava:1432)
[13/10/05 07:50:24:878 CDT] 00000048 SystemErr R at
java.lang.Throwable.(Throwable.java:195) [13/10/05 07:50:24:878
CDT] 00000048 SystemErr R at java.lang.Error.(Error.java:49)
[13/10/05 07:50:24:879 CDT] 00000048 SystemErr R at
java.lang.NoClassDefFoundError.(NoClassDefFoundError.java:40)
[13/10/05 07:50:24:879 CDT] 00000048 SystemErr R at
javax.crypto.KeyAgreement.getInstance(Unknown Source) [13/10/05
07:50:24:879 CDT] 00000048 SystemErr R at com.ibm.jsse2.o.a(Unknown
Source) [13/10/05 07:50:24:880 CDT] 00000048 SystemErr R at
com.ibm.jsse2.x.a(Unknown Source) [13/10/05 07:50:24:880 CDT] 00000048
SystemErr R at com.ibm.jsse2.x.a(Unknown Source) [13/10/05 07:50:24:880
CDT] 00000048 SystemErr R at com.ibm.jsse2.v.a(Unknown Source)
[13/10/05 07:50:24:881 CDT] 00000048 SystemErr R at
com.ibm.jsse2.bf.a(Unknown Source) [13/10/05 07:50:24:881 CDT] 00000048
SystemErr R at com.ibm.jsse2.bf.unwrap(Unknown Source) [13/10/05
07:50:24:881 CDT] 00000048 SystemErr R at
com.ibm.ws.ssl.channel.impl.SSLUtils.handleHandsha ke(SSLUtils.java:482)
[13/10/05 07:50:24:882 CDT] 00000048 SystemErr R at
com.ibm.ws.ssl.channel.impl.SSLHandshakeIOCallback .complete(SSLHandshakeIOCallback.java:65)
[13/10/05 07:50:24:882 CDT] 00000048 SystemErr R at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.reque stComplete(WorkQueueManager.java:537)
[13/10/05 07:50:24:883 CDT] 00000048 SystemErr R at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.attem ptIO(WorkQueueManager.java:593)
[13/10/05 07:50:24:883 CDT] 00000048 SystemErr R at
com.ibm.ws.tcp.channel.impl.WorkQueueManager.worke rRun(WorkQueueManager.java:946)
[13/10/05 07:50:24:883 CDT] 00000048 SystemErr R at
com.ibm.ws.tcp.channel.impl.WorkQueueManager$Worke r.run(WorkQueueManager.java:1038)
[13/10/05 07:50:24:884 CDT] 00000048 SystemErr R at
com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.j ava:1432)


To my configuration: I have both, jdk 1.3 and jdk 1.4 installed on the
iSeries. In the SystemDefault.properties I have a line
"java.version=1.4"

The missing class should be in the jce.jar, but this I can only find in
the lib-directory of the jdk 1.4 and not in the lib-directory of the
OS400/Java400/lib-tree like I have seen on another machine where
everything is working fine.

Has anyone an idea? Did I forget anything to install?

Thank you very much!

Yours

Arcus