I am getting this error ..please suggest ... - Websphere

This is a discussion on I am getting this error ..please suggest ... - Websphere ; I am receiving this error often in web sphere logs. I don?t have exact idea on this error, does any one have idea on this.. Currently the web sphere using oracle JDBC thin driver adapter 9.2 .. [8/27/07 8:29:48:111 EDT] ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: I am getting this error ..please suggest ...

  1. I am getting this error ..please suggest ...

    I am receiving this error often in web sphere logs. I don?t have exact idea on this error, does any one have idea on this..
    Currently the web sphere using oracle JDBC thin driver adapter 9.2 ..

    [8/27/07 8:29:48:111 EDT] 00000044 ConnectionEve A J2CA0056I: The Connection Manager received a fatal connection error from the Resource Adapter for resource jdbc/plrs-ds. The exception which was received is com.ibm.websphere.ce.cm.StaleConnectionException: No more data to read from socket:java.sql.SQLException: No more data to read from socket
    [8/27/07 8:29:48:286 EDT] 00000044 LocalTranCoor E WLTC0016E: Resource jdbc/plrs-ds failed to complete. Exception stack trace follows: javax.transaction.xa.XAException

    Caused by: com.ibm.websphere.ce.cm.StaleConnectionException: No more data to read from socketDSRA0010E: SQL State = null, Error Code = 17,410



  2. Re: I am getting this error ..please suggest ...

    venkata.kalikivaya@fmr.com wrote:
    > I am receiving this error often in web sphere logs. I don?t have exact idea on this error, does any one have idea on this..
    > Currently the web sphere using oracle JDBC thin driver adapter 9.2 ..
    >
    > [8/27/07 8:29:48:111 EDT] 00000044 ConnectionEve A J2CA0056I: The Connection Manager received a fatal connection error from the Resource Adapter for resource jdbc/plrs-ds. The exception which was received is com.ibm.websphere.ce.cm.StaleConnectionException: No more data to read from socket:java.sql.SQLException: No more data to read from socket
    > [8/27/07 8:29:48:286 EDT] 00000044 LocalTranCoor E WLTC0016E: Resource jdbc/plrs-ds failed to complete. Exception stack trace follows: javax.transaction.xa.XAException
    >
    > Caused by: com.ibm.websphere.ce.cm.StaleConnectionException: No more data to read from socketDSRA0010E: SQL State = null, Error Code = 17,410
    >
    >


    I've seen situations like this when there's a firewall between the
    application server and the database server, and the firewall closes the
    TCP/IP link when there hasn't been recent activity.

    Ken

  3. Re: I am getting this error ..please suggest ...

    Ken Hygh wrote:
    > venkata.kalikivaya@fmr.com wrote:
    >> I am receiving this error often in web sphere logs. I don?t have exact
    >> idea on this error, does any one have idea on this..
    >> Currently the web sphere using oracle JDBC thin driver adapter 9.2 ..
    >>
    >> [8/27/07 8:29:48:111 EDT] 00000044 ConnectionEve A J2CA0056I: The
    >> Connection Manager received a fatal connection error from the Resource
    >> Adapter for resource jdbc/plrs-ds. The exception which was received is
    >> com.ibm.websphere.ce.cm.StaleConnectionException: No more data to read
    >> from socket:java.sql.SQLException: No more data to read from socket
    >> [8/27/07 8:29:48:286 EDT] 00000044 LocalTranCoor E WLTC0016E: Resource
    >> jdbc/plrs-ds failed to complete. Exception stack trace follows:
    >> javax.transaction.xa.XAException
    >>
    >> Caused by: com.ibm.websphere.ce.cm.StaleConnectionException: No more
    >> data to read from socketDSRA0010E: SQL State = null, Error Code = 17,410
    >>
    >>

    >
    > I've seen situations like this when there's a firewall between the
    > application server and the database server, and the firewall closes the
    > TCP/IP link when there hasn't been recent activity.
    >
    > Ken


    Yeah, I won't swear it was the exact same problem, but we were getting
    StaleConnectionExceptions with our Oracle Type 4 DataSource as well. We ended
    up changing the DataSource settings to allow a minimum of 0 connections, IIRC,
    so that all connections were cleaned up when not in use, and this does seem to
    have resolved our problem.

    --
    Doug

  4. Re: I am getting this error ..please suggest ...

    i changed min of 0 connections .Now its working .thanx for solutions.


+ Reply to Thread