I met a problem yesterday: after I upgraded WAS5.1.1.13 to .14 (although I encountered some problems in the process, finally the upgrade completed successfully), the vesioninfo can not work. Below is the error:

F:\Program Files\WebSphere\AppServer\bin>genversionreport
WVER0010I: Copyright (c) IBM Corporation 2002; All rights reserved.
WVER0011I: WebSphere Application Server Release 5.1
WVER0012I: VersionInfo reporter version 1.15.2.1, dated 4/28/04

org.xml.sax.SAXParseException: Content is not allowed in prolog.
at org.apache.xerces.util.ErrorHandlerWrapper.createS AXParseException(Unknown Source)
at org.apache.xerces.util.ErrorHandlerWrapper.fatalEr ror(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportErro r(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportErro r(Unknown Source)
at org.apache.xerces.impl.XMLScanner.reportFatalError (Unknown Source)
at org.apache.xerces.impl.XMLDocumentScannerImpl$Prol ogDispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerI mpl.scanDocument(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse (Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse( Unknown Source)
at com.ibm.websphere.product.xml.BaseFactory.load(Bas eFactory.java:191)
at com.ibm.websphere.product.xml.BaseFactory.load(Bas eFactory.java:173)
at com.ibm.websphere.product.history.WASHistory.loadH istory(WASHistory.java:547)
at com.ibm.websphere.product.history.WASHistory.initi alize(WASHistory.java:510)
at com.ibm.websphere.product.history.WASHistory.(WASHistory.java:444)
at com.ibm.websphere.product.VersionInfo.setProduct(V ersionInfo.java:515)
at com.ibm.websphere.product.VersionInfo.runReport(Ve rsionInfo.java:807)
at com.ibm.websphere.product.VersionInfo.runReport(Ve rsionInfo.java:750)
at com.ibm.websphere.product.VersionInfo.runReport(Ve rsionInfo.java:695)
at com.ibm.websphere.product.VersionInfo.main(Version Info.java:419)
at com.ibm.websphere.product.VersionInfo.main(Version Info.java:262)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:85)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:58)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:60)
at java.lang.reflect.Method.invoke(Method.java:391)
at com.ibm.ws.bootstrap.WSLauncher.run(WSLauncher.jav a:222)
at java.lang.Thread.run(Thread.java:567)
WVER0004E: Error writing version report to versionReport.html: java.lang.NullPointerException

Looks like the issue was caused by a corrupt XML file, right? any help will be appreciated.