EJB2 - Application in WAS 5.0 will it run in WAS6.1? - Websphere

This is a discussion on EJB2 - Application in WAS 5.0 will it run in WAS6.1? - Websphere ; Hi all, We have been asked to help in a project that is using ejb2 on was5.0.We need to setup development environments and were wondering if we could use WAS6.1 and still be backwardly compatible with was5.0? We haven't used ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: EJB2 - Application in WAS 5.0 will it run in WAS6.1?

  1. EJB2 - Application in WAS 5.0 will it run in WAS6.1?

    Hi all,

    We have been asked to help in a project that is using ejb2 on was5.0.We need to setup development environments and were wondering if we could use WAS6.1 and still be backwardly compatible with was5.0?

    We haven't used a lot of ejb2 stuff before but the project makes use of simple session and entity beans with CMP. Are the deploymnets descriptors etc the same between the versions or are there enough differences to be a problem?

    regards

    Mark

  2. Re: EJB2 - Application in WAS 5.0 will it run in WAS6.1?

    EJB apps written to WAS 5.0 are fully upward-compatible with WAS 6.1. It is not even necessary to rerun the deploy tool; just install your app from 5.0 and run.

    mark@jumpingbean.co.za wrote:
    > Hi all,
    >
    > We have been asked to help in a project that is using ejb2 on was5.0.We need to setup development environments and were wondering if we could use WAS6.1 and still be backwardly compatible with was5.0?
    >
    > We haven't used a lot of ejb2 stuff before but the project makes use of simple session and entity beans with CMP. Are the deploymnets descriptors etc the same between the versions or are there enough differences to be a problem?
    >
    > regards
    >
    > Mark


  3. Re: EJB2 - Application in WAS 5.0 will it run in WAS6.1?

    thanks for the info. I haven't worked much with websphere before. If I carry out modifications and run the app on was6.1 and then delpoy to was5.0 will there be anything I need to be aware of? i.e is was5.0 upwardly compatible with 6.1? I won't be taking advantage of any of the new advanced features of 6.1.

    thanks again.

    regards

    Mark


  4. Re: EJB2 - Application in WAS 5.0 will it run in WAS6.1?

    Well...you'd asked whether 5.0 was upward-compatible with 6.1, and it is. I'm assuming you're asking now whether 6.1 is backward-compatible with 5.0, and that's not officially supported. (Actually, 5.0 itself isn't officially supported anymore.)

    That said, as long as your apps don't use any features that aren't available in 5.0, they will probably run OK even if built using a 6.1 environment...but it's not guaranteed to work, so you'd want to test carefully.

    mark@jumpingbean.co.za wrote:
    > thanks for the info. I haven't worked much with websphere before. If I carry out modifications and run the app on was6.1 and then delpoy to was5.0 will there be anything I need to be aware of? i.e is was5.0 upwardly compatible with 6.1? I won't be taking advantage of any of the new advanced features of 6.1.
    >
    > thanks again.
    >
    > regards
    >
    > Mark
    >


+ Reply to Thread