Silent install fails - Websphere

This is a discussion on Silent install fails - Websphere ; I am trying to perform a silent install of WAS V6.1 on Windows 2000 using the following command: install.exe -options "C:\Temp\myresponsefile.txt" -silent -log # !C:\Temp\log.txt @ALL Anyone have any ideas why this is failing? The install fails with the following ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: Silent install fails

  1. Silent install fails

    I am trying to perform a silent install of WAS V6.1 on Windows 2000 using the following command:
    install.exe -options "C:\Temp\myresponsefile.txt" -silent -log # !C:\Temp\log.txt @ALL

    Anyone have any ideas why this is failing?

    The install fails with the following message in the log.txt file:

    com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction, err, null
    (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction, err, null
    (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction, err, java.lang.NullPointerException
    at com.ibm.ws.install.ni.framework.registry.NIFRegist ryOfferingEntry.hashCode(NIFRegistryOfferingEntry. java:270)
    at com.ibm.ws.install.ni.framework.aspects.logging.Jo inPointLogUtils.appendArgList(JoinPointLogUtils.ja va:228)
    at com.ibm.ws.install.ni.framework.aspects.logging.Jo inPointLogUtils.logEntry(JoinPointLogUtils.java:53 )
    at com.ibm.ws.install.ni.framework.aspects.logging.Ab stractInstallerLogging.ajc$before$com_ibm_ws_insta ll_ni_framework_aspects_logging_AbstractInstallerL ogging$5$7b38cfba(AbstractInstallerLogging.aj:295)
    at com.ibm.ws.install.ni.framework.registry.NIFRegist ryOfferingEntry.doesThisOfferingEntryHasTheseAttri butes(NIFRegistryOfferingEntry.java)
    at com.ibm.ws.install.ni.framework.registry.NIFRegist ry.getOfferingLocationURIArrayByOffering(NIFRegist ry.java:250)
    at com.ibm.ws.install.ni.framework.registry.NIFRegist ry.getOfferingLocationStringArrayByOffering(NIFReg istry.java:284)
    at com.ibm.ws.install.ni.framework.registry.NIFRegist ryPlugin.getOfferingLocatonStringArrayByOffering(N IFRegistryPlugin.java:187)
    at com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction.getCoexistenceInstallRoots(Dete ctCoexistenceAndUpgradeAction.java:349)
    at com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction.execute(DetectCoexistenceAndUpg radeAction.java:71)
    at com.installshield.wizard.StandardWizardListener.ex ecute(StandardWizardListener.java:123)
    at com.installshield.wizard.StandardWizardListener.cu rrentBeanChanged(StandardWizardListener.java:106)
    at com.installshield.wizard.Wizard$RunThread.run(Wiza rd.java:1568)

    (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.SettleNIFRegist ryAction, msg1, Current install/uninstall process failed.
    (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.SetExitCodeActi on, msg1, CWUPI0000I: EXITCODE=1
    (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.ISMPLogSuccessM essageAction, msg1, INSTCONFFAILED




  2. Re: Silent install fails

    It appears from your registry that WAS believes it is still installed
    in C:\WASv61, which most likely means the uninstall process did not
    complete successfully. If you install to a different directory (as
    determined in the response file), it should install properly. The
    other option is deleting any files from the C:\WASv61 directory, and
    deleting those lines in the nifregistry that reference it (12 lines
    near the bottom of .nifregistry)



    On Aug 7, 10:56 am, wrote:
    > I am trying to perform a silent install of WAS V6.1 on Windows 2000 using the following command:
    > install.exe -options "C:\Temp\myresponsefile.txt" -silent -log # !C:\Temp\log.txt @ALL
    >
    > Anyone have any ideas why this is failing?
    >
    > The install fails with the following message in the log.txt file:
    >
    > com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction, err, null
    > (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction, err, null
    > (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction, err, java.lang.NullPointerException
    > at com.ibm.ws.install.ni.framework.registry.NIFRegist ryOfferingEntry.hashCode(NIFRegistryOfferingEntry. java:270)
    > at com.ibm.ws.install.ni.framework.aspects.logging.Jo inPointLogUtils.appendArgList(JoinPointLogUtils.ja va:228)
    > at com.ibm.ws.install.ni.framework.aspects.logging.Jo inPointLogUtils.logEntry(JoinPointLogUtils.java:53 )
    > at com.ibm.ws.install.ni.framework.aspects.logging.Ab stractInstallerLogging.ajc$before$com_ibm_ws_insta ll_ni_framework_aspects_logging_AbstractInstallerL ogging$5$7b38cfba(AbstractInstallerLogging.aj:295)
    > at com.ibm.ws.install.ni.framework.registry.NIFRegist ryOfferingEntry.doesThisOfferingEntryHasTheseAttri butes(NIFRegistryOfferingEntry.java)
    > at com.ibm.ws.install.ni.framework.registry.NIFRegist ry.getOfferingLocationURIArrayByOffering(NIFRegist ry.java:250)
    > at com.ibm.ws.install.ni.framework.registry.NIFRegist ry.getOfferingLocationStringArrayByOffering(NIFReg istry.java:284)
    > at com.ibm.ws.install.ni.framework.registry.NIFRegist ryPlugin.getOfferingLocatonStringArrayByOffering(N IFRegistryPlugin.java:187)
    > at com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction.getCoexistenceInstallRoots(Dete ctCoexistenceAndUpgradeAction.java:349)
    > at com.ibm.ws.install.ni.ismp.actions.DetectCoexisten ceAndUpgradeAction.execute(DetectCoexistenceAndUpg radeAction.java:71)
    > at com.installshield.wizard.StandardWizardListener.ex ecute(StandardWizardListener.java:123)
    > at com.installshield.wizard.StandardWizardListener.cu rrentBeanChanged(StandardWizardListener.java:106)
    > at com.installshield.wizard.Wizard$RunThread.run(Wiza rd.java:1568)
    >
    > (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.SettleNIFRegist ryAction, msg1, Current install/uninstall process failed.
    > (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.SetExitCodeActi on, msg1, CWUPI0000I: EXITCODE=1
    > (Aug 7, 2007 10:51:19 AM), Process, com.ibm.ws.install.ni.ismp.actions.ISMPLogSuccessM essageAction, msg1, INSTCONFFAILED




  3. Re: Silent install fails

    I got the same error.

    How do you fix this?

  4. Re: Silent install fails

    I seem to recall something about this in the APARs. Something about Fixpack 9 failing to install. Try editing your response file to disable OS prereq checking. You might also want to try building a customized installation package. That way you can test it out multiple times without actually impacting your server (you just delete the failures). Also, make sure that your response file has the right things set - especially if you edited it by hand. I had trouble in the scripting and automation class a couple of times until I re-edited my response file and made sure the profiles were created in another file.

    You probably already checked these things, but hey, it never hurts to look, right?

  5. Re: Silent install fails

    Hi JCR,
    It seems to me that the installer is not able to check for your current installed software.
    Do you have a WAS already installed on the machine?
    If so, is it properly installed? Can you verify in the registry if WAS is there as well.
    Also, please check if you had an "impartial success" install. I would suggest to uninstall any broken installs of WAS and then retrying.

    Furthermore, install as root and ignore the pre-req check by uncommenting the line:
    -OPT disableOSPrereqChecking="true"

    You can also use the option "-is:javaconsole" with your command for silent install to help you see all the java messages via console.

    Here are some useful links:
    Silent install of 6.1 - http://publib.boulder.ibm.com/infoce...runSilent.html
    Response file details - http://publib.boulder.ibm.com/infoce...file_nd61.html

    Let me know if that works or at least identifies your problem.
    Salman

  6. Re: Silent install fails

    FYI - WebSphere Application Server V6.1 Base edition installer shows "null" error when installing on a system that has WebSphere Application Server V6.1 Trial edition: http://www-01.ibm.com/support/docvie...id=swg21269226

    Salman

+ Reply to Thread