WAS6 Connection to Deployment Manager - Websphere

This is a discussion on WAS6 Connection to Deployment Manager - Websphere ; We are trying to connect to a remote Deployment Manager but the error below keeps coming up. Has anyone seen this before. Everything worked find on WAS5. com.ibm.websphere.management.exception.ConnectorEx ception: ADMC0053E: The system cannot create a SOAP connector to connect to ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: WAS6 Connection to Deployment Manager

  1. WAS6 Connection to Deployment Manager

    We are trying to connect to a remote Deployment Manager but the error below keeps coming up. Has anyone seen this before. Everything worked find on WAS5.

    com.ibm.websphere.management.exception.ConnectorEx ception:
    ADMC0053E: The system cannot create a SOAP connector to connect to host was6ndu1.bcbsfl.com at port 5643 with SOAP connector security enabled.

    java.lang.reflect.InvocationTargetException: null

    com.ibm.websphere.management.exception.ConnectorNo tAvailableException: [SOAPException: faultCode=SOAP-ENV:Client; msg=Error opening socket: java.net.SocketException; targetException=java.lang.IllegalArgumentException : Error opening socket: java.net.SocketException]
    org.apache.soap.SOAPException: Error opening socket: java.net.SocketException


  2. Re: WAS6 Connection to Deployment Manager

    Hi, How are your trying to connect? With wsadmin.sh? Some other way?

    Brian

  3. Re: WAS6 Connection to Deployment Manager

    Thanks for your reply Brain.
    We have developed an in house application that uses the AdminClient api.
    After loading the Admin Client with such properties as
    Deployment Manager
    PORT
    Keystore/Password
    Truststore/Password
    etc...

    Then we use AdminClientFactory.createAdminClient to get the Admin Client.
    A ConnectorException is thrown from the createAdminClient method.


  4. Re: WAS6 Connection to Deployment Manager

    john.peters@bcbsfl.com wrote:
    > We are trying to connect to a remote Deployment Manager but the error below keeps coming up. Has anyone seen this before. Everything worked find on WAS5.
    >
    > com.ibm.websphere.management.exception.ConnectorEx ception:
    > ADMC0053E: The system cannot create a SOAP connector to connect to host was6ndu1.bcbsfl.com at port 5643 with SOAP connector security enabled.
    >
    > java.lang.reflect.InvocationTargetException: null
    >
    > com.ibm.websphere.management.exception.ConnectorNo tAvailableException: [SOAPException: faultCode=SOAP-ENV:Client; msg=Error opening socket: java.net.SocketException; targetException=java.lang.IllegalArgumentException : Error opening socket: java.net.SocketException]
    > org.apache.soap.SOAPException: Error opening socket: java.net.SocketException
    >


    Wrong port number? firewall?
    Ken

  5. Re: WAS6 Connection to Deployment Manager

    Verified all the above

  6. Re: WAS6 Connection to Deployment Manager

    On Aug 7, 12:24 pm, Ken Hygh wrote:
    > john.pet...@bcbsfl.com wrote:
    > > We are trying to connect to a remote Deployment Manager but the error below keeps coming up. Has anyone seen this before. Everything worked find on WAS5.

    >
    > > com.ibm.websphere.management.exception.ConnectorEx ception:
    > > ADMC0053E: The system cannot create a SOAP connector to connect to host was6ndu1.bcbsfl.com at port 5643 with SOAP connector security enabled.

    >
    > > java.lang.reflect.InvocationTargetException: null

    >
    > > com.ibm.websphere.management.exception.ConnectorNo tAvailableException: [SOAPException: faultCode=SOAP-ENV:Client; msg=Error opening socket: java.net.SocketException; targetException=java.lang.IllegalArgumentException : Error opening socket: java.net.SocketException]
    > > org.apache.soap.SOAPException: Error opening socket: java.net.SocketException

    >
    > Wrong port number? firewall?
    > Ken


    soap.client.props


  7. Re: WAS6 Connection to Deployment Manager

    john.peters@bcbsfl.com wrote:
    > Verified all the above


    Show us your code, XXXX out all passwords etc.
    Ken

  8. Re: WAS6 Connection to Deployment Manager

    We found the problem.
    Turns out the user/pass were not being auth.
    We only found this out by debug on.


+ Reply to Thread