Can not start my app - Websphere

This is a discussion on Can not start my app - Websphere ; Hello, I am having a problem with starting up my app since I enabled the global security and disable the application server security. The error is: Server xxx failed to start becasue of the following exception com.ibm.ws.security.registry.unix.UnixRegistryExce ption: permission denied: ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: Can not start my app

  1. Can not start my app


    Hello,

    I am having a problem with starting up my app since I enabled the global security
    and disable the application server security.

    The error is:

    Server xxx failed to start becasue of the following exception com.ibm.ws.security.registry.unix.UnixRegistryExce ption: permission denied: must be run as 'root'

    Any idea?


  2. Re: Can not start my app

    gmanavipour@cds.com wrote:
    > Hello,
    >
    > I am having a problem with starting up my app since I enabled the global security
    > and disable the application server security.
    >
    > The error is:
    >
    > Server xxx failed to start becasue of the following exception com.ibm.ws.security.registry.unix.UnixRegistryExce ption: permission denied: must be run as 'root'
    >
    > Any idea?
    >


    You set up global security to use local OS registry, which is only
    supported if the appserver runs as Root.

  3. Re: Can not start my app

    Thanks...I logged on as root to the server and tried to start my app using ./startServer.sh xxx but still I get the same error. How can I start my app as root?

  4. Re: Can not start my app

    gmanavipour@cds.com wrote:
    > Thanks...I logged on as root to the server and tried to start my app using ./startServer.sh xxx but still I get the same error. How can I start my app as root?


    edit
    /profiles//config/cells//nodes//servers//server.xml,
    in the element, make sure 'runAsUser' is set to root. It may
    have been set to something else.

    Ken

  5. Re: Can not start my app

    Great..that worked. thanks alot

+ Reply to Thread