WAS V 5.1 - WebAppErrorReport & IllegalStateException no contenttype - Websphere

This is a discussion on WAS V 5.1 - WebAppErrorReport & IllegalStateException no contenttype - Websphere ; Hi All We have a problem in WebSphere Application Server version 5.1 environment. There is a big stack trace entry in the System out log file as soon as the application is up and running on WAS 5.1. Can anyone ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: WAS V 5.1 - WebAppErrorReport & IllegalStateException no contenttype

  1. WAS V 5.1 - WebAppErrorReport & IllegalStateException no contenttype

    Hi All

    We have a problem in WebSphere Application Server version 5.1 environment.
    There is a big stack trace entry in the System out log file as soon as the application is up and running on WAS 5.1.

    Can anyone give us any clue to the following errors?

    1. Error Page Exception: : com.ibm.ws.webcontainer.webapp.WebAppErrorReport: -6
    at com.ibm.ws.webcontainer.webapp.WebApp.handleError( WebApp.java:1079)
    at com.ibm.ws.webcontainer.webapp.WebApp.sendError(We bApp.java:897)
    at com.ibm.ws.webcontainer.srt.WebAppInvoker.doForwar d(WebAppInvoker.java:185)
    at com.ibm.ws.webcontainer.srt.WebAppInvoker.handleIn vocationHook(WebAppInvoker.java:276)
    at com.ibm.ws.webcontainer.cache.invocation.CachedInv ocation.handleInvocation(CachedInvocation.java:71)

    2. Unable to report exception to client: java.lang.IllegalStateException: no Content-Type was specified

    at com.ibm.ws.http.HttpResponse.writeHeaders(HttpResp onse.java:273)
    at com.ibm.ws.http.ResponseStream.writeHeaders(Respon seStream.java:234)
    at com.ibm.ws.http.ResponseStream.flushBuffer(Respons eStream.java:203)
    at com.ibm.ws.http.ResponseStream.flush(ResponseStrea m.java:297)
    at com.ibm.ws.io.WriteStream.flush(WriteStream.java:1 39)

    Its very urgent, your help will be greatly appreciated.

    with regards,
    Satya




  2. Re: WAS V 5.1 - WebAppErrorReport & IllegalStateException no content type

    (1) Looks like an applicative error. Isn't the complete stacktrace more
    informative ?

    (2) http://www-1.ibm.com/support/docview...id=swg1PK16703

    > Its very urgent, your help will be greatly appreciated.


    Mind you, this is not a place for urgent support. Only volunteers contribute
    here.


+ Reply to Thread