When I apply WAS 6.0 RP, I get a IVT failed (error code 3) in thelogs. - Websphere

This is a discussion on When I apply WAS 6.0 RP, I get a IVT failed (error code 3) in thelogs. - Websphere ; If you see this: [2007/05/08 08:28:55:779] ALG00128I: Executing command: ./apachectl start. [2007/05/08 08:28:57:571] ALG00133I: Starting installation verification test. /opt/IBM/WebSphere/AppServer/bin/ivt.sh server1 Store2Profile /opt/IBM/SIF/java142/jre/bin/java -cp /opt/IBM/SIF/utility/SifUtility. jar:/opt/IBM/SIF/utility:. com.ibm.sif.utility.FindString /opt/IBM/SIF/logs/WasIvt.log IVTL0070I Searching for [2007/05/08 08:29:02:420] ALG00107E: Installation verfication test failed. Return code is ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: When I apply WAS 6.0 RP, I get a IVT failed (error code 3) in thelogs.

  1. When I apply WAS 6.0 RP, I get a IVT failed (error code 3) in thelogs.

    If you see this:

    [2007/05/08 08:28:55:779] ALG00128I: Executing command: ./apachectl
    start.
    [2007/05/08 08:28:57:571] ALG00133I: Starting installation verification
    test.
    /opt/IBM/WebSphere/AppServer/bin/ivt.sh server1 Store2Profile
    /opt/IBM/SIF/java142/jre/bin/java -cp /opt/IBM/SIF/utility/SifUtility.
    jar:/opt/IBM/SIF/utility:. com.ibm.sif.utility.FindString
    /opt/IBM/SIF/logs/WasIvt.log IVTL0070I
    Searching for
    [2007/05/08 08:29:02:420] ALG00107E: Installation verfication test
    failed. Return code is 3.
    Shows /opt/IBM/SIF/logs/WasIvt.log
    Java.lang.ClassNotFoundException: com.ibm.websphere.ivt.client.IVTClient
    at java.net.URLClassLoader.findClass(URLClassLoader.j ava:376)
    at com.ibm.ws.bootstrap.ExtClassLoader.findClass(ExtC lassLoader.
    java:106)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:5 72)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:5 04)
    at com.ibm.ws.bootstrap.WSLauncher.run(WSLauncher.jav a:194)
    at java.lang.Thread.run(Thread.java:568)

    It means that "export LD_ASSUME_KERNEL=2.4.18" has been set. You need to clear this variable out and then it'll patch successfully.



    Albert T. Wong
    http://www.ibm.com/developerworks/bl...cOpenComputing

  2. Re: When I apply WAS 6.0 RP, I get a IVT failed (error code 3) in the logs.

    Hi,
    To which file do you propose this change to be made in?

    Jean Abraham

    On May 22, 8:52 pm, "Albert T. Wong" wrote:
    > If you see this:
    >
    > [2007/05/08 08:28:55:779] ALG00128I: Executing command: ./apachectl
    > start.
    > [2007/05/08 08:28:57:571] ALG00133I: Starting installation verification
    > test.
    > /opt/IBM/WebSphere/AppServer/bin/ivt.sh server1 Store2Profile
    > /opt/IBM/SIF/java142/jre/bin/java -cp /opt/IBM/SIF/utility/SifUtility.
    > jar:/opt/IBM/SIF/utility:. com.ibm.sif.utility.FindString
    > /opt/IBM/SIF/logs/WasIvt.log IVTL0070I
    > Searching for
    > [2007/05/08 08:29:02:420] ALG00107E: Installation verfication test
    > failed. Return code is 3.
    > Shows /opt/IBM/SIF/logs/WasIvt.log
    > Java.lang.ClassNotFoundException: com.ibm.websphere.ivt.client.IVTClient
    > at java.net.URLClassLoader.findClass(URLClassLoader.j ava:376)
    > at com.ibm.ws.bootstrap.ExtClassLoader.findClass(ExtC lassLoader.
    > java:106)
    > at java.lang.ClassLoader.loadClass(ClassLoader.java:5 72)
    > at java.lang.ClassLoader.loadClass(ClassLoader.java:5 04)
    > at com.ibm.ws.bootstrap.WSLauncher.run(WSLauncher.jav a:194)
    > at java.lang.Thread.run(Thread.java:568)
    >
    > It means that "export LD_ASSUME_KERNEL=2.4.18" has been set. You need to clear this variable out and then it'll patch successfully.
    >
    > Albert T. Wonghttp://www.ibm.com/developerworks/blogs/page/PragmaticOpenComputing




+ Reply to Thread