Hi All,

I am facing a problem while generating WSDL file using Java2WSDL WebSphere ant task.
I have used the following script in "build.xml"









generatin
className="com.test.Add"
implClass="com.test.AddImpl"
namespace="http://com.test"
location="http://localhost:9080/CrossReferenceSerive/">
package="com.test"/>







and the "maven.xml" has the following data







dir="${basedir}" />
hi "${basedir}"




The error I am geting was

__ __
| \/ |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \ ~ intelligent projects ~
|_| |_\__,_|\_/\___|_||_| v. 1.0

build:start:

clean:clean:
[delete] Deleting directory C:\Naresh\RAD_DB\TestWebService\target

clean:

war:init:

javarepare-filesystem:
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\classes

java:compile:
[echo] Compiling to C:\Naresh\RAD_DB\TestWebService/target/classes
[javac] Compiling 3 source files to C:\Naresh\RAD_DB\TestWebService\target\classes

java:jar-resources:

testrepare-filesystem:
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\test-classes
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\test-reports

test:test-resources:

test:compile:
[echo] No test source files to compile.

test:test:
[echo] No tests to run.

war:webapp:
[echo] Assembling webapp TestWebService
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\TestWebServ ice
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\TestWebServ ice\WEB-INF
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\TestWebServ ice\WEB-INF\lib
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\TestWebServ ice\WEB-INF\tld
[mkdir] Created dir: C:\Naresh\RAD_DB\TestWebService\target\TestWebServ ice\WEB-INF\classes
[copy] Copying 3 files to C:\Naresh\RAD_DB\TestWebService\target\TestWebServ ice\WEB-INF\classes
[exec] Buildfile: build.xml
[exec]
[exec] createwsdd:
[exec] [echo] generatin
[exec] [Java2WSDLTask] java.lang.NoClassDefFoundError: org/eclipse/jem/java/JavaHelpers
[exec] [Java2WSDLTask] at com.ibm.ws.webservices.tools.ant.Java2WSDL.execute (Java2WSDL.java:122)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Task.perform(Task.java:341)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Target.execute(Target.java:30 9)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Target.performTasks(Target.ja va:336)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Project.executeTarget(Project .java:1339)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Project.executeTargets(Projec t.java:1255)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Main.runBuild(Main.java:609)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Main.start(Main.java:196)
[exec] [Java2WSDLTask] at org.apache.tools.ant.Main.main(Main.java:235)
[exec]
[exec] BUILD FAILED
[exec] file:C:/Naresh/RAD_DB/TestWebService/build.xml:14: Error while running com.ibm.websphere.ant.tasks.Java2WSDL
[exec]
[exec] Total time: 0 seconds
[echo] hi "C:\Naresh\RAD_DB\TestWebService"

war:war:
[echo] Building WAR TestWebService
[jar] Building jar: C:\Naresh\RAD_DB\TestWebService\target\TestWebServ ice.war
Copying: from 'C:\Naresh\RAD_DB\TestWebService\target\TestWebSer vice.war' to: 'c:\RADMaven\repositiory\TestWebService\wars\TestW ebService-1.0.war'
Copying: from 'C:\Naresh\RAD_DB\TestWebService\project.xml' to: 'c:\RADMaven\repositiory\TestWebService\poms\TestW ebService-1.0.pom'
BUILD SUCCESSFUL
Total time: 4 seconds
Finished at: Fri Apr 27 00:35:27 EDT 2007


Please help me.

Thanks in advance,
Naresh