Cannot login to ND Admin Console - Websphere

This is a discussion on Cannot login to ND Admin Console - Websphere ; Hi all, I have a problem to login to admin console in network deployment when i login, the page display error (400 or maybe 500?). also after the ND is started, the log shows: [4/23/07 10:26:28:242 WIT] 150a0 WsServer A ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Cannot login to ND Admin Console

  1. Cannot login to ND Admin Console



    Hi all,

    I have a problem to login to admin console in network deployment
    when i login, the page display error (400 or maybe 500?).

    also after the ND is started, the log shows:

    [4/23/07 10:26:28:242 WIT] 150a0 WsServer A WSVR0001I: Server dmgr open for e-business
    [4/23/07 10:26:30:285 WIT] 1da77f5 DiscoveryMBea I ADMD0023I: Process discovered (name: portal2, type: NodeAgent, pid: 1549)
    [4/23/07 10:26:31:926 WIT] 12d2e33 DiscoveryMBea I ADMD0023I: Process discovered (name: portal1, type: NodeAgent, pid: 3950)
    [4/23/07 10:26:35:022 WIT] 912f10 RoleBasedAuth E SECJ0306E: No received or invocation credential exist on the thread. The Role based authorization check will not have an accessId of the caller to check. The parameters are: access check method extract:java.lang.String on resource ConfigRepository and module ConfigRepository. The stack trace is java.lang.Exception: dump thread stack for debugging
    at com.ibm.ws.security.role.RoleBasedAuthorizerImpl.c heckAccess(RoleBasedAuthorizerImpl.java:291)
    at com.ibm.ws.management.repository.FileRepository.ch eckInvocationPermission(FileRepository.java:2460)
    at com.ibm.ws.management.repository.FileRepository.ex tract(FileRepository.java:1044)
    ...
    ...
    ...

    [4/23/07 10:26:35:038 WIT] 912f10 RoleBasedAuth A SECJ0305I: Role based authorization check failed for security name , accessId no_cred_no_access_id while invoking method extract:java.lang.String on resource ConfigRepository and module ConfigRepository.
    [4/23/07 10:26:35:053 WIT] 912f10 WorkSpaceMast E WKSP0012E: Exception while extracting cells/portal2Network/clusters/PortalCluster/cluster-pme.xml from ConfigRepository--com.ibm.websphere.management.exception.RepositoryE xception: null is not in required role to read configuration data
    at com.ibm.ws.management.repository.FileRepository.ch eckInvocationPermission(FileRepository.java:2467)
    ...
    ...

    when i try to login, the log shows :

    [4/23/07 14:29:41:720 WIT] 1ead8c7 WebGroup E SRVE0026E: [Servlet Error]-[]: java.lang.NullPointerException
    at org.apache.jsp._console._jspService(_console.java: 172)
    ...
    ...


    I wish you guys could give me a clue. Thanks,


    **yahya**

  2. Re: Cannot login to ND Admin Console

    yahya@anabatictech.co.id wrote:
    >
    > Hi all,
    >
    > I have a problem to login to admin console in network deployment
    > when i login, the page display error (400 or maybe 500?).
    >
    > also after the ND is started, the log shows:
    >
    > [4/23/07 10:26:28:242 WIT] 150a0 WsServer A WSVR0001I: Server dmgr open for e-business
    > [4/23/07 10:26:30:285 WIT] 1da77f5 DiscoveryMBea I ADMD0023I: Process discovered (name: portal2, type: NodeAgent, pid: 1549)
    > [4/23/07 10:26:31:926 WIT] 12d2e33 DiscoveryMBea I ADMD0023I: Process discovered (name: portal1, type: NodeAgent, pid: 3950)
    > [4/23/07 10:26:35:022 WIT] 912f10 RoleBasedAuth E SECJ0306E: No received or invocation credential exist on the thread. The Role based authorization check will not have an accessId of the caller to check. The parameters are: access check method extract:java.lang.String on resource ConfigRepository and module ConfigRepository. The stack trace is java.lang.Exception: dump thread stack for debugging
    > at com.ibm.ws.security.role.RoleBasedAuthorizerImpl.c heckAccess(RoleBasedAuthorizerImpl.java:291)
    > at com.ibm.ws.management.repository.FileRepository.ch eckInvocationPermission(FileRepository.java:2460)
    > at com.ibm.ws.management.repository.FileRepository.ex tract(FileRepository.java:1044)
    > ..
    > ..
    > ..
    >
    > [4/23/07 10:26:35:038 WIT] 912f10 RoleBasedAuth A SECJ0305I: Role based authorization check failed for security name , accessId no_cred_no_access_id while invoking method extract:java.lang.String on resource ConfigRepository and module ConfigRepository.
    > [4/23/07 10:26:35:053 WIT] 912f10 WorkSpaceMast E WKSP0012E: Exception while extracting cells/portal2Network/clusters/PortalCluster/cluster-pme.xml from ConfigRepository--com.ibm.websphere.management.exception.RepositoryE xception: null is not in required role to read configuration data
    > at com.ibm.ws.management.repository.FileRepository.ch eckInvocationPermission(FileRepository.java:2467)
    > ..
    > ..
    >
    > when i try to login, the log shows :
    >
    > [4/23/07 14:29:41:720 WIT] 1ead8c7 WebGroup E SRVE0026E: [Servlet Error]-[]: java.lang.NullPointerException
    > at org.apache.jsp._console._jspService(_console.java: 172)
    > ..
    > ..
    >
    >
    > I wish you guys could give me a clue. Thanks,
    >
    >
    > **yahya**


    Um, ok. Clue #1: it's important to give all relevant information when
    asking for help. There's a big difference between HTTP Response codes
    400 & 500.

    Clue #2: it looks like you may have security turned on, and there's some
    issue talking to your user repository.

    Ken

  3. Re: Cannot login to ND Admin Console


  4. Re: Cannot login to ND Admin Console

    On Apr 24, 12:24 pm, wrote:
    > I have a problem to login to admin console in network deployment
    > when i login, the page display error (400 or maybe 500?).
    >
    > also after the ND is started, the log shows:
    >

    [...]
    > [4/23/07 10:26:35:022 WIT] 912f10 RoleBasedAuth E SECJ0306E: No received or invocation credential exist on the thread. The Role based authorization check will not have an accessId of the caller to check. The parameters are: access check method extract:java.lang.String on resource ConfigRepository and module ConfigRepository. The stack trace is java.lang.Exception: dump thread stack for debugging
    > at com.ibm.ws.security.role.RoleBasedAuthorizerImpl.c heckAccess(RoleBasedAuthorizerImpl.java:291)
    > at com.ibm.ws.management.repository.FileRepository.ch eckInvocationPermission(FileRepository.java:2460)
    > at com.ibm.ws.management.repository.FileRepository.ex tract(FileRepository.java:1044)


    I would disable global security in your cell (edit cells/${cellname}/
    security.xml, search for enabled=true in the Security element, change
    it to enabled=false and restart the Deployment Manager) and the verify
    if your security settings are good (is your user registry valid, user
    account information correct, ...).

    If you are confident all settings are correct you can re-enable
    security (through the administrative console). It should perform some
    checks to make sure it is actually reachable (the user registry).

    Wkr,
    Sven Vermeulen


+ Reply to Thread