Websphere 6.1.0.5 and Struts 2 (filters not matching - works 100%in Tomcat 5.5) - Websphere

This is a discussion on Websphere 6.1.0.5 and Struts 2 (filters not matching - works 100%in Tomcat 5.5) - Websphere ; Hi, I'm having great difficulty getting a Struts 2 app working in Websphere 6.1. I was at a stage where it would run the Struts 2 filter, but also send a 404 response at the end of the response, which ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Websphere 6.1.0.5 and Struts 2 (filters not matching - works 100%in Tomcat 5.5)

  1. Websphere 6.1.0.5 and Struts 2 (filters not matching - works 100%in Tomcat 5.5)

    Hi,

    I'm having great difficulty getting a Struts 2 app working in Websphere 6.1.
    I was at a stage where it would run the Struts 2 filter, but also send a 404 response at the end of the response, which caused lot's of problems. So I installed the 6.1.0.5 pack and the fix for http://www-1.ibm.com/support/docview...id=swg24014758 . Unfortunately, now all I get now is a 404 error - the Struts2 filter doesn't seem to even get initialised. The struts2-blank.war (which can be downloaded from the struts 2 site) also doesn't work at all.

    Deploying the struts2-blank.war in tomcat 5.5. works like a charm.

    For more detail, please view:
    http://www.nabble.com/-S2--Websphere....html#a9806456

    Please, any tips would be appreciated.
    Thanks.


  2. Re: Websphere 6.1.0.5 and Struts 2 (filters not matching - works100% in Tomcat 5.5)

    Fixed!!

    Had to set the com.ibm.ws.webcontainer.invokefilterscompatibility to true to get the Struts2 and Sitemesh filters to work with 6.1.0.5 along with an interim fix for PK33090.

    More details here:
    http://www.nabble.com/forum/ViewPost...31115&framed=y


+ Reply to Thread