[J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml" - Weblogic

This is a discussion on [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml" - Weblogic ; Hi all! I'm trying to deploy my HelloWorld servlet, so I've created the .war file. When I click Deploy I get the following error: Missing deployment descriptor "WEB-INF/web.xml" at "C:\bea\user_projects\domains\mydomain\myserver\upl oad\HelloWorld.war" But in that folder there's the WEB-INF/web.xml file needed. ...

+ Reply to Thread
Results 1 to 8 of 8

Thread: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

  1. [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Hi all!

    I'm trying to deploy my HelloWorld servlet, so I've created the .war file. When I click Deploy I get the following error:

    Missing deployment descriptor "WEB-INF/web.xml" at "C:\bea\user_projects\domains\mydomain\myserver\upl oad\HelloWorld.war"

    But in that folder there's the WEB-INF/web.xml file needed.
    What am I doing wrong? Help please!:_|

  2. Re: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Hello,

    Can you check the integrity of your web.xml file, make sure its well formed and uses a proper DTD etc.






    HelloWorldServlet
    HelloWorldServlet



    HelloWorldServlet
    *




    Are there are other error messages in your log?

    I just deployed the above on WLS 8.1sp4, in exploded form

    If you are deploying your app in jar form check its contents with jar -tf

    Cheers,
    Hoos

    Message was edited by hoos at Feb 12, 2005 4:28 AM

  3. Re: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Hi,
    I too have the same problem. I checked the web.xml and weblogic.xml file the dtd is perfect but I still get the same error

  4. Re: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Hi,
    I too have the same problem. I checked the web.xmla nd weblogic.xml files.dtds ate perfect. I even checked the contents of jar file.It has the xml files in it. I am still getting the same error.

    Any help is appreciated.

    Thanks,
    Rukmini

  5. Re: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Hello again! Thanks for your reply

    I checked the web.xml file and (I think) it's ok:



    HelloWorld
    HelloWorld



    HelloWorld
    /HelloWorld



    When I created the HelloWorld.war file, I included HelloWorld.class and web.xml, is it wrong? should I put something more(maybe the source file)?

    Cheers

  6. Re: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Hi,

    Could you also check weblogic.xml?

    Specifically the element jsp-descriptors.

    For example:

    I received the same error when my weblogic.xml had specified workingDir to a non-existent directory i.e d:\foo.



    compileCommand
    javac


    workingDir
    d:\foo


    keepgenerated
    true


    Try to comment any elements in weblogic.xml that is either not used or redundant. Another suggestion is to remove the weblogic.xml for this hello world war sample and try to deploy again.

    HTH,
    Venkat

  7. Re: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Hi Venkat,
    I checked my weblogic.xml file and it indeed was pointing to a different directory. I changed it and then deployed it again. I still get the same error.
    Any help is appreciated.

    Thanks,
    Rukmini

  8. Re: [J2EE:160043] Missing deployment descriptor "WEB-INF/web.xml"

    Thank U Venkat and Hoo

    At last it works I had a little bug in my web.xml file

    One more question. Could anybody tell me how to deploy a JSP file using Bea Workshop? which directory-tree should I build?

    Regards

+ Reply to Thread