my first JSF won't work ... why?? - Weblogic

This is a discussion on my first JSF won't work ... why?? - Weblogic ; hi all i used JSF project for the first time on Tomcat server, it was just simple tutorial and it worked very smoothly. But when I tried to deploy it on Weblogic 8.1 it causes an exception and I don't ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: my first JSF won't work ... why??

  1. my first JSF won't work ... why??

    hi all
    i used JSF project for the first time on Tomcat server, it was just simple tutorial and it worked very smoothly. But when I tried to deploy it on Weblogic 8.1 it causes an exception and I don't know what the problem is.
    The exception is as following:

    java.lang.NullPointerException
    at javax.faces.webapp.FacesServlet.init(FacesServlet. java:144)
    at weblogic.servlet.internal.ServletStubImpl$ServletI nitAction.run(ServletStubImpl.java:993)
    at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(AuthenticatedSubject.java:317)
    at weblogic.security.service.SecurityManager.runAs(Se curityManager.java:118)
    at weblogic.servlet.internal.ServletStubImpl.createSe rvlet(ServletStubImpl.java:869)
    at weblogic.servlet.internal.ServletStubImpl.createIn stances(ServletStubImpl.java:848)
    at weblogic.servlet.internal.ServletStubImpl.prepareS ervlet(ServletStubImpl.java:787)
    at weblogic.servlet.internal.ServletStubImpl.getServl et(ServletStubImpl.java:518)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:362)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:305)
    at weblogic.servlet.internal.WebAppServletContext$Ser vletInvocationAction.run(WebAppServletContext.java :6350)
    at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(AuthenticatedSubject.java:317)
    at weblogic.security.service.SecurityManager.runAs(Se curityManager.java:118)
    at weblogic.servlet.internal.WebAppServletContext.inv okeServlet(WebAppServletContext.java:3635)
    at weblogic.servlet.internal.ServletRequestImpl.execu te(ServletRequestImpl.java:2585)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:197)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:170)


    can any body help me here?? please i need this to work very soon.

  2. Re: my first JSF won't work ... why??

    hi...

    u also using JSP and Tomcat???

    me too...

    erm.. just wanna ask u... u know how to use JSP and Tomcat together with Crystal Report9????


    please helps...


    i really new in Crystal Report....




    kianchoong@yahoo.com

+ Reply to Thread