Problem with JSF with WEBLOGIC 8.1 SP3 - Weblogic

This is a discussion on Problem with JSF with WEBLOGIC 8.1 SP3 - Weblogic ; We are trying to get a JSF application working with WEBLOGIC 8.1 SP3. It gives the following error. I researched in the newsgroup and everybody is saying the same thing. Can somebody from weblogic answer this question please. When will ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Problem with JSF with WEBLOGIC 8.1 SP3

  1. Problem with JSF with WEBLOGIC 8.1 SP3

    We are trying to get a JSF application working with WEBLOGIC 8.1 SP3. It gives the following error. I researched in the newsgroup and everybody is saying the same thing. Can somebody from weblogic answer this question please. When will 8.1 SP1 or later work with JSF? This is critical to our company and needs to be resolved pretty soon. PLEASE SOMEBODY FROM WEBLOGIC answer as soon as possible.

    javax.servlet.jsp.JspException: Cannot find FacesContext
    at javax.faces.webapp.UIComponentTag.doStartTag(UICom ponentTag.java:401)

    at com.sun.faces.taglib.jsf_core.ViewTag.doStartTag(V iewTag.java:105)
    at jsp_servlet.__index._jspService(__index.java:192)
    at weblogic.servlet.jsp.JspBase.service(JspBase.java: 33)
    at weblogic.servlet.internal.ServletStubImpl$ServletI nvocationAction.run
    (ServletStubImpl.java:996)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubIm
    pl.java:419)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubIm
    pl.java:315)
    at weblogic.servlet.internal.WebAppServletContext$Ser vletInvocationActio
    n.run(WebAppServletContext.java:6452)
    at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(Authenticate
    dSubject.java:321)
    at weblogic.security.service.SecurityManager.runAs(Se curityManager.java:
    118)
    at weblogic.servlet.internal.WebAppServletContext.inv okeServlet(WebAppSe
    rvletContext.java:3661)
    at weblogic.servlet.internal.ServletRequestImpl.execu te(ServletRequestIm
    pl.java:2630)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:219)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:178)
    >


  2. Re: Problem with JSF with WEBLOGIC 8.1 SP3

    One possible reason for this problem is the way you call
    your JSP. Be sure that you forward to a JSP with the prefix you set in web.xml for the tag .
    For Example, if the setting looks like:

    Faces Servlet
    /faces/*


    you have to forward to any.jsp with:


    I hope it helps you.

    Wahid Bashirazad

+ Reply to Thread