Updrading 8.1 sp3 from 6.1 - Weblogic

This is a discussion on Updrading 8.1 sp3 from 6.1 - Weblogic ; Hello, I'm currently in the process of upgrading my app from WLS 6.1 to 8.1sp3.. I've come across a few problems so far, the latest was related to taglibs and getting rid of the old servlet.jar.. Maybe this next problem ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Updrading 8.1 sp3 from 6.1

  1. Updrading 8.1 sp3 from 6.1

    Hello,

    I'm currently in the process of upgrading my app from WLS 6.1 to 8.1sp3.. I've come across a few problems so far, the latest was related to taglibs and getting rid of the old servlet.jar.. Maybe this next problem is related to taglibs as well, or maybe the controller, i cant get past my index page.. The error message is:

    java.lang.NullPointerException
    at jsp_servlet.__error._jspService(Ljavax.servlet.htt p.HttpServletRequest;Ljavax.servlet.http.HttpServl etResponseV(__error.java:155)
    at weblogic.servlet.jsp.JspBase.service(Ljavax.servle t.ServletRequest;Ljavax.servlet.ServletResponseV(JspBase.java:33)
    at weblogic.servlet.internal.ServletStubImpl$ServletI nvocationAction.run()Ljava.lang.Object;(ServletStu bImpl.java:996)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(Ljavax.servlet.ServletRequest;Ljavax.servlet .ServletResponse;Lweblogic.servlet.internal.Filter ChainImplV(ServletStubImpl.java:419)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(Ljavax.servlet.ServletRequest;Ljavax.servlet .ServletResponseV(ServletStubImpl.java:315)
    at weblogic.servlet.internal.RequestDispatcherImpl.fo rward(Ljavax.servlet.ServletRequest;Ljavax.servlet .ServletResponseV(RequestDispatcherImpl.java:312)
    at com.phsus.spds.framework.Controller.doPost(Ljavax. servlet.http.HttpServletRequest;Ljavax.servlet.htt p.HttpServletResponseV(Controller.java:75)
    at javax.servlet.http.HttpServlet.service(Ljavax.serv let.http.HttpServletRequest;Ljavax.servlet.http.Ht tpServletResponseV(HttpServlet.java:760)
    at javax.servlet.http.HttpServlet.service(Ljavax.serv let.ServletRequest;Ljavax.servlet.ServletResponseV(HttpServlet.java:853)
    at weblogic.servlet.internal.ServletStubImpl$ServletI nvocationAction.run()Ljava.lang.Object;(ServletStu bImpl.java:996)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(Ljavax.servlet.ServletRequest;Ljavax.servlet .ServletResponse;Lweblogic.servlet.internal.Filter ChainImplV(ServletStubImpl.java:419)
    at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(Ljavax.servlet.ServletRequest;Ljavax.servlet .ServletResponseV(ServletStubImpl.java:315)
    at weblogic.servlet.internal.WebAppServletContext$Ser vletInvocationAction.run()Ljava.lang.Object;(WebAp pServletContext.java:6452)
    at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(Lweblogic.security.subject.AbstractSubject; Ljava.security.PrivilegedActionLjava.lang.Object;(AuthenticatedSubject.java:321)
    at weblogic.security.service.SecurityManager.runAs(Lw eblogic.security.acl.internal.AuthenticatedSubject ;Lweblogic.security.acl.internal.AuthenticatedSubj ect;Ljava.security.PrivilegedActionLjava.lang.Object;(SecurityManager.java:118)
    at weblogic.servlet.internal.WebAppServletContext.inv okeServlet(Lweblogic.servlet.internal.ServletReque stImpl;Lweblogic.servlet.internal.ServletResponseI mplV(WebAppServletContext.java:3661)
    at weblogic.servlet.internal.ServletRequestImpl.execu te(Lweblogic.kernel.ExecuteThreadV(ServletRequestImpl.java:2630)
    at weblogic.kernel.ExecuteThread.execute(Lweblogic.ke rnel.ExecuteRequestV(ExecuteThread.java:219)
    at weblogic.kernel.ExecuteThread.run()V(ExecuteThread .java:178)
    at java.lang.Thread.startThreadFromVM(Ljava.lang.Thre adV(Unknown Source)

    Any direction would be great.

    Thanks!

  2. Re: Updrading 8.1 sp3 from 6.1

    Your configured errorpage (error.jsp) throws a NullpointerException.

    So, you should start analyzing this page (with debug statements, ...) first.

    --Stefan

+ Reply to Thread