jsp compilation is buggy - Weblogic

This is a discussion on jsp compilation is buggy - Weblogic ; From: "Sandeep Takhar" Sender: "Sandeep Takhar" Reply-To: "Sandeep Takhar" Subject: jsp compilation is buggy Newsgroups: weblogic.developer.interest.jsp X-User-Info: 207.61.221.28 NNTP-Posting-Host: 207.61.221.28 X-Original-NNTP-Posting-Host: 207.61.221.28 Message-ID: Date: 23 Jul 2003 13:01:35 -0700 X-Trace: newsgroups.bea.com 1058990495 207.61.221.28 (23 Jul 2003 13:01:35 -0700) X-Original-Trace: 23 ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: jsp compilation is buggy

  1. jsp compilation is buggy

    From: "Sandeep Takhar"
    Sender: "Sandeep Takhar"
    Reply-To: "Sandeep Takhar"
    Subject: jsp compilation is buggy
    Newsgroups: weblogic.developer.interest.jsp
    X-User-Info: 207.61.221.28
    NNTP-Posting-Host: 207.61.221.28
    X-Original-NNTP-Posting-Host: 207.61.221.28
    Message-ID: <3f1ee99f$1@newsgroups.bea.com>
    Date: 23 Jul 2003 13:01:35 -0700
    X-Trace: newsgroups.bea.com 1058990495 207.61.221.28 (23 Jul 2003 13:01:35 -0700)
    X-Original-Trace: 23 Jul 2003 13:01:35 -0700, 207.61.221.28
    Organization: BEA NEWS SITE
    Lines: 29
    XPident: Unknown
    Path: newsgroups.bea.com!not-for-mail
    Xref: newsgroups.bea.com weblogic.developer.interest.jsp:11500


    I am using struts and weblogic 8.1 (which has weblogic server 8.1 sp1) & struts
    1.1 final. I am also using the standard sun jdk.

    When I compile a page I get a failure because one of the struts tags that create
    a page scripting variable does not create this scripting variable.

    property="reflectedPropertyToGet" type="java.lang.String"/>

    Normally if I look at the java file I get

    java.lang.String thisIsTheNameOfTheVar = null;
    etc....

    However I'm not.

    If I change to use this:

    property="reflectedPropertyToGet" type="java.lang.String">


    everything works ok.

    I think this is a weblogic.jspc bug. It used to work in 6.1 fine.

    sandeep


  2. Re: jsp compilation is buggy


    Have you found a solution to this? I am experiencing the same behaviour.

    cheers
    dim

    "Sandeep Takhar" wrote:
    >
    >I am using struts and weblogic 8.1 (which has weblogic server 8.1 sp1)
    >& struts
    >1.1 final. I am also using the standard sun jdk.
    >
    >When I compile a page I get a failure because one of the struts tags
    >that create
    >a page scripting variable does not create this scripting variable.
    >
    > >property="reflectedPropertyToGet" type="java.lang.String"/>
    >
    >Normally if I look at the java file I get
    >
    >java.lang.String thisIsTheNameOfTheVar = null;
    >etc....
    >
    >However I'm not.
    >
    >If I change to use this:
    >
    > >property="reflectedPropertyToGet" type="java.lang.String">
    >

    >
    >everything works ok.
    >
    >I think this is a weblogic.jspc bug. It used to work in 6.1 fine.
    >
    >sandeep
    >



  3. Re: jsp compilation is buggy (8.1 SP1)


    For the record. I logged a bug with this and it is a known issue (CR112484).
    I was supplied with a patch for 8.1SP1 that will be included in SP2. If anyone
    else experiences the same issue I suggest asking support for this patch.

    cheers
    dim

    "Dmitri Colebatch" wrote:
    >
    >Have you found a solution to this? I am experiencing the same behaviour.
    >
    >cheers
    >dim
    >
    >"Sandeep Takhar" wrote:
    >>
    >>I am using struts and weblogic 8.1 (which has weblogic server 8.1 sp1)
    >>& struts
    >>1.1 final. I am also using the standard sun jdk.
    >>
    >>When I compile a page I get a failure because one of the struts tags
    >>that create
    >>a page scripting variable does not create this scripting variable.
    >>
    >> >>property="reflectedPropertyToGet" type="java.lang.String"/>
    >>
    >>Normally if I look at the java file I get
    >>
    >>java.lang.String thisIsTheNameOfTheVar = null;
    >>etc....
    >>
    >>However I'm not.
    >>
    >>If I change to use this:
    >>
    >> >>property="reflectedPropertyToGet" type="java.lang.String">
    >>

    >>
    >>everything works ok.
    >>
    >>I think this is a weblogic.jspc bug. It used to work in 6.1 fine.
    >>
    >>sandeep
    >>

    >



+ Reply to Thread