Hi,

Platform : Solaris x86
Weblogic: 8.1 SP3


I'm installing Weblogic server and after configuring a single domain I get the following exception at startup:

The WebLogic Server did not start up properly.

java.lang.UnsatisfiedLinkError: /usr/local/weblogic/weblogic81/server/lib/solaris/libweblogicunix1.so: ld.so.1: /usr/j2se/bin/java: fatal: /usr/local/weblogic/weblogic81/server/lib/solaris/libweblogicunix1.so: wrong ELF data format: ELFDATA2MSB

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.jav a:1560)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java :1485)

at java.lang.Runtime.loadLibrary0(Runtime.java:788)

at java.lang.System.loadLibrary(System.java:834)

at weblogic.platform.Unix.(Unix.java:14)

at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:39)

at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)

at java.lang.reflect.Constructor.newInstance(Construc tor.java:274)

at java.lang.Class.newInstance0(Class.java:308)

at java.lang.Class.newInstance(Class.java:261)

at weblogic.platform.OperatingSystem.getOS(OperatingS ystem.java:116)

at weblogic.t3.srvr.SetUIDManager.init(SetUIDManager. java:51)

at weblogic.t3.srvr.T3Srvr.initializeHere(T3Srvr.java :777)

at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:670 )

at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:344)

at weblogic.Server.main(Server.java:32)

Reason: /usr/local/weblogic/weblogic81/server/lib/solaris/libweblogicunix1.so: ld.so.1: /usr/j2se/bin/java: fatal: /usr/local/weblogic/weblogic81/server/lib/solaris/libweblogicunix1.so: wrong ELF data format: ELFDATA2MSB


I did a quick search on here and the closest explanation I can find as an unsupported version. However I took my installer from here.

http://e-docs.bea.com/platform/suppc...x86/81sp3.html