Problem starting managed server when in STANDBY state. - Weblogic

This is a discussion on Problem starting managed server when in STANDBY state. - Weblogic ; Hi, I have a clustered server with a managed node which is not starting. When the NodeManager and Admin servers start successfully I can see that the managed node in question has been somwhat loaded but is in the 'STANDBY' ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Problem starting managed server when in STANDBY state.

  1. Problem starting managed server when in STANDBY state.

    Hi, I have a clustered server with a managed node which is not starting. When the NodeManager and Admin servers start successfully I can see that the managed node in question has been somwhat loaded but is in the 'STANDBY' state.

    After using the Console control panel to 'resume' server I get the following error:
    **********************************************
    weblogic.utils.AssertionError: ***** ASSERTION FAILED *****[ Can only start a STANDBY service ]
    at weblogic.utils.Debug.assertion(Debug.java:57)
    at weblogic.jndi.internal.NamingService.resume(Naming Service.java:87)
    at weblogic.t3.srvr.SubsystemManager.resume(Subsystem Manager.java:131)
    at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:964)
    at weblogic.t3.srvr.ServerRuntime.unprotectedResume(S erverRuntime.java:459)
    at weblogic.t3.srvr.ServerRuntime.access$200(ServerRu ntime.java:83)
    at weblogic.t3.srvr.ServerRuntime$3.run(ServerRuntime .java:403)
    at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(AuthenticatedSubject.java:317)
    at weblogic.security.service.SecurityManager.runAs(Se curityManager.java:118)
    at weblogic.t3.srvr.ServerRuntime.resume(ServerRuntim e.java:399)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:324)
    at weblogic.management.internal.DynamicMBeanImpl.invo keLocally(DynamicMBeanImpl.java:711)
    at weblogic.management.internal.DynamicMBeanImpl.invo ke(DynamicMBeanImpl.java:690)
    at com.sun.management.jmx.MBeanServerImpl.invoke(MBea nServerImpl.java:1557)
    at com.sun.management.jmx.MBeanServerImpl.invoke(MBea nServerImpl.java:1525)
    at weblogic.management.internal.RemoteMBeanServerImpl .private_invoke(RemoteMBeanServerImpl.java:947)
    at weblogic.management.internal.RemoteMBeanServerImpl .invoke(RemoteMBeanServerImpl.java:908)
    at weblogic.management.internal.RemoteMBeanServerImpl _WLSkel.invoke(Unknown Source)
    at weblogic.rmi.internal.BasicServerRef.invoke(BasicS erverRef.java:477)
    at weblogic.rmi.internal.BasicServerRef$1.run(BasicSe rverRef.java:420)
    at weblogic.security.acl.internal.AuthenticatedSubjec t.doAs(AuthenticatedSubject.java:353)
    at weblogic.security.service.SecurityManager.runAs(Se curityManager.java:144)
    at weblogic.rmi.internal.BasicServerRef.handleRequest (BasicServerRef.java:415)
    at weblogic.rmi.internal.BasicExecuteRequest.execute( BasicExecuteRequest.java:30)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:197)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:170)
    **********************************************

    Has anybody seen this before?

    Thanks.

  2. Re: Problem starting managed server when in STANDBY state.

    Can you double check the state of the standby server using the weblogic.Admin tool when your console says it is in standby state.

    Also refresh the console don't laugh!

    Also check using the console the node manager log

    server>control>click status link

    Hoos

  3. Re: Problem starting managed server when in STANDBY state.

    Hi,

    I encountered the same error in my environment today. Did you managed to resolve it. If yes, can you pls. share it.

    Thanks,
    Samuel

  4. Re: Problem starting managed server when in STANDBY state.

    This was because of my IP changes. Now it works.
    Thanks,
    Samuel

+ Reply to Thread