Hi All

Im having the following error after uninstall WL7.0 SP 5 and trying to run the old version WL7.0 SP2


<149205> {
Module Name: usermgmt, Error: Exception preparing module: EJBModule(usermgmt,status=NEW)


Unable to deploy EJB: usermgmt.jar from usermgmt.jar:


Class not found: Lcom/bea/p13n/security/realm/PortalSearchableRealm;
java.lang.NoClassDefFoundError: Class not found: Lcom/bea/p13n/security/realm/PortalSearchableRealm;
at weblogic.ejb20.compliance.EJBComplianceChecker.che ck(EJBComplianceChecker.java:283)
at weblogic.ejb20.compliance.EJBComplianceChecker.che ckDeploymentInfo(EJBComplianceChecker.java:228)
at weblogic.ejb20.ejbc.EJBCompiler.complianceCheckJar (EJBCompiler.java:901)
at weblogic.ejb20.ejbc.EJBCompiler.checkCompliance(EJ BCompiler.java:857)
at weblogic.ejb20.ejbc.EJBCompiler.doCompile(EJBCompi ler.java:185)
at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBComp iler.java:344)
at weblogic.ejb20.deployer.EJBDeployer.runEJBC(EJBDep loyer.java:489)
at weblogic.ejb20.deployer.EJBDeployer.compileEJB(EJB Deployer.java:819)
at weblogic.ejb20.deployer.EJBDeployer.prepare(EJBDep loyer.java:1268)
at weblogic.ejb20.deployer.EJBModule.prepare(EJBModul e.java:232)
at weblogic.j2ee.J2EEApplicationContainer.prepareModu le(J2EEApplicationContainer.java:1570)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2E EApplicationContainer.java:737)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2E EApplicationContainer.java:555)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2E EApplicationContainer.java:458)
at weblogic.management.deploy.slave.SlaveDeployer.pre pareAllStagedApplications(SlaveDeployer.java:502)
at weblogic.management.deploy.slave.SlaveDeployer.ini tialize(SlaveDeployer.java:265)
at weblogic.management.deploy.DeploymentManagerServer LifeCycleImpl.initialize(DeploymentManagerServerLi feCycleImpl.java:150)
at weblogic.t3.srvr.ServerLifeCycleList.initialize(Se rverLifeCycleList.java:54)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:78 2)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
at weblogic.Server.main(Server.java:32)

at weblogic.ejb20.compliance.EJBComplianceChecker.che ck(EJBComplianceChecker.java:264)
at weblogic.ejb20.compliance.EJBComplianceChecker.che ckDeploymentInfo(EJBComplianceChecker.java:228)
at weblogic.ejb20.ejbc.EJBCompiler.complianceCheckJar (EJBCompiler.java:901)
at weblogic.ejb20.ejbc.EJBCompiler.checkCompliance(EJ BCompiler.java:857)
at weblogic.ejb20.ejbc.EJBCompiler.doCompile(EJBCompi ler.java:185)
at weblogic.ejb20.ejbc.EJBCompiler.compileEJB(EJBComp iler.java:344)
at weblogic.ejb20.deployer.EJBDeployer.runEJBC(EJBDep loyer.java:489)
at weblogic.ejb20.deployer.EJBDeployer.compileEJB(EJB Deployer.java:819)
at weblogic.ejb20.deployer.EJBDeployer.prepare(EJBDep loyer.java:1268)
at weblogic.ejb20.deployer.EJBModule.prepare(EJBModul e.java:232)
at weblogic.j2ee.J2EEApplicationContainer.prepareModu le(J2EEApplicationContainer.java:1570)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2E EApplicationContainer.java:737)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2E EApplicationContainer.java:555)
at weblogic.j2ee.J2EEApplicationContainer.prepare(J2E EApplicationContainer.java:458)
at weblogic.management.deploy.slave.SlaveDeployer.pre pareAllStagedApplications(SlaveDeployer.java:502)
at weblogic.management.deploy.slave.SlaveDeployer.ini tialize(SlaveDeployer.java:265)
at weblogic.management.deploy.DeploymentManagerServer LifeCycleImpl.initialize(DeploymentManagerServerLi feCycleImpl.java:150)
at weblogic.t3.srvr.ServerLifeCycleList.initialize(Se rverLifeCycleList.java:54)
at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:78 2)
at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
at weblogic.Server.main(Server.java:32)


Does anyone knows why is not finding the com/bea/p13n/security/realm/PortalSearchableRealm; ?? Do i miss a uninstallation step?? Do i need to install the SP2 upgrade package??

Thanks for your help.
Regards!