I would guess that BEA's installation problems are not just limited to Weblogic Server. I have a similar difficulty with Weblogic Platform 8.1 with SP2. The installer does not install the Java runtime, and the uninstall is dependent upon that.

Not impressed BEA. You have some work to do.