Hi guys,
As Ryan pointed, the problem is because of the JRE incompatibility...
Try to install the JRE 1.4 & above which will solve the issue.