Weblogic 6.1 sp4 on Linux Redhat AS.
Sun JAva 1.4


As a work aroung from another user, I added a file called login.conf and made
the entry change in StartWLS.sh file. The entry in the login.conf file is

ServerLoginModule {
weblogic.security.internal.ServerLoginModule required debug=true;
};


Can someone help

When I attempt to startup weblogic I get the following messages .


java.lang.SecurityException: Unable to locate a login configuration
at com.sun.security.auth.login.ConfigFile.(ConfigFile.java:97)
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstruct
orAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingC
onstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Construc tor.java:274)
at java.lang.Class.newInstance0(Class.java:308)
at java.lang.Class.newInstance(Class.java:261)
at javax.security.auth.login.Configuration$3.run(Conf iguration.java:221)
at java.security.AccessController.doPrivileged(Native Method)
at javax.security.auth.login.Configuration.getConfigu ration(Configuratio
n.java:215)
at javax.security.auth.login.LoginContext$1.run(Login Context.java:170)
at java.security.AccessController.doPrivileged(Native Method)
at javax.security.auth.login.LoginContext.init(LoginC ontext.java:167)
at javax.security.auth.login.LoginContext.(LoginContext.java:404)
at weblogic.security.internal.ServerAuthenticate.main (ServerAuthenticate
..java:78)
at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:210)
at weblogic.Server.main(Server.java:35)
Caused by: java.io.IOException: Unable to locate a login configuration
at com.sun.security.auth.login.ConfigFile.init(Config File.java:206)
at com.sun.security.auth.login.ConfigFile.(ConfigFile.java:95)
... 16 more