WebLogic is connecting to openldap with a realm.
In the console all ldap groups seems OK and are viewed in the console
(security-->groups), but in security-->users, there is a java
exception. It seems weblogic don't see any users because
authentication don't work.


java.lang.NullPointerException
at weblogic.management.internal.RemoteRealmManagerImp l$1.handle(RemoteRealmManagerImpl.java:121)
at weblogic.management.internal.BatchedEnumeration.ge tNextBatch(BatchedEnumeration.java:50)
at weblogic.management.internal.RemoteRealmManagerImp l.getListResults(RemoteRealmManagerImpl.java:387)
at weblogic.management.internal.RemoteRealmManagerImp l.listUsers(RemoteRealmManagerImpl.java:114)
at weblogic.management.configuration.RealmManager.lis tUsers(RealmManager.java:165)
at weblogic.management.console.webapp._domain.__usert able._jspService(__usertable.java:433)
at weblogic.servlet.jsp.JspBase.service(JspBase.java: 27)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:275)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:199)
at weblogic.servlet.internal.RequestDispatcherImpl.fo rward(RequestDispatcherImpl.java:286)
at weblogic.servlet.jsp.PageContextImpl.forward(PageC ontextImpl.java:119)
at weblogic.management.console.actions.ForwardAction. perform(ForwardAction.java:35)
at weblogic.management.console.actions.internal.Actio nServlet.doAction(ActionServlet.java:171)
at weblogic.management.console.actions.internal.Actio nServlet.doGet(ActionServlet.java:91)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:740)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:853)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:275)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:199)
at weblogic.servlet.internal.WebAppServletContext.inv okeServlet(WebAppServletContext.java:2702)
at weblogic.servlet.internal.ServletRequestImpl.execu te(ServletRequestImpl.java:2427)
at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:159)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:140)
--------------- nested within: ------------------
weblogic.management.configuration.RealmException:
RealmManager.listUsers - with nested exception:
[java.lang.NullPointerException]
at weblogic.management.configuration.RealmManager.lis tUsers(RealmManager.java:176)
at weblogic.management.console.webapp._domain.__usert able._jspService(__usertable.java:433)
at weblogic.servlet.jsp.JspBase.service(JspBase.java: 27)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:275)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:199)
at weblogic.servlet.internal.RequestDispatcherImpl.fo rward(RequestDispatcherImpl.java:286)
at weblogic.servlet.jsp.PageContextImpl.forward(PageC ontextImpl.java:119)
at weblogic.management.console.actions.ForwardAction. perform(ForwardAction.java:35)
at weblogic.management.console.actions.internal.Actio nServlet.doAction(ActionServlet.java:171)
at weblogic.management.console.actions.internal.Actio nServlet.doGet(ActionServlet.java:91)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:740)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:853)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:275)
at weblogic.servlet.internal.ServletStubImpl.invokeSe rvlet(ServletStubImpl.java:199)
at weblogic.servlet.internal.WebAppServletContext.inv okeServlet(WebAppServletContext.java:2702)
at weblogic.servlet.internal.ServletRequestImpl.execu te(ServletRequestImpl.java:2427)
at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:159)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:140)