Re: Configure a Custom User Name Mapper and No Log Output,help - Weblogic

This is a discussion on Re: Configure a Custom User Name Mapper and No Log Output,help - Weblogic ; "BlackSnail" wrote in message news:3f2f8215@newsgroups.bea.com... > I'm working on SSL security on WLS8.1.I did the steps as below: > > 1. configure two-way SSL successfully > 2. implement a NewUserNameMapper > 3. open http://locahost:7001/console,modify "Default Identity Assertion > provider" page ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Re: Configure a Custom User Name Mapper and No Log Output,help

  1. Re: Configure a Custom User Name Mapper and No Log Output,help


    "BlackSnail" wrote in message
    news:3f2f8215@newsgroups.bea.com...
    > I'm working on SSL security on WLS8.1.I did the steps as below:
    >
    > 1. configure two-way SSL successfully
    > 2. implement a NewUserNameMapper
    > 3. open http://locahost:7001/console,modify "Default Identity Assertion
    > provider" page
    > enter the name of implementation in the "User Name Mapper Class Name"
    > attribute and click "Apply" button.
    > 5. reboot WebLogic Server 8.1
    >
    > WLS runs normally except one thing--it didn't show the log on the dos
    > window.I use many "System.out.println()" in the code,but none of them is
    > output to the stdout or examplesServer.log.
    >
    > Why?
    >
    > I use this cmd to start server:
    >

    D:\bea81\user_projects\examples>startExamplesServer -Dssl.debug=true -Dweblo
    > gic.
    > StdoutDebugEnabled=true
    >
    > Any helps will be appreciated.
    >
    >


    Are you sure your username mapper is being called? Did you specify
    client-cert in the deployment
    descriptor.
    http://edocs.bea.com/wls/docs81/secu...t.html#1034721






  2. Re: Configure a Custom User Name Mapper and No Log Output,help


    would the auth_type be client-cert if I a would liek to authenticate using kerberos


    please help
    prem

    "Peter" wrote:
    >
    >"BlackSnail" wrote in message
    >news:3f2f8215@newsgroups.bea.com...
    >> I'm working on SSL security on WLS8.1.I did the steps as below:
    >>
    >> 1. configure two-way SSL successfully
    >> 2. implement a NewUserNameMapper
    >> 3. open http://locahost:7001/console,modify "Default Identity Assertion
    >> provider" page
    >> enter the name of implementation in the "User Name Mapper Class

    >Name"
    >> attribute and click "Apply" button.
    >> 5. reboot WebLogic Server 8.1
    >>
    >> WLS runs normally except one thing--it didn't show the log on the dos
    >> window.I use many "System.out.println()" in the code,but none of them

    >is
    >> output to the stdout or examplesServer.log.
    >>
    >> Why?
    >>
    >> I use this cmd to start server:
    >>

    >D:\bea81\user_projects\examples>startExamplesServer -Dssl.debug=true
    >-Dweblo
    >> gic.
    >> StdoutDebugEnabled=true
    >>
    >> Any helps will be appreciated.
    >>
    >>

    >
    >Are you sure your username mapper is being called? Did you specify
    >client-cert in the deployment
    >descriptor.
    >http://edocs.bea.com/wls/docs81/secu...t.html#1034721
    >
    >
    >
    >
    >



  3. Re: Configure a Custom User Name Mapper and No Log Output,help


    "PremS" wrote in message
    news:3f370537$1@newsgroups.bea.com...
    >
    > would the auth_type be client-cert if I a would liek to authenticate using

    kerberos
    >
    >
    > please help
    > prem


    client-cert will cause the servlet container to call the identity asserter
    for request
    headers and cookies. If you are passing the kerberos token in the request,
    then
    you can implement an identity asserter that can validate the token and map
    to the correct user.







+ Reply to Thread