Distributed queue member with messages, but no consumers - Weblogic

This is a discussion on Distributed queue member with messages, but no consumers - Weblogic ; Hello, I have 2 nodes in cluster each one has a pinned JMS server with a queue QueueA and QueueA2 respectively both mebers in a distributed destination dist_queue. There is a consumer on QueueA only (startup class). In case of ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: Distributed queue member with messages, but no consumers

  1. Distributed queue member with messages, but no consumers


    Hello,
    I have 2 nodes in cluster each one has a pinned JMS server with a queue QueueA
    and QueueA2
    respectively both mebers in a distributed destination dist_queue.
    There is a consumer on QueueA only (startup class).
    In case of a message sent to QueueA2 a consumer is created for QueueA2 automaticly
    (seen in the admin console) out of the blue, and the message do not get forward
    to QueueA where my consumer is listening.
    Monitoring JMS connections of both servers shows only my consumers' connection.
    Our application depends on the forward feature.
    Am I doing something wrong? any ideas?

    Thanks.
    Eran

  2. Re: Distributed queue member with messages, but no consumers

    Hi Eran,

    Have you set up the ForwardPolicy for the Distributed Queue?
    By default, the ForwardPolicy is -1, which turns off the forwarding.

    Dongbo

    eran wrote:

    > Hello,
    > I have 2 nodes in cluster each one has a pinned JMS server with a queue QueueA
    > and QueueA2
    > respectively both mebers in a distributed destination dist_queue.
    > There is a consumer on QueueA only (startup class).
    > In case of a message sent to QueueA2 a consumer is created for QueueA2 automaticly
    > (seen in the admin console) out of the blue, and the message do not get forward
    > to QueueA where my consumer is listening.
    > Monitoring JMS connections of both servers shows only my consumers' connection.
    > Our application depends on the forward feature.
    > Am I doing something wrong? any ideas?
    >
    > Thanks.
    > Eran



  3. Re: Distributed queue member with messages, but no consumers

    Sorry, the attribute is ForwardDelay, not ForwardPolicy.

    Dongbo

    Dongbo Xiao wrote:

    > Hi Eran,
    >
    > Have you set up the ForwardPolicy for the Distributed Queue?
    > By default, the ForwardPolicy is -1, which turns off the forwarding.
    >
    > Dongbo
    >
    > eran wrote:
    >
    > > Hello,
    > > I have 2 nodes in cluster each one has a pinned JMS server with a queue QueueA
    > > and QueueA2
    > > respectively both mebers in a distributed destination dist_queue.
    > > There is a consumer on QueueA only (startup class).
    > > In case of a message sent to QueueA2 a consumer is created for QueueA2 automaticly
    > > (seen in the admin console) out of the blue, and the message do not get forward
    > > to QueueA where my consumer is listening.
    > > Monitoring JMS connections of both servers shows only my consumers' connection.
    > > Our application depends on the forward feature.
    > > Am I doing something wrong? any ideas?
    > >
    > > Thanks.
    > > Eran



  4. Re: Distributed queue member with messages, but no consumers


    Yes.
    It turns out that if replicate local queue jndi name in cluster is set to false
    the message did not get forward

    Dongbo Xiao wrote:
    >Sorry, the attribute is ForwardDelay, not ForwardPolicy.
    >
    >Dongbo
    >
    >Dongbo Xiao wrote:
    >
    >> Hi Eran,
    >>
    >> Have you set up the ForwardPolicy for the Distributed Queue?
    >> By default, the ForwardPolicy is -1, which turns off the forwarding.
    >>
    >> Dongbo
    >>
    >> eran wrote:
    >>
    >> > Hello,
    >> > I have 2 nodes in cluster each one has a pinned JMS server with a

    >queue QueueA
    >> > and QueueA2
    >> > respectively both mebers in a distributed destination dist_queue.
    >> > There is a consumer on QueueA only (startup class).
    >> > In case of a message sent to QueueA2 a consumer is created for QueueA2

    >automaticly
    >> > (seen in the admin console) out of the blue, and the message do not

    >get forward
    >> > to QueueA where my consumer is listening.
    >> > Monitoring JMS connections of both servers shows only my consumers'

    >connection.
    >> > Our application depends on the forward feature.
    >> > Am I doing something wrong? any ideas?
    >> >
    >> > Thanks.
    >> > Eran

    >



+ Reply to Thread