the pending message when server crashes - Weblogic

This is a discussion on the pending message when server crashes - Weblogic ; Hi I have dealt with this before and am kind if repeating the question. As we had discussed - there was a small issue with messages remaining in limbo state [pending state] when the server crashes while a transacted message ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: the pending message when server crashes

  1. the pending message when server crashes


    Hi
    I have dealt with this before and am kind if repeating the question. As we had
    discussed - there was a small issue with messages remaining in limbo state [pending
    state] when the server crashes while a transacted message is getting processed
    [the server crashes before the transaction is commited/rolledback]. When the server
    comes back up - the message used to take a long time to be visible back in the
    queue - and the time used vary form upwards 2 minutes - 30 min. Now this was fixed
    in 7.0 sp1 with a patch which I tested - the delay time was reduced to 0. But
    if I test in sp2 without that patch the delay is still there - was it supposed
    to be fixed in sp2 or only in 8.1 or is there any sp3?

    thanks
    Anamitra

  2. Re: the pending message when server crashes

    Hi Anamitra,

    I'm not sure. Contact customer support, they should
    be able to straighten it out. I don't think 7.0SP3
    is out yet, so it looks like you may need a temporary
    patch that works on top of SP2.

    Tom

    Anamitra wrote:
    > Hi
    > I have dealt with this before and am kind if repeating the question. As we had
    > discussed - there was a small issue with messages remaining in limbo state [pending
    > state] when the server crashes while a transacted message is getting processed
    > [the server crashes before the transaction is commited/rolledback]. When the server
    > comes back up - the message used to take a long time to be visible back in the
    > queue - and the time used vary form upwards 2 minutes - 30 min. Now this was fixed
    > in 7.0 sp1 with a patch which I tested - the delay time was reduced to 0. But
    > if I test in sp2 without that patch the delay is still there - was it supposed
    > to be fixed in sp2 or only in 8.1 or is there any sp3?
    >
    > thanks
    > Anamitra



  3. Re: the pending message when server crashes


    Anamitra

    How u got this resolved. I have kind of sma issue with 7.0 sp3. The pendng messages
    seem to take about 5-20 minutes before they are processed again. I want to see
    if I cna have control over this time

    Please let me know
    Thanks
    Priya
    Tom Barnes wrote:
    >Hi Anamitra,
    >
    >I'm not sure. Contact customer support, they should
    >be able to straighten it out. I don't think 7.0SP3
    >is out yet, so it looks like you may need a temporary
    >patch that works on top of SP2.
    >
    >Tom
    >
    >Anamitra wrote:
    >> Hi
    >> I have dealt with this before and am kind if repeating the question.

    >As we had
    >> discussed - there was a small issue with messages remaining in limbo

    >state [pending
    >> state] when the server crashes while a transacted message is getting

    >processed
    >> [the server crashes before the transaction is commited/rolledback].

    >When the server
    >> comes back up - the message used to take a long time to be visible

    >back in the
    >> queue - and the time used vary form upwards 2 minutes - 30 min. Now

    >this was fixed
    >> in 7.0 sp1 with a patch which I tested - the delay time was reduced

    >to 0. But
    >> if I test in sp2 without that patch the delay is still there - was

    >it supposed
    >> to be fixed in sp2 or only in 8.1 or is there any sp3?
    >>
    >> thanks
    >> Anamitra

    >



  4. Re: the pending message when server crashes

    Hi Priya,

    Try posting to the transaction newsgroup to find out the current
    status, this behavior is actually outside of JMS control
    as it is the transaction manager that controls the
    timing of transaction recovery. And/or contact customer support.

    Tom

    Priya wrote:

    > Anamitra
    >
    > How u got this resolved. I have kind of sma issue with 7.0 sp3. The pendng messages
    > seem to take about 5-20 minutes before they are processed again. I want to see
    > if I cna have control over this time
    >
    > Please let me know
    > Thanks
    > Priya
    > Tom Barnes wrote:
    >
    >>Hi Anamitra,
    >>
    >>I'm not sure. Contact customer support, they should
    >>be able to straighten it out. I don't think 7.0SP3
    >>is out yet, so it looks like you may need a temporary
    >>patch that works on top of SP2.
    >>
    >>Tom
    >>
    >>Anamitra wrote:
    >>
    >>>Hi
    >>>I have dealt with this before and am kind if repeating the question.

    >>
    >>As we had
    >>
    >>>discussed - there was a small issue with messages remaining in limbo

    >>
    >>state [pending
    >>
    >>>state] when the server crashes while a transacted message is getting

    >>
    >>processed
    >>
    >>>[the server crashes before the transaction is commited/rolledback].

    >>
    >>When the server
    >>
    >>>comes back up - the message used to take a long time to be visible

    >>
    >>back in the
    >>
    >>>queue - and the time used vary form upwards 2 minutes - 30 min. Now

    >>
    >>this was fixed
    >>
    >>>in 7.0 sp1 with a patch which I tested - the delay time was reduced

    >>
    >>to 0. But
    >>
    >>>if I test in sp2 without that patch the delay is still there - was

    >>
    >>it supposed
    >>
    >>>to be fixed in sp2 or only in 8.1 or is there any sp3?
    >>>
    >>>thanks
    >>>Anamitra

    >>

    >



+ Reply to Thread