Io exception: Connection refused Error - Weblogic

This is a discussion on Io exception: Connection refused Error - Weblogic ; I am trying to configure a connection pool on Weblogic 8.1 using Oracle thin client. When I click on the Test Driver configuration, I get the following error: Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=153092352)(ERR=1 2505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4)))) I have verified that the username/url are ...

+ Reply to Thread
Results 1 to 7 of 7

Thread: Io exception: Connection refused Error

  1. Io exception: Connection refused Error


    I am trying to configure a connection pool on Weblogic 8.1 using Oracle thin client.
    When I click on the Test Driver configuration, I get the following error:
    Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=153092352)(ERR=1 2505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))

    I have verified that the username/url are correct.

    Any ideas?

  2. Re: Io exception: Connection refused Error



    Sreeram wrote:

    > I am trying to configure a connection pool on Weblogic 8.1 using Oracle thin client.
    > When I click on the Test Driver configuration, I get the following error:
    > Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=153092352)(ERR=1 2505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))
    >
    > I have verified that the username/url are correct.


    The SID is probably wrong. What does utils.dbping show?
    Joe

    >
    > Any ideas?



  3. Re: Io exception: Connection refused Error


    I am not sure how to run utils.dbping.

    Anyway, I am able to connect to the database using SQLPlus. I have the following
    entry in my tnsnames ora:

    dbalias.world=
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = server.xx.com)(PORT = 1521))
    )
    (CONNECT_DATA =
    (service_name = dbname)
    )
    )

    Thanks!

    Joe Weinstein wrote:
    >
    >
    >Sreeram wrote:
    >
    >> I am trying to configure a connection pool on Weblogic 8.1 using Oracle

    >thin client.
    >> When I click on the Test Driver configuration, I get the following

    >error:
    >> Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=153092352)(ERR=1 2505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))
    >>
    >> I have verified that the username/url are correct.

    >
    >The SID is probably wrong. What does utils.dbping show?
    >Joe
    >
    >>
    >> Any ideas?

    >



  4. Re: Io exception: Connection refused Error



    Sreeram wrote:

    > I am not sure how to run utils.dbping.


    Try this:

    C:\> java utils.dbping

    It will print out a usage message.

    > Anyway, I am able to connect to the database using SQLPlus. I have the following
    > entry in my tnsnames ora:
    >
    > dbalias.world=
    > (DESCRIPTION =
    > (ADDRESS_LIST =
    > (ADDRESS = (PROTOCOL = TCP)(HOST = server.xx.com)(PORT = 1521))
    > )
    > (CONNECT_DATA =
    > (service_name = dbname)
    > )
    > )


    Ok, and how did you define the pool? What were the properties and URL?
    Did your URL contain 'dbname' as the SID, or did you set the SID in the properties?
    show me the pool definition and show me how you start SQL-PLUS.
    Joe


    > Thanks!
    >
    > Joe Weinstein wrote:
    >
    >>
    >>Sreeram wrote:
    >>
    >>
    >>>I am trying to configure a connection pool on Weblogic 8.1 using Oracle

    >>
    >>thin client.
    >>
    >>>When I click on the Test Driver configuration, I get the following

    >>
    >>error:
    >>
    >>>Io exception: Connection refused(DESCRIPTION=(TMP=)(VSNNUM=153092352)(ERR=1 2505)(ERROR_STACK=(ERROR=(CODE=12505)(EMFI=4))))
    >>>
    >>>I have verified that the username/url are correct.

    >>
    >>The SID is probably wrong. What does utils.dbping show?
    >>Joe
    >>
    >>
    >>>Any ideas?

    >>

    >



  5. Re: Io exception: Connection refused Error


    Thanks for your reply.

    >Try this:
    >
    >C:\> java utils.dbping
    >
    >It will print out a usage message.


    Tried this. I get a NoClassDefFound error. I have set the java bin & lib dirs
    in the PATH and CLASSPATH variables. Not sure which other path needs to be set.


    >Ok, and how did you define the pool? What were the properties and URL?
    >Did your URL contain 'dbname' as the SID, or did you set the SID in the
    >properties?
    >show me the pool definition and show me how you start SQL-PLUS.
    >Joe


    I defined the pool from the Admin console. The database is Oracle 9.2.0.3. In
    the properties, I just specified username and password. (user=username and password=passwd
    on separate lines)

    The url is- jdbcracle:thin:@server.xx.com:1521:dbname

    I start SQLPlus by - sqlplus user/passwd@dbalias.world

  6. Re: Io exception: Connection refused Error



    Sreeram wrote:

    > Thanks for your reply.
    >
    >
    >>Try this:
    >>
    >>C:\> java utils.dbping
    >>
    >>It will print out a usage message.

    >
    >
    > Tried this. I get a NoClassDefFound error. I have set the java bin & lib dirs
    > in the PATH and CLASSPATH variables. Not sure which other path needs to be set.


    Ok... You need to have weblogic stuff in the classpath...

    >>Ok, and how did you define the pool? What were the properties and URL?
    >>Did your URL contain 'dbname' as the SID, or did you set the SID in the
    >>properties?
    >>show me the pool definition and show me how you start SQL-PLUS.
    >>Joe

    >
    > I defined the pool from the Admin console. The database is Oracle 9.2.0.3. In
    > the properties, I just specified username and password. (user=username and password=passwd
    > on separate lines)
    >
    > The url is- jdbcracle:thin:@server.xx.com:1521:dbname
    >
    > I start SQLPlus by - sqlplus user/passwd@dbalias.world


    Ok, then the URL looks correct. I can only suggest that
    you download oracle's thin driver separately, and try
    getting oracle's own thin driver example to connect to your
    DBMS. Once that works, we'll know how to define the pool.
    Joe


  7. Re: Io exception: Connection refused Error


    I found the problem. The database I was trying to connect had a global database
    name different from the SID. SQLPlus expects the global databasename. I was using
    the same while creating the connection pool. When I changed it to the SID, it
    worked fine.

    Thanks for your help.

+ Reply to Thread