ejc cmp 2.0 - Weblogic

This is a discussion on ejc cmp 2.0 - Weblogic ; I have a j2ee app with about 20 tables and 20 matching ejb cmp beans. when I start weblogic 8.1, for some reason, weblogic deletes all the data in one of the tables. It only affects this one table. I ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: ejc cmp 2.0

  1. ejc cmp 2.0


    I have a j2ee app with about 20 tables and 20 matching ejb cmp beans.
    when I start weblogic 8.1, for some reason, weblogic deletes all the data in one
    of the tables.
    It only affects this one table. I have set to Disabled
    in all of the weblogic-cmp-jar.xml deployment descriptor files, so I don't know
    why weblogic is singling out this one table to delete all of its rows.

    Any clues?

  2. Re: ejc cmp 2.0

    Can you change the security on the database so the user doesn't have drop
    privileges and see where this is happening? You could also turn on JDBC logging
    to see what is actually being done to the database.

    Sam

    beaglebuddy wrote:

    > I have a j2ee app with about 20 tables and 20 matching ejb cmp beans.
    > when I start weblogic 8.1, for some reason, weblogic deletes all the data in one
    > of the tables.
    > It only affects this one table. I have set to Disabled
    > in all of the weblogic-cmp-jar.xml deployment descriptor files, so I don't know
    > why weblogic is singling out this one table to delete all of its rows.
    >
    > Any clues?



  3. Re: ejc cmp 2.0


    Set to 'False' in weblogic-cmp-rdbms-jar.xml
    False




    "beaglebuddy" wrote:
    >
    >I have a j2ee app with about 20 tables and 20 matching ejb cmp beans.
    >when I start weblogic 8.1, for some reason, weblogic deletes all the
    >data in one
    >of the tables.
    >It only affects this one table. I have set
    >to Disabled
    >in all of the weblogic-cmp-jar.xml deployment descriptor files, so I
    >don't know
    >why weblogic is singling out this one table to delete all of its rows.
    >
    >Any clues?



  4. Re: ejc cmp 2.0


    In WebLogic 8.1 the setting for not creating the default tables is
    'Disabled' not 'False'. In WebLogic 7.0 the setting is 'False'.


    thanks,
    Deepak

    "beaglebuddy" wrote:
    >
    >I have a j2ee app with about 20 tables and 20 matching ejb cmp beans.
    >when I start weblogic 8.1, for some reason, weblogic deletes all the
    >data in one
    >of the tables.
    >It only affects this one table. I have set
    >to Disabled
    >in all of the weblogic-cmp-jar.xml deployment descriptor files, so I
    >don't know
    >why weblogic is singling out this one table to delete all of its rows.
    >
    >Any clues?



+ Reply to Thread