In weblogic-ejb-jar.xml use 6.0
instead of 5.1.0.

thanks,
Deepak



"aplsyn5" wrote:
>Getting following error while compiling ejb using weblogic.ejbc20
>compiler..Please
>help
>
>ejbc] [EJB:012029]Error occurred while processing weblogic-rdbms-bean.xml
>file:
>'META-INF/weblogic-cmp-rdbms-jar.xml'. Encountered an unexpected version
>of
>XML
>file. Make sure that your weblogic-rdbms-bean.xml file is the correct
>version
>(e.g. a common error is to use
>a 6.0.0 CMP20 cmp xml file on a 5.1.0 CMP11 Bean). EJB Name :
>'net.uu.cco.product.pop.ejb.POPAccountBean'.
>XML Processor: 'weblogic.ejb20.cmp.rdbms.WebLogicCmp20Loader_WLS8 10'..
>
>I have converted the EJBs deployment descriptors by using DDconverter
>utility.
>
>The Deployment descriptors are given below.
>
> >8.1.0
>EJB RDBMS Persistence//EN'
>'http://www.bea.com/servers/wls810/dtd/weblogic-rdbms20-persistence-810.dtd'
>>

>
>
>
>
>
>
> net.uu.cco.product.pop.ejb.POPAccountBean
> UUNETPool
>
> uunet_live_cco_dev.popusers
>
> password
> passwd_clear
>

>
> mailAlias
> maildir
>

>

>
>
> findByMailAlias
>
> java.lang.String
>

>
>

>
>
>

>

>

>
>********************************************
> >8.1.0
>EJB//EN'
>'http://www.bea.com/servers/wls810/dtd/weblogic-
>
>ejb-jar.dt
>d'>
>
>
>
>
>
>
> net.uu.cco.product.pop.ejb.POPAccountHelperBean
>
>
> 100
>

>
>
>

>
>

>
>
> 60
>

>
> True
> net.uu.cco.product.pop.ejb.POPAccountHelperBean
>

>
> net.uu.cco.product.pop.ejb.POPAccountBean
>
>
>

>
>
> 1000
> Exclusive
>

>
>
>
> WebLogic_CMP_RDBMS
> 5.1.0
> META-INF/weblogic-cmp-rdbms-jar.xml
>

>
>

>
>
>

>
>

>
>
> 60
>

>
> True
> net.uu.cco.product.pop.ejb.POPAccountBean
>

>

>
>
>
>
>