Calling EJB from WL 7.0 to WL 5.1 - Weblogic

This is a discussion on Calling EJB from WL 7.0 to WL 5.1 - Weblogic ; Hello All, Here is my situation. There are 3 app servers. App server 1 and 2 are WL 7.0. App server 3 is WL 5.1. EJB A is deployed in App server 1. EJB B is deployed in app servers ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Calling EJB from WL 7.0 to WL 5.1

  1. Calling EJB from WL 7.0 to WL 5.1


    Hello All,
    Here is my situation. There are 3 app servers. App server 1 and 2 are WL 7.0.
    App server 3 is WL 5.1. EJB A is deployed in App server 1. EJB B is deployed in
    app servers 2 and 3. For EJB B deployed in app server 3, I compiled using WL 5.1
    classes. When I call the EJB B deployed in app server 3 from EJB A deployed in
    app server 1, I am getting the following exception:
    javax.naming.CommunicationException [Root exception is weblogic.socket.UnrecoverableConnectException:
    [Login failed: 'Incompatible version:Incompatible versions - this server:5.1.0
    client:7.0.4.0]]

    I have read earliar documentation, but the solution is not clear. I have tried
    calling the EJB B using iiop( I compiled using -iiop option) instead of t3 and
    that is not working either.
    Thanks for the help.

  2. Re: Calling EJB from WL 7.0 to WL 5.1

    "Jeba Bhaskaran" writes:

    There are a bunch of interop fixes for 5.1 that you probably
    require. Please go through support to obtain these.

    andy


    > Hello All,
    > Here is my situation. There are 3 app servers. App server 1 and 2 are WL 7.0.
    > App server 3 is WL 5.1. EJB A is deployed in App server 1. EJB B is deployed in
    > app servers 2 and 3. For EJB B deployed in app server 3, I compiled using WL 5.1
    > classes. When I call the EJB B deployed in app server 3 from EJB A deployed in
    > app server 1, I am getting the following exception:
    > javax.naming.CommunicationException [Root exception is weblogic.socket.UnrecoverableConnectException:
    > [Login failed: 'Incompatible version:Incompatible versions - this server:5.1.0
    > client:7.0.4.0]]
    >
    > I have read earliar documentation, but the solution is not clear. I have tried
    > calling the EJB B using iiop( I compiled using -iiop option) instead of t3 and
    > that is not working either.
    > Thanks for the help.


+ Reply to Thread