Upgrading from WLS6.0 to WLS7.0 EJB XML Question - Weblogic

This is a discussion on Upgrading from WLS6.0 to WLS7.0 EJB XML Question - Weblogic ; EJB Folks, I posted this message on the Security newsgroup first, but have not received any response. Possibly, this is more of an EJB XML question. We are upgrading from WLS6.0 to WLS7.0, and after correcting various XML issues, we've ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Upgrading from WLS6.0 to WLS7.0 EJB XML Question

  1. Upgrading from WLS6.0 to WLS7.0 EJB XML Question


    EJB Folks,

    I posted this message on the Security newsgroup first, but have not received any
    response. Possibly, this is more of an EJB XML question. We are upgrading from
    WLS6.0 to WLS7.0, and after correcting various XML issues, we've stumbled over
    a very troublesome security issue. The following is a portion of the ejb-jar.xml
    for one of the beans:

    foo


    The WLS documentation directed changing run-as-specified-identity to run-as, so
    the reviews ejb-jar.xml excerpt is:

    foo


    Now, the build process errors out with the role-name must be defined as security-role.
    But, I cannot seem to draft the proper syntax for the security-role. I added the
    assembly-descriptor, security-role and role-name. I've tried removing the security-identity,
    run-as. Nothing helps. The original developers are long gone, so I don't even
    know where the validation is occuring. Any guidance would be appreciated.

    Sincerely, Dan (mailto:d_p_cooney@yahoo.com)


  2. Re: Upgrading from WLS6.0 to WLS7.0 EJB XML Question

    I can definitely help. Can you show me the error you get from ejbc?

    -- Rob

    Dan wrote:
    > EJB Folks,
    >
    > I posted this message on the Security newsgroup first, but have not received any
    > response. Possibly, this is more of an EJB XML question. We are upgrading from
    > WLS6.0 to WLS7.0, and after correcting various XML issues, we've stumbled over
    > a very troublesome security issue. The following is a portion of the ejb-jar.xml
    > for one of the beans:
    >
    > foo
    >

    >
    > The WLS documentation directed changing run-as-specified-identity to run-as, so
    > the reviews ejb-jar.xml excerpt is:
    >
    > foo
    >
    >
    > Now, the build process errors out with the role-name must be defined as security-role.
    > But, I cannot seem to draft the proper syntax for the security-role. I added the
    > assembly-descriptor, security-role and role-name. I've tried removing the security-identity,
    > run-as. Nothing helps. The original developers are long gone, so I don't even
    > know where the validation is occuring. Any guidance would be appreciated.
    >
    > Sincerely, Dan (mailto:d_p_cooney@yahoo.com)
    >



+ Reply to Thread