can i setup cluster in a single machine without having network - Weblogic

This is a discussion on can i setup cluster in a single machine without having network - Weblogic ; Hi everyone, i have Windows XP on my machine P4. I have installed weblogic 6.1 and deployed an application. Now i want to run the cluster. I have done the cluster set up containing 2 servers one is admin and ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: can i setup cluster in a single machine without having network

  1. can i setup cluster in a single machine without having network


    Hi everyone,

    i have Windows XP on my machine P4. I have installed weblogic 6.1 and deployed
    an application. Now i want to run the cluster.
    I have done the cluster set up containing 2 servers one is admin and another is
    managed server.

    Now, to run this weblogic cluser, do i require inernet connection ?

    If i am not in the internet, multicast test is failing.

    Only when i am in internet, my mustcast test is working fine giving the following
    output.


    ***** WARNING ***** WARNING ***** WARNING *****
    Do NOT use the same multicast address as a running WLS cluster.
    Starting test. Hit any key to abort
    Using multicast address 239.255.111.111:7001
    Will send messages under the name server100 every 2 seconds
    Will print warning every 600 seconds if no messages are received

    I (server100) sent message num 1
    I (server100) sent message num 2
    I (server100) sent message num 3
    I (server100) sent message num 4
    ..................................

    Now, even if i am in the internet and multicast is running, when i start the
    admin server, i get the following error for every 2 seconds :


    java.io.InterruptedIOException: Receive timed out
    java.io.InterruptedIOException: Receive timed out
    at java.net.PlainDatagramSocketImpl.receive(Native Method)
    at java.net.DatagramSocket.receive(DatagramSocket.jav a:392)
    at weblogic.cluster.FragmentSocket.receive(FragmentSo cket.java:145)
    at weblogic.cluster.MulticastManager.execute(Multicas tManager.java:293)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:137)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:120)

    Please suggest me what should i do.

    thanks



  2. Re: can i setup cluster in a single machine without having network


    BTW, my intension of setting up cluster in a single machine is to be familiar
    with cluster so that later i can work on live application.

    "misra " wrote:
    >
    >Hi everyone,
    >
    >i have Windows XP on my machine P4. I have installed weblogic 6.1 and
    >deployed
    >an application. Now i want to run the cluster.
    >I have done the cluster set up containing 2 servers one is admin and
    >another is
    >managed server.
    >
    >Now, to run this weblogic cluser, do i require inernet connection ?
    >
    >If i am not in the internet, multicast test is failing.
    >
    >Only when i am in internet, my mustcast test is working fine giving
    >the following
    >output.
    >
    >
    >***** WARNING ***** WARNING ***** WARNING *****
    >Do NOT use the same multicast address as a running WLS cluster.
    >Starting test. Hit any key to abort
    >Using multicast address 239.255.111.111:7001
    >Will send messages under the name server100 every 2 seconds
    >Will print warning every 600 seconds if no messages are received
    >
    > I (server100) sent message num 1
    > I (server100) sent message num 2
    > I (server100) sent message num 3
    > I (server100) sent message num 4
    > ..................................
    >
    >Now, even if i am in the internet and multicast is running, when i
    >start the
    >admin server, i get the following error for every 2 seconds :
    >
    >
    > >error:
    > java.io.InterruptedIOException: Receive timed out
    >java.io.InterruptedIOException: Receive timed out
    > at java.net.PlainDatagramSocketImpl.receive(Native Method)
    > at java.net.DatagramSocket.receive(DatagramSocket.jav a:392)
    > at weblogic.cluster.FragmentSocket.receive(FragmentSo cket.java:145)
    > at weblogic.cluster.MulticastManager.execute(Multicas tManager.java:293)
    > at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:137)
    > at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:120)
    >
    >Please suggest me what should i do.
    >
    >thanks
    >
    >



  3. Re: can i setup cluster in a single machine without having network


    No need to have Net connection. Error is due to the inclusion of admin server
    in the cluster.
    Create one more managed server and make a cluster of two managed servers under
    admin server.

    "misra" wrote:
    >
    >BTW, my intension of setting up cluster in a single machine is to be
    >familiar
    >with cluster so that later i can work on live application.
    >
    >"misra " wrote:
    >>
    >>Hi everyone,
    >>
    >>i have Windows XP on my machine P4. I have installed weblogic 6.1 and
    >>deployed
    >>an application. Now i want to run the cluster.
    >>I have done the cluster set up containing 2 servers one is admin and
    >>another is
    >>managed server.
    >>
    >>Now, to run this weblogic cluser, do i require inernet connection ?
    >>
    >>If i am not in the internet, multicast test is failing.
    >>
    >>Only when i am in internet, my mustcast test is working fine giving
    >>the following
    >>output.
    >>
    >>
    >>***** WARNING ***** WARNING ***** WARNING *****
    >>Do NOT use the same multicast address as a running WLS cluster.
    >>Starting test. Hit any key to abort
    >>Using multicast address 239.255.111.111:7001
    >>Will send messages under the name server100 every 2 seconds
    >>Will print warning every 600 seconds if no messages are received
    >>
    >> I (server100) sent message num 1
    >> I (server100) sent message num 2
    >> I (server100) sent message num 3
    >> I (server100) sent message num 4
    >> ..................................
    >>
    >>Now, even if i am in the internet and multicast is running, when i
    >>start the
    >>admin server, i get the following error for every 2 seconds :
    >>
    >>
    >> >>error:
    >> java.io.InterruptedIOException: Receive timed out
    >>java.io.InterruptedIOException: Receive timed out
    >> at java.net.PlainDatagramSocketImpl.receive(Native Method)
    >> at java.net.DatagramSocket.receive(DatagramSocket.jav a:392)
    >> at weblogic.cluster.FragmentSocket.receive(FragmentSo cket.java:145)
    >> at weblogic.cluster.MulticastManager.execute(Multicas tManager.java:293)
    >> at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:137)
    >> at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:120)
    >>
    >>Please suggest me what should i do.
    >>
    >>thanks
    >>
    >>

    >



  4. Re: can i setup cluster in a single machine without having network


    i do not think it is due to adding admin server in the cluster. In my previous
    client applications, they have added even admin server also in the cluster and
    the application is running live from months together without any error.
    But i know that if we add admin server in the cluster, there is a persformance
    issue.

    here i am getting, the multicast received time out error which is definitely
    due to some IP configuration. But i donot how to resolve. I am unable to get
    a static IP address for my machine. I have gone through the procedure of getting
    static IP address for my window XP machine. But still I am not getting the
    IP.

    So what i am doing is, when i get into internet, i am getting an IP address and
    this IP address I am using for admin server and local host address 127.0.0.1
    I am using for managed server.

    I know that i can do mulithoming and get virtual IP addresses. But nothing is
    working in my XP professioanl machine.

    I hope someone will guide me what i have missed while setting the static IP address
    and then multihoming.

    thanks

    "cheenu" wrote:
    >
    > No need to have Net connection. Error is due to the inclusion of
    >admin server
    >in the cluster.
    >Create one more managed server and make a cluster of two managed servers
    >under
    >admin server.
    >
    >"misra" wrote:
    >>
    >>BTW, my intension of setting up cluster in a single machine is to be
    >>familiar
    >>with cluster so that later i can work on live application.
    >>
    >>"misra " wrote:
    >>>
    >>>Hi everyone,
    >>>
    >>>i have Windows XP on my machine P4. I have installed weblogic 6.1

    >and
    >>>deployed
    >>>an application. Now i want to run the cluster.
    >>>I have done the cluster set up containing 2 servers one is admin and
    >>>another is
    >>>managed server.
    >>>
    >>>Now, to run this weblogic cluser, do i require inernet connection ?
    >>>
    >>>If i am not in the internet, multicast test is failing.
    >>>
    >>>Only when i am in internet, my mustcast test is working fine giving
    >>>the following
    >>>output.
    >>>
    >>>
    >>>***** WARNING ***** WARNING ***** WARNING *****
    >>>Do NOT use the same multicast address as a running WLS cluster.
    >>>Starting test. Hit any key to abort
    >>>Using multicast address 239.255.111.111:7001
    >>>Will send messages under the name server100 every 2 seconds
    >>>Will print warning every 600 seconds if no messages are received
    >>>
    >>> I (server100) sent message num 1
    >>> I (server100) sent message num 2
    >>> I (server100) sent message num 3
    >>> I (server100) sent message num 4
    >>> ..................................
    >>>
    >>>Now, even if i am in the internet and multicast is running, when

    >i
    >>>start the
    >>>admin server, i get the following error for every 2 seconds :
    >>>
    >>>
    >>> >>>error:
    >>> java.io.InterruptedIOException: Receive timed out
    >>>java.io.InterruptedIOException: Receive timed out
    >>> at java.net.PlainDatagramSocketImpl.receive(Native Method)
    >>> at java.net.DatagramSocket.receive(DatagramSocket.jav a:392)
    >>> at weblogic.cluster.FragmentSocket.receive(FragmentSo cket.java:145)
    >>> at weblogic.cluster.MulticastManager.execute(Multicas tManager.java:293)
    >>> at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:137)
    >>> at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:120)
    >>>
    >>>Please suggest me what should i do.
    >>>
    >>>thanks
    >>>
    >>>

    >>

    >



  5. Re: can i setup cluster in a single machine without having network

    Do you have two network interfaces? Setting up a cluster on a single
    machine with a single network interface is theoretically supported on
    version 7+.

    Don't need an internet connection, unless the application needs DTDs etc.,
    that need to be resolved.

    However, I have had problems without network connection...

    "misra " wrote in message
    news:3fbfb313$1@newsgroups.bea.com...
    >
    > Hi everyone,
    >
    > i have Windows XP on my machine P4. I have installed weblogic 6.1 and

    deployed
    > an application. Now i want to run the cluster.
    > I have done the cluster set up containing 2 servers one is admin and

    another is
    > managed server.
    >
    > Now, to run this weblogic cluser, do i require inernet connection ?
    >
    > If i am not in the internet, multicast test is failing.
    >
    > Only when i am in internet, my mustcast test is working fine giving the

    following
    > output.
    >
    >
    > ***** WARNING ***** WARNING ***** WARNING *****
    > Do NOT use the same multicast address as a running WLS cluster.
    > Starting test. Hit any key to abort
    > Using multicast address 239.255.111.111:7001
    > Will send messages under the name server100 every 2 seconds
    > Will print warning every 600 seconds if no messages are received
    >
    > I (server100) sent message num 1
    > I (server100) sent message num 2
    > I (server100) sent message num 3
    > I (server100) sent message num 4
    > ..................................
    >
    > Now, even if i am in the internet and multicast is running, when i start

    the
    > admin server, i get the following error for every 2 seconds :
    >
    >
    >
    error:
    > java.io.InterruptedIOException: Receive timed out
    > java.io.InterruptedIOException: Receive timed out
    > at java.net.PlainDatagramSocketImpl.receive(Native Method)
    > at java.net.DatagramSocket.receive(DatagramSocket.jav a:392)
    > at

    weblogic.cluster.FragmentSocket.receive(FragmentSo cket.java:145)
    > at

    weblogic.cluster.MulticastManager.execute(Multicas tManager.java:293)
    > at weblogic.kernel.ExecuteThread.execute(ExecuteThrea d.java:137)
    > at weblogic.kernel.ExecuteThread.run(ExecuteThread.ja va:120)
    >
    > Please suggest me what should i do.
    >
    > thanks
    >
    >