FAILOVER_REQUIRED messages from iPlanet plugin - Weblogic

This is a discussion on FAILOVER_REQUIRED messages from iPlanet plugin - Weblogic ; Recently we were in the middle of recycling the servers in one of our production clusters. This is a WLS 8.1sp1 cluster with two servers, sitting behind some iPlanet instances that have the WebLogic proxy plugin installed. The first server ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: FAILOVER_REQUIRED messages from iPlanet plugin

  1. FAILOVER_REQUIRED messages from iPlanet plugin


    Recently we were in the middle of recycling the servers in one of our production
    clusters. This is a WLS 8.1sp1 cluster with two servers, sitting behind some
    iPlanet instances that have the WebLogic proxy plugin installed. The first server
    had shut down and been restarted and the other one was suspended, waiting for
    sessions to expire before it could gracefully shutdown. During this time, we
    started seeing errors like this in the iPlanet log:

    [24/Oct/2003:12:20:18] failure ( 5675): for host 204.154.227.xxx trying to GET
    /oao/login.jsp, wl-proxy reports: exception occurred for backend host '10.1.100.xxx/8200':
    'FAILOVER_REQUIRED [line 1320 of proxy.cpp]: Service Unavailable'

    Hitting the WebLogicBridgeConfig page on the different iPlanet instances showed
    that some of the still had the shutting-down server in their list of servers marked
    OK, and some did not show it at all.

    Can anyone give me some information about what this error message means?

    Thanks,
    Tim


  2. Re: FAILOVER_REQUIRED messages from iPlanet plugin


    Upon further review, it seems like that message simply means that an incoming request
    was routed to a WebLogic instance that returned an HTTP 503, meaning that it's
    unable to service the request because it's in the process of suspending. At this
    point the proxy needs to try to fail over to a different server in the cluster,
    and I think that's all the message means. Our problem was that when this was
    happening, the proxy did not seem to believe that there were any other servers
    available in the cluster, even though there was one. The reason why is a long
    story, and we're waiting for a definitive answer from BEA on the issue; if anybody
    wants more info, please let me know.

    - Tim

    "Tim Kannenberg" wrote:
    >
    >Recently we were in the middle of recycling the servers in one of our
    >production
    >clusters. This is a WLS 8.1sp1 cluster with two servers, sitting behind
    >some
    >iPlanet instances that have the WebLogic proxy plugin installed. The
    >first server
    >had shut down and been restarted and the other one was suspended, waiting
    >for
    >sessions to expire before it could gracefully shutdown. During this
    >time, we
    >started seeing errors like this in the iPlanet log:
    >
    >[24/Oct/2003:12:20:18] failure ( 5675): for host 204.154.227.xxx trying
    >to GET
    >/oao/login.jsp, wl-proxy reports: exception occurred for backend host
    >'10.1.100.xxx/8200':
    >'FAILOVER_REQUIRED [line 1320 of proxy.cpp]: Service Unavailable'
    >
    >Hitting the WebLogicBridgeConfig page on the different iPlanet instances
    >showed
    >that some of the still had the shutting-down server in their list of
    >servers marked
    >OK, and some did not show it at all.
    >
    >Can anyone give me some information about what this error message means?
    >
    >Thanks,
    >Tim
    >



  3. Re: FAILOVER_REQUIRED messages from iPlanet plugin

    Hi Tim,

    I would love some more info on this error - If you don't mind.
    Did BEA/oracle deem this a bug? Is it related to the plugin? I am currently seeing this error along with "'PROTOCOL_ERROR [line 837 of URL.cpp]: Backend Server not responding'
    " running under WLS 9.2 and iPlanet 6.1 SP5.


    Thanks,
    -victor

  4. Re: FAILOVER_REQUIRED messages from iPlanet plugin

    Windows 2003 can do load balancing of network services, using Clustering

+ Reply to Thread