NullPointerException on start-up - Weblogic

This is a discussion on NullPointerException on start-up - Weblogic ; I'm getting a NullPointerException on startup. After modifying the domain via the console, I cannot start up the domain anymore. I attempted to copy config.xml.booted onto config.xml and I get the same problem. My domain: 1 AdminServer 2 Managed Servers ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: NullPointerException on start-up

  1. NullPointerException on start-up


    I'm getting a NullPointerException on startup. After modifying the domain via
    the console, I cannot start up the domain anymore. I attempted to copy config.xml.booted
    onto config.xml and I get the same problem.

    My domain:
    1 AdminServer
    2 Managed Servers in a cluster
    1 Managed Server not participating int the cluster

    WebLogic 7.x sp2
    OS: RedHat 7.3
    JVM: Sun 1.3.1_03



    Here is the stacktrace I get on startup:

    <000364> during initialization. Exception:weblogic.management.configuration.Config urationException:
    Error parsing the configuration file: null - with nested exception:
    [java.lang.NullPointerException]
    java.lang.NullPointerException
    at weblogic.management.internal.xml.ConfigurationPars er$ConfigurationHandler.resolveMBeanAttributes(Con figurationParser.java:871)
    at weblogic.management.internal.xml.ConfigurationPars er$ConfigurationHandler.endDocument(ConfigurationP arser.java:339)
    at weblogic.apache.xerces.parsers.SAXParser.endDocume nt(SAXParser.java:1235)
    at weblogic.apache.xerces.validators.common.XMLValida tor.callEndDocument(XMLValidator.java:1159)
    at weblogic.apache.xerces.framework.XMLDocumentScanne r$EndOfInputDispatcher.dispatch(XMLDocumentScanner .java:1531)
    at weblogic.apache.xerces.framework.XMLDocumentScanne r.parseSome(XMLDocumentScanner.java:399)
    at weblogic.apache.xerces.framework.XMLParser.parse(X MLParser.java:1138)
    at weblogic.management.internal.xml.ConfigurationPars er.parse(ConfigurationParser.java:227)
    at weblogic.management.internal.xml.XmlFileRepository .createOrLoadDomain(XmlFileRepository.java:483)
    at weblogic.management.internal.xml.XmlFileRepository .bootStrapAndLoadActiveDomain(XmlFileRepository.ja va:354)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:217)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:202)
    at weblogic.management.AdminServer.configure(AdminSer ver.java:196)
    at weblogic.management.AdminServerAdmin.initialize(Ad minServerAdmin.java:111)
    at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:66 4)
    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
    at weblogic.Server.main(Server.java:32)
    --------------- nested within: ------------------
    weblogic.management.configuration.ConfigurationExc eption: Error parsing the configuration
    file: null - with nested exception:
    [java.lang.NullPointerException]
    at weblogic.management.internal.xml.ConfigurationPars er.parse(ConfigurationParser.java:243)
    at weblogic.management.internal.xml.XmlFileRepository .createOrLoadDomain(XmlFileRepository.java:483)
    at weblogic.management.internal.xml.XmlFileRepository .bootStrapAndLoadActiveDomain(XmlFileRepository.ja va:354)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:217)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:202)
    at weblogic.management.AdminServer.configure(AdminSer ver.java:196)
    at weblogic.management.AdminServerAdmin.initialize(Ad minServerAdmin.java:111)
    at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:66 4)
    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
    at weblogic.Server.main(Server.java:32)
    >

    ************************************************** *************************
    The WebLogic Server did not start up properly.
    Exception raised:
    java.lang.NullPointerException
    at weblogic.management.internal.xml.ConfigurationPars er$ConfigurationHandler.resolveMBeanAttributes(Con figurationParser.java:871)
    at weblogic.management.internal.xml.ConfigurationPars er$ConfigurationHandler.endDocument(ConfigurationP arser.java:339)
    at weblogic.apache.xerces.parsers.SAXParser.endDocume nt(SAXParser.java:1235)
    at weblogic.apache.xerces.validators.common.XMLValida tor.callEndDocument(XMLValidator.java:1159)
    at weblogic.apache.xerces.framework.XMLDocumentScanne r$EndOfInputDispatcher.dispatch(XMLDocumentScanner .java:1531)
    at weblogic.apache.xerces.framework.XMLDocumentScanne r.parseSome(XMLDocumentScanner.java:399)
    at weblogic.apache.xerces.framework.XMLParser.parse(X MLParser.java:1138)
    at weblogic.management.internal.xml.ConfigurationPars er.parse(ConfigurationParser.java:227)
    at weblogic.management.internal.xml.XmlFileRepository .createOrLoadDomain(XmlFileRepository.java:483)
    at weblogic.management.internal.xml.XmlFileRepository .bootStrapAndLoadActiveDomain(XmlFileRepository.ja va:354)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:217)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:202)
    at weblogic.management.AdminServer.configure(AdminSer ver.java:196)
    at weblogic.management.AdminServerAdmin.initialize(Ad minServerAdmin.java:111)
    at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:66 4)
    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
    at weblogic.Server.main(Server.java:32)
    --------------- nested within: ------------------
    weblogic.management.configuration.ConfigurationExc eption: Error parsing the configuration
    file: null - with nested exception:
    [java.lang.NullPointerException]
    at weblogic.management.internal.xml.ConfigurationPars er.parse(ConfigurationParser.java:243)
    at weblogic.management.internal.xml.XmlFileRepository .createOrLoadDomain(XmlFileRepository.java:483)
    at weblogic.management.internal.xml.XmlFileRepository .bootStrapAndLoadActiveDomain(XmlFileRepository.ja va:354)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:217)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:202)
    at weblogic.management.AdminServer.configure(AdminSer ver.java:196)
    at weblogic.management.AdminServerAdmin.initialize(Ad minServerAdmin.java:111)
    at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:66 4)
    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
    at weblogic.Server.main(Server.java:32)
    Reason: Fatal initialization exception
    Throwable: weblogic.management.configuration.ConfigurationExc eption: Error parsing
    the configuration file: null - with nested exception:
    [java.lang.NullPointerException]
    java.lang.NullPointerException
    at weblogic.management.internal.xml.ConfigurationPars er$ConfigurationHandler.resolveMBeanAttributes(Con figurationParser.java:871)
    at weblogic.management.internal.xml.ConfigurationPars er$ConfigurationHandler.endDocument(ConfigurationP arser.java:339)
    at weblogic.apache.xerces.parsers.SAXParser.endDocume nt(SAXParser.java:1235)
    at weblogic.apache.xerces.validators.common.XMLValida tor.callEndDocument(XMLValidator.java:1159)
    at weblogic.apache.xerces.framework.XMLDocumentScanne r$EndOfInputDispatcher.dispatch(XMLDocumentScanner .java:1531)
    at weblogic.apache.xerces.framework.XMLDocumentScanne r.parseSome(XMLDocumentScanner.java:399)
    at weblogic.apache.xerces.framework.XMLParser.parse(X MLParser.java:1138)
    at weblogic.management.internal.xml.ConfigurationPars er.parse(ConfigurationParser.java:227)
    at weblogic.management.internal.xml.XmlFileRepository .createOrLoadDomain(XmlFileRepository.java:483)
    at weblogic.management.internal.xml.XmlFileRepository .bootStrapAndLoadActiveDomain(XmlFileRepository.ja va:354)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:217)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:202)
    at weblogic.management.AdminServer.configure(AdminSer ver.java:196)
    at weblogic.management.AdminServerAdmin.initialize(Ad minServerAdmin.java:111)
    at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:66 4)
    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
    at weblogic.Server.main(Server.java:32)
    --------------- nested within: ------------------
    weblogic.management.configuration.ConfigurationExc eption: Error parsing the configuration
    file: null - with nested exception:
    [java.lang.NullPointerException]
    at weblogic.management.internal.xml.ConfigurationPars er.parse(ConfigurationParser.java:243)
    at weblogic.management.internal.xml.XmlFileRepository .createOrLoadDomain(XmlFileRepository.java:483)
    at weblogic.management.internal.xml.XmlFileRepository .bootStrapAndLoadActiveDomain(XmlFileRepository.ja va:354)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:217)
    at weblogic.management.AdminServer.configureFromRepos itory(AdminServer.java:202)
    at weblogic.management.AdminServer.configure(AdminSer ver.java:196)
    at weblogic.management.AdminServerAdmin.initialize(Ad minServerAdmin.java:111)
    at weblogic.t3.srvr.T3Srvr.initialize1(T3Srvr.java:66 4)
    at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:594 )
    at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:282)
    at weblogic.Server.main(Server.java:32)

    ************************************************** *************************



    Has anyone seen this before? How did you get around it?

    Thanks

  2. Re: NullPointerException on start-up

    "Doug Walker" wrote in message news:<3f170463$1@newsgroups.bea.com>...
    > I'm getting a NullPointerException on startup. After modifying the domain via
    > the console, I cannot start up the domain anymore. I attempted to copy config.xml.booted
    > onto config.xml and I get the same problem.




    > Has anyone seen this before?


    I am getting it right now!! (WLS 7.0 SP1).

    > How did you get around it?


    I am desperately in search of a solution. One thing that I noticed is,
    that config.xml.booted is not the same as the config.xml that the
    server was booted with. The admin server rewrites the config.xml and
    the config.xml.booted, which explains why a good config.xml sometimes
    becomes bad.

    > Thanks


  3. Re: NullPointerException on start-up

    "Doug Walker" wrote in message news:<3f170463$1@newsgroups.bea.com>...
    > I'm getting a NullPointerException on startup. After modifying the domain via
    > the console, I cannot start up the domain anymore. I attempted to copy config.xml.booted
    > onto config.xml and I get the same problem.


    Are you using the same name for the domain as for the cluster?? If so,
    clone the cluster, give it a name different from the domain, move your
    applications, connection pools, etc to the new cluster, and delete the
    old cluster.

    Hope this helps.

  4. Re: NullPointerException on start-up

    Do you have a stack trace for the exception? That should give a clue of what
    went wrong.

    /
    sree
    "Jan Bruun Andersen" wrote in message
    news:7dab6ffb.0308041613.6a50a75f@posting.google.c om...
    > "Doug Walker" wrote in message

    news:<3f170463$1@newsgroups.bea.com>...
    > > I'm getting a NullPointerException on startup. After modifying the

    domain via
    > > the console, I cannot start up the domain anymore. I attempted to copy

    config.xml.booted
    > > onto config.xml and I get the same problem.

    >
    > Are you using the same name for the domain as for the cluster?? If so,
    > clone the cluster, give it a name different from the domain, move your
    > applications, connection pools, etc to the new cluster, and delete the
    > old cluster.
    >
    > Hope this helps.




  5. Re: NullPointerException on start-up


    OIRZQQPYOETK@spammotel.com (Jan Bruun Andersen) wrote:
    >"Doug Walker" wrote in message news:<3f170463$1@newsgroups.bea.com>...
    >> I'm getting a NullPointerException on startup. After modifying the

    >domain via
    >> the console, I cannot start up the domain anymore. I attempted to

    >copy config.xml.booted
    >> onto config.xml and I get the same problem.

    >
    >Are you using the same name for the domain as for the cluster?? If so,
    >clone the cluster, give it a name different from the domain, move your
    >applications, connection pools, etc to the new cluster, and delete the
    >old cluster.
    >
    >Hope this helps.




    This solved the problem. Thank you very much!!!

+ Reply to Thread