Problem with booting vxworks standalone binary image - VxWorks

This is a discussion on Problem with booting vxworks standalone binary image - VxWorks ; Hello all, I am trying to boot a Vxworks standalone binary image from ROM without using a bootrom. The kernel comes up ok but reports 'Adding 0 symbols for standalone'. I checked the symTbl.c file and standTblSize has a reasonable ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problem with booting vxworks standalone binary image

  1. Problem with booting vxworks standalone binary image

    Hello all,
    I am trying to boot a Vxworks standalone binary image from ROM without
    using a bootrom.

    The kernel comes up ok but reports 'Adding 0 symbols for standalone'.
    I checked the symTbl.c file and standTblSize has a reasonable value. I
    can't find out
    why or where standTblSize is being reset back to zero.

    Does the utility objcopyppc removes symbols when it makes a binary ?
    How can I retain symbols in binary images ?

    Thanks for your suggestions.
    -shru


  2. Re: Problem with booting vxworks standalone binary image

    On Jun 15, 4:31 pm, "psgrshru...@gmail.com"
    wrote:
    > Hello all,
    > I am trying to boot a Vxworks standalone binary image from ROM without
    > using a bootrom.
    >
    > The kernel comes up ok but reports 'Adding 0 symbols for standalone'.
    > I checked the symTbl.c file and standTblSize has a reasonable value. I
    > can't find out
    > why or where standTblSize is being reset back to zero.
    >
    > Does the utility objcopyppc removes symbols when it makes a binary ?
    > How can I retain symbols in binary images ?
    >
    > Thanks for your suggestions.
    > -shru


    Hi,
    I am not sure whether this will help you resolve the problem.But worth
    giving a try:
    Try including the following macros in your build:
    INCLUDE_SYM_TBL, INCLUDE_SYM_TBL_INIT, INCLUDE_STANDALONE_SYM_TBL

    Regards,
    s.subbarayan


  3. Re: Problem with booting vxworks standalone binary image

    What command are you using to build the standalone image? If you
    aren't already, try using "make vxWorks.st", where the st stands for
    symbol table, and thus includes it.

    regards
    Gavin Nottage
    Harmonic Software Systems


+ Reply to Thread