"Error: Simulator Failed to initialize before timeout" - VxWorks

This is a discussion on "Error: Simulator Failed to initialize before timeout" - VxWorks ; Hi everybody, While starting VxSim, i got error message "Error: Simulator Failed to initialize before timeout" and Simulator did not get started. Can anybody help me to solve the problem....

+ Reply to Thread
Results 1 to 13 of 13

Thread: "Error: Simulator Failed to initialize before timeout"

  1. "Error: Simulator Failed to initialize before timeout"

    Hi everybody,

    While starting VxSim, i got error message "Error: Simulator Failed to
    initialize before timeout" and Simulator did not get started.
    Can anybody help me to solve the problem.


  2. Re: "Error: Simulator Failed to initialize before timeout"

    I guess it's set up issue. Double check the selected
    options under the menu Tools->Target Server->Configure


    s.manimaran1976@gmail.com wrote:
    > Hi everybody,
    >
    > While starting VxSim, i got error message "Error: Simulator Failed to
    > initialize before timeout" and Simulator did not get started.
    > Can anybody help me to solve the problem.



  3. Re: "Error: Simulator Failed to initialize before timeout"


    I did not configure anything under Tools->Target Server->configure. I
    just started VxSim. It reported the above error message and stopped.
    Can anybody tell step by step solution.


  4. Re: "Error: Simulator Failed to initialize before timeout"


    Select the "standard simulator" when launching the target server. Do
    not use Custum built simulator.


    s.manimaran1976@gmail.com wrote:
    > I did not configure anything under Tools->Target Server->configure. I
    > just started VxSim. It reported the above error message and stopped.
    > Can anybody tell step by step solution.



  5. Re: "Error: Simulator Failed to initialize before timeout"


    Thanks vij. But it gave the same problem when i launch Custom
    Simulator. I need to know root cause of problem. Can you help in this
    regard.


  6. Re: "Error: Simulator Failed to initialize before timeout"


    Thanks Vij.

    I observed the same problem even i launch Standard Simulator.

    Basically i need to know root cause of this problem.

    Can you help in this regard.


  7. Re: "Error: Simulator Failed to initialize before timeout"

    Hi Manimaran,

    You get this timeout when you observe Exception 13: Voilation Error on
    the vxSim screen which opens on clicking the VXSIM ICON in the menu
    bar. This "timeout" problems occurs due to lot more causes like:
    (a) When the vxSim window launches properly but the target server
    doesn't which shows a exclaimatory mark on the Bulls-Eye icon in the
    system tray.
    (b) When the vxSim window launches properly but the next upcoming
    window shows "System Error" / "Network Error" and you may be asked to
    contact your system administrator. But this error is very rare.
    (c) When you choose Custom Built Simulator and the path doesn't match
    as that of project created but forcibly try launching the simulator,
    you can encounter this error. But in this case it can be avoided as the
    "Launch Target Sever => Details => choose Full Simulator instead of
    Integrated simulator => Click OK". Then launch the target server from
    the Tool => Target Server => create a new one, give proper image path
    and later is as guided in the manuals.

    I hope the above explaination answers your query.

    Regards
    Pappuda


    s.manimaran1976@gmail.com wrote:
    > Hi everybody,
    >
    > While starting VxSim, i got error message "Error: Simulator Failed to
    > initialize before timeout" and Simulator did not get started.
    > Can anybody help me to solve the problem.



  8. Re: "Error: Simulator Failed to initialize before timeout"


    Thanks pappuda,

    I tried your suggestion. But it did not worked at all.

    Actually i installed tornado 2.2 3 months back and i used to click icon
    "Launch Simulator" to launch Standard/Custom Simulator. It worked
    nicely.

    Last week, the problem appeared suddently.

    when i start Standard Simulator, VxSim Console opened and Closed
    within two seconds reported me "Error: Simulator failed to initialize
    before Timeout".
    When i launch Custom Simulator, the same error got appeared after a
    minute.

    when i lauch target server, i got following error mesage

    tgtsvr (vxSim0@Manimaran): Thu Aug 17 10:04:14 2006
    Checking License ...OK
    Connecting to target agent...
    Error: rpccore backend client Timed out
    failed.
    Connecting to target agent...
    Error: rpccore backend client Timed out
    failed.
    Connecting to target agent...

    I want to know, Root cause first problem and solution.


  9. Re: "Error: Simulator Failed to initialize before timeout"

    The same error started to appear on my Tornado when I installed Win XP
    Aug 2006 Security paths, so I suspect that is the reason,
    I reported it to our System & Network support and awaiting for results
    of their investigation

    regards,
    Piotrek


  10. Re: "Error: Simulator Failed to initialize before timeout"

    Hi all,

    Problem is Solved.
    Problem is due to WinXP August Security Updates.
    I uninstalled those updates and found tornado Simulator/Target Server
    is Working.
    Thanks for your cooperation.


  11. Re: "Error: Simulator Failed to initialize before timeout"

    there is no need to uninstall WinXP August Security Updates,
    problem got solved also after WinXP Service Pack 2 installation

    regards,
    Piotrek


  12. Re: "Error: Simulator Failed to initialize before timeout"


    optyk wrote:
    > there is no need to uninstall WinXP August Security Updates,
    > problem got solved also after WinXP Service Pack 2 installation
    >
    > regards,
    > Piotrek


    Hey optyk ....
    Can you tell me how to fix the issue without uninstalling Security
    updates.


  13. Re: "Error: Simulator Failed to initialize before timeout"

    if you installed Aug Security Patches, just install WinXP SP2,
    it helped in my case

    regards,
    Piotrek


+ Reply to Thread