Connection to target's FTP server problem - VxWorks

This is a discussion on Connection to target's FTP server problem - VxWorks ; Hi, I use Tornado 2.0 on WIN-XP host, and I'm unable to log in to the FTP server on target from the FTP client on XP. The INCLUDE_FTP_SERVER component is included, and the "tFtpdTask" is running. When I start an ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: Connection to target's FTP server problem

  1. Connection to target's FTP server problem

    Hi,

    I use Tornado 2.0 on WIN-XP host, and I'm unable to log in to the FTP
    server on target from the FTP client on XP.
    The INCLUDE_FTP_SERVER component is included, and the "tFtpdTask" is
    running.

    When I start an FTP session from DOS, I get:
    C:\>ftp 1.100.100.11
    Connected to 1.100.100.11.

    and after a long time, I get:
    Connection closed by remote host.

    On target, I get:
    0x1cd75490 (tFtpdTask): accepted a new client connection from
    1.100.100.10
    0x1cd75490 (tFtpdTask): creating a new server task tFtpdServ1...
    0x1cd75490 (tFtpdTask): done.
    0x1cd75490 (tFtpdTask): waiting for a new client connection...

    And I can see the new "tFtpdServ1" running.


    Does anyone know what is the problem, and how to solve it?

    Thanks,
    Asaf


  2. Re: Connection to target's FTP server problem

    Take a look at the vxWorks FAQ in the FTP problems section. Looks like
    you've already turned on debug - maybe the registry timeout issue might
    apply.

    I use it from XP and it works OK. Is your tftpserv1 task OK - ie not
    suspended?

    If you get desprate, etherreal is excellent for debugging FTP issues.

    lc

    Asaf Sinai wrote:
    > Hi,
    >
    > I use Tornado 2.0 on WIN-XP host, and I'm unable to log in to the FTP
    > server on target from the FTP client on XP.
    > The INCLUDE_FTP_SERVER component is included, and the "tFtpdTask" is
    > running.
    >
    > When I start an FTP session from DOS, I get:
    > C:\>ftp 1.100.100.11
    > Connected to 1.100.100.11.
    >
    > and after a long time, I get:
    > Connection closed by remote host.
    >
    > On target, I get:
    > 0x1cd75490 (tFtpdTask): accepted a new client connection from
    > 1.100.100.10
    > 0x1cd75490 (tFtpdTask): creating a new server task tFtpdServ1...
    > 0x1cd75490 (tFtpdTask): done.
    > 0x1cd75490 (tFtpdTask): waiting for a new client connection...
    >
    > And I can see the new "tFtpdServ1" running.
    >
    >
    > Does anyone know what is the problem, and how to solve it?
    >
    > Thanks,
    > Asaf



+ Reply to Thread