ifShow does not display the network interfaces - VxWorks

This is a discussion on ifShow does not display the network interfaces - VxWorks ; Hi, When i execute ifShow , it does not show me the network interfaces. I have included the network constants in the config.h and configAll.h. Does anyone know how to manually add the n/w interfaces lo and an ethernet interface? ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: ifShow does not display the network interfaces

  1. ifShow does not display the network interfaces

    Hi,

    When i execute ifShow , it does not show me the network interfaces.
    I have included the network constants in the config.h and configAll.h.

    Does anyone know how to manually add the n/w interfaces lo and an
    ethernet interface?

    Rgds,
    Maniac


  2. Re: ifShow does not display the network interfaces


    Maniac wrote:
    > Hi,
    >
    > When i execute ifShow , it does not show me the network interfaces.
    > I have included the network constants in the config.h and configAll.h.
    >
    > Does anyone know how to manually add the n/w interfaces lo and an
    > ethernet interface?
    >
    > Rgds,
    > Maniac


    Hello,
    have you included Network Show routines ( macro INCLUDE_NET_SHOW )
    when building your project ?
    The other reason may be that your network device is not declared


  3. Re: ifShow does not display the network interfaces

    yes, its included but still not displayed


  4. Re: ifShow does not display the network interfaces


    Maniac wrote:
    > yes, its included but still not displayed


    hello again,

    I think that you must give more details about your config and your boot
    parameters.

    Regards


  5. Re: ifShow does not display the network interfaces

    Have you issued ipAttach() with
    appropriate device name(s)
    for your network interfaces?

    Best,
    Akiva Sadovski


+ Reply to Thread