Problems with new installation (Industrial Devices) - VxWorks

This is a discussion on Problems with new installation (Industrial Devices) - VxWorks ; Hi, We had a license of "VxWorks Developer's Toolkit 2.2.1". When the license was renewed, we changed to the "VxWorks Industrial Devices" platform. After installing and getting my old source code and projects back into Tornado, I now can't compile ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: Problems with new installation (Industrial Devices)

  1. Problems with new installation (Industrial Devices)

    Hi,
    We had a license of "VxWorks Developer's Toolkit 2.2.1". When the license
    was renewed, we changed to the "VxWorks Industrial Devices" platform.

    After installing and getting my old source code and projects back into
    Tornado, I now can't compile one of my projects anymore. Or rather: I can't
    link it.

    When I loaded and tried to compile my project (which is a boot-image project
    for a Kontron CP605 Pentium CPU board), I got information from Tornado
    saying:

    "Your project contains configuration errors. In the VxWorks' view, follow
    the highlighted folders (colored red by default) until you reach the
    component(s) or selection(s) annotated with the error icon. Double-click
    each of these to display the property sheets. The first property page will
    describe the error"

    The components I had to changed were mostly related to network components,
    including a "ARP Table for Ethernet" which had to be included.

    After this, the project compiled OK, but did not link. The error is:

    partialImage.o: In function `usrIfProxyArpInit':
    c:\unifis3000\sw\unifis101\CP605image\default\C:\T ornado2.2\target\config\comps\src\net\us
    rNetLib.c:125: undefined reference to `proxyArpDefaultOn'
    c:\unifis3000\sw\unifis101\CP605image\default\C:\T ornado2.2\target\config\comps\src\net\us
    rNetLib.c:127: undefined reference to `proxyArpDefaultOff'
    make: *** [vxWorks] Error 0x1

    Any ideas how to included whatever library is needed?


    Thanks for any input!

    Best regards,

    Jostein




  2. Re: Problems with new installation (Industrial Devices)

    Sorry folks,

    my mistake (as suspected...). I hadn't compiled the libraries for the
    relevant target system - this step was not necessary in my previous
    platform.

    Thanks anyways!

    Best regards,
    jostein



    "K. Hv." wrote in message
    news:CfSdnb02HaOTqp3eRVnzvA@telenor.com...
    > Hi,
    > We had a license of "VxWorks Developer's Toolkit 2.2.1". When the license
    > was renewed, we changed to the "VxWorks Industrial Devices" platform.
    >
    > After installing and getting my old source code and projects back into
    > Tornado, I now can't compile one of my projects anymore. Or rather: I
    > can't link it.
    >
    > When I loaded and tried to compile my project (which is a boot-image
    > project for a Kontron CP605 Pentium CPU board), I got information from
    > Tornado saying:
    >
    > "Your project contains configuration errors. In the VxWorks' view, follow
    > the highlighted folders (colored red by default) until you reach the
    > component(s) or selection(s) annotated with the error icon. Double-click
    > each of these to display the property sheets. The first property page will
    > describe the error"
    >
    > The components I had to changed were mostly related to network components,
    > including a "ARP Table for Ethernet" which had to be included.
    >
    > After this, the project compiled OK, but did not link. The error is:
    >
    > partialImage.o: In function `usrIfProxyArpInit':
    > c:\unifis3000\sw\unifis101\CP605image\default\C:\T ornado2.2\target\config\comps\src\net\us
    > rNetLib.c:125: undefined reference to `proxyArpDefaultOn'
    > c:\unifis3000\sw\unifis101\CP605image\default\C:\T ornado2.2\target\config\comps\src\net\us
    > rNetLib.c:127: undefined reference to `proxyArpDefaultOff'
    > make: *** [vxWorks] Error 0x1
    >
    > Any ideas how to included whatever library is needed?
    >
    >
    > Thanks for any input!
    >
    > Best regards,
    >
    > Jostein
    >
    >
    >




  3. Re: Problems with new installation (Industrial Devices)


    add following code to sysLib.c

    static unsigned int proxyArpDefault =0;

    int proxyArpDefaultOff(void)

    {

    proxyArpDefault = 0;

    return 0;

    }

    int proxyArpDefaultOn(void)

    {

    proxyArpDefault = 0;

    return 0;

    }


    "K. Hv." wrote:
    >Sorry folks,
    >
    >my mistake (as suspected...). I hadn't compiled the libraries for the
    >relevant target system - this step was not necessary in my previous
    >platform.
    >
    >Thanks anyways!
    >
    >Best regards,
    >jostein
    >
    >
    >
    >"K. Hv." wrote in message
    >news:CfSdnb02HaOTqp3eRVnzvA@telenor.com...
    >> Hi,
    >> We had a license of "VxWorks Developer's Toolkit 2.2.1". When the license


    >> was renewed, we changed to the "VxWorks Industrial Devices" platform.
    >>
    >> After installing and getting my old source code and projects back into


    >> Tornado, I now can't compile one of my projects anymore. Or rather: I


    >> can't link it.
    >>
    >> When I loaded and tried to compile my project (which is a boot-image
    >> project for a Kontron CP605 Pentium CPU board), I got information from


    >> Tornado saying:
    >>
    >> "Your project contains configuration errors. In the VxWorks' view, follow


    >> the highlighted folders (colored red by default) until you reach the
    >> component(s) or selection(s) annotated with the error icon. Double-click


    >> each of these to display the property sheets. The first property page

    will
    >> describe the error"
    >>
    >> The components I had to changed were mostly related to network components,


    >> including a "ARP Table for Ethernet" which had to be included.
    >>
    >> After this, the project compiled OK, but did not link. The error is:
    >>
    >> partialImage.o: In function `usrIfProxyArpInit':
    >> c:\unifis3000\sw\unifis101\CP605image\default\C:\T ornado2.2\target\config\comps\src\net\us
    >> rNetLib.c:125: undefined reference to `proxyArpDefaultOn'
    >> c:\unifis3000\sw\unifis101\CP605image\default\C:\T ornado2.2\target\config\comps\src\net\us
    >> rNetLib.c:127: undefined reference to `proxyArpDefaultOff'
    >> make: *** [vxWorks] Error 0x1
    >>
    >> Any ideas how to included whatever library is needed?
    >>
    >>
    >> Thanks for any input!
    >>
    >> Best regards,
    >>
    >> Jostein
    >>
    >>
    >>

    >
    >



+ Reply to Thread