problem in PING, where to suspect.(inconsistent PING ) - VxWorks

This is a discussion on problem in PING, where to suspect.(inconsistent PING ) - VxWorks ; Hi, 1. We are using the Vxworks5.5 for PowerPC and developing a BSP for 7410 processor based board. and the controller is cpc700. Our Board is using the AMD's AM79c972 Ethernet Controller in PCI bus. We are facing problem in ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: problem in PING, where to suspect.(inconsistent PING )

  1. problem in PING, where to suspect.(inconsistent PING )

    Hi,


    1. We are using the Vxworks5.5 for PowerPC and developing a BSP for
    7410 processor based board.
    and the controller is cpc700.
    Our Board is using the AMD's AM79c972 Ethernet Controller in PCI
    bus.
    We are facing problem in the PING itself. The ping is not
    consistent.
    If i try to ping some remote host from the board it is not giving
    consistent output. I don't know where to
    suspect.

    NOTE: We are using the Linux's boot loader (uBOOT) to load the vxworks
    image, we have simply called the function "usrNetInit" from the target
    shell to install the network driver. no other functions are used to
    configure the driver.



    2. UDP packets on reception showing the checksum error in shell
    command "udpstatShow" .

    3. Network commands ( ls, dirList, dirs...) are not working. But while
    loading the driver no errors reported.



    4. windriver has provided ln97xEnd.c driver for this controller.
    but this Driver is not working correctly. So i verified with the
    workbench's ln97xEnd.c driver.
    In that lots of modifications has been from the last history of
    the tornado5.5.

    the last history date in workbench6.5 we have--> 01v,11may06
    the last history date in tornado5.5 we have--> 01o,15jan03

    Even i tried porting from the WB6.5 to vx5.5 but some part of the
    definitions is not available.
    how to get the updated driver.

    suggestion or solution will be greatly appreciated.


    Thank you
    Aravindhan

  2. Re: problem in PING, where to suspect.(inconsistent PING )

    Hi,

    What do you mean with inconsistent?

    Johnny

    "arvind" wrote in message
    news:5d078768-6f31-4a67-b955-9fc271abeb2b@i29g2000prf.googlegroups.com...
    > Hi,
    >
    >
    > 1. We are using the Vxworks5.5 for PowerPC and developing a BSP for
    > 7410 processor based board.
    > and the controller is cpc700.
    > Our Board is using the AMD's AM79c972 Ethernet Controller in PCI
    > bus.
    > We are facing problem in the PING itself. The ping is not
    > consistent.
    > If i try to ping some remote host from the board it is not giving
    > consistent output. I don't know where to
    > suspect.
    >
    > NOTE: We are using the Linux's boot loader (uBOOT) to load the vxworks
    > image, we have simply called the function "usrNetInit" from the target
    > shell to install the network driver. no other functions are used to
    > configure the driver.
    >
    >
    >
    > 2. UDP packets on reception showing the checksum error in shell
    > command "udpstatShow" .
    >
    > 3. Network commands ( ls, dirList, dirs...) are not working. But while
    > loading the driver no errors reported.
    >
    >
    >
    > 4. windriver has provided ln97xEnd.c driver for this controller.
    > but this Driver is not working correctly. So i verified with the
    > workbench's ln97xEnd.c driver.
    > In that lots of modifications has been from the last history of
    > the tornado5.5.
    >
    > the last history date in workbench6.5 we have--> 01v,11may06
    > the last history date in tornado5.5 we have--> 01o,15jan03
    >
    > Even i tried porting from the WB6.5 to vx5.5 but some part of the
    > definitions is not available.
    > how to get the updated driver.
    >
    > suggestion or solution will be greatly appreciated.
    >
    >
    > Thank you
    > Aravindhan




  3. Re: problem in PING, where to suspect.(inconsistent PING )

    On Jan 17, 10:16 pm, "Johnny Willemsen" wrote:
    > Hi,
    >
    > What do you mean with inconsistent?
    >
    > Johnny
    >
    > "arvind" wrote in message
    >
    > news:5d078768-6f31-4a67-b955-9fc271abeb2b@i29g2000prf.googlegroups.com...
    >
    >
    >
    >
    >
    > > Hi,

    >
    > > 1. We are using the Vxworks5.5 for PowerPC and developing a BSP for
    > > 7410 processor based board.
    > > and the controller is cpc700.
    > > Our Board is using the AMD's AM79c972 Ethernet Controller in PCI
    > > bus.
    > > We are facing problem in the PING itself. The ping is not
    > > consistent.
    > > If i try to ping some remote host from the board it is not giving
    > > consistent output. I don't know where to
    > > suspect.

    >
    > > NOTE: We are using the Linux's boot loader (uBOOT) to load the vxworks
    > > image, we have simply called the function "usrNetInit" from the target
    > > shell to install the network driver. no other functions are used to
    > > configure the driver.

    >
    > > 2. UDP packets on reception showing the checksum error in shell
    > > command "udpstatShow" .

    >
    > > 3. Network commands ( ls, dirList, dirs...) are not working. But while
    > > loading the driver no errors reported.

    >
    > > 4. windriver has provided ln97xEnd.c driver for this controller.
    > > but this Driver is not working correctly. So i verified with the
    > > workbench's ln97xEnd.c driver.
    > > In that lots of modifications has been from the last history of
    > > the tornado5.5.

    >
    > > the last history date in workbench6.5 we have--> 01v,11may06
    > > the last history date in tornado5.5 we have--> 01o,15jan03

    >
    > > Even i tried porting from the WB6.5 to vx5.5 but some part of the
    > > definitions is not available.
    > > how to get the updated driver.

    >
    > > suggestion or solution will be greatly appreciated.

    >
    > > Thank you
    > > Aravindhan




    Hi Mr.John,

    if I ping from the board , the ping succeeds some times and gives time
    out some times.

    here is its output

    ->
    ->
    -> ping "192.168.0.125"
    PING 192.168.0.125: 24 data bytes
    0x6ff4060 (tShell): TX index 1 pBuf=0x6f7ca74
    ping: wrote 192.168.0.125 32 chars, ret=32
    0x6fb7420 (tNetTask): RX index = 59 Rbuf =0x6f62fb0
    0x6fb7420 (tNetTask): TX index 2 pBuf=0x6f7d65c
    0x6fb7420 (tNetTask): RX index = 60 Rbuf =0x6f635a4
    ping: timeout
    no answer from 192.168.0.125
    value = -1 = 0xffffffff
    ->
    ->.


    -> ping "192.168.0.125"
    PING 192.168.0.125: 56 data bytes
    0x6ff4060 (tShell): TX index 3 pBuf=0x6f7d65c
    ping: wrote 192.168.0.125 64 chars, ret=64
    0x6fb7420 (tNetTask): RX index = 83 Rbuf =0x6f6be90
    @@@ping recvd pkt = 6f3d778@@@
    Into the RXprint function..
    Aravind->inet name =255.255.255.255
    64 bytes from 255.255.255.255: icmp_seq=0. time=16. ms
    0x6ff4060 (tShell): TX index 4 pBuf=0x6f6be90
    ping: wrote 192.168.0.125 64 chars, ret=64
    0x6fb7420 (tNetTask): RX index = 84 Rbuf =0x6f6c484
    ----192.168.0.125 PING Statistics----
    2 packets transmitted, 1 packets received, 50% packet loss
    round-trip (ms) min/avg/max = 16/16/16
    value = 0 = 0x0
    ->

    some times ping 3 or 4 packets will succeed, some times no packets
    will succeed.

    thanks for your reply.

    looking forward for your reply.

    regards
    Arvind



+ Reply to Thread