configure openssl on ppc860 link error - VxWorks

This is a discussion on configure openssl on ppc860 link error - VxWorks ; I use current Cygwin to build openssl-0.9.8g for Vxworks on Windows XP platform. When I Run ../configure vxworks-ppc so it display links error 3 .... process_begin: CreateProcess((null)), /usr/bin/perl ./util/mkdir-p.pl include/openssl, ...) failed. make (e=3): cant find path d:\Tornado2.2\host\x86-win32\bin\make.exe: *** [links] ...

+ Reply to Thread
Results 1 to 2 of 2

Thread: configure openssl on ppc860 link error

  1. configure openssl on ppc860 link error

    I use current Cygwin to build openssl-0.9.8g for Vxworks on Windows
    XP
    platform.
    When I Run
    ../configure vxworks-ppc
    so it display links error 3

    ....
    process_begin: CreateProcess((null)), /usr/bin/perl ./util/mkdir-p.pl
    include/openssl, ...) failed.
    make (e=3): cant find path
    d:\Tornado2.2\host\x86-win32\bin\make.exe: *** [links] error 3

    Here are the steps I took to get OpenSSL building for VxWorks
    on Motorola MPC8xx processors using a Window XP host

    1) Install cygwin.

    2) Download

    3) Copy the downloaded openssl-0.9.8g.tar.gz file to cygwin /tmp
    directory.

    4) Run the Windows Command Prompt.

    5) Execute your tarVars.bat.

    d:\Tornado2.2\host\x86-win32\bin\torVars.bat

    6) Run cygwin.

    C:\cygwin\cygwin.bat

    7) Go to cygwin /tmp directory.

    cd /tmp

    9) Untar OpenSSL archive:

    tar -zxf openssl-0.9.8g.tar.gz

    10) Configure OpenSSL:

    ./Configure vxworks-ppc860

    Then i see the error. Did anybody meet it?
    Please help me out. Thanks!

  2. Re: configure openssl on ppc860 link error

    i track the configure file , found the configure stop
    at line 1603 :
    (system $make_command.$make_targets) == 0 or exit $?
    if $make_targets ne "";

    cygwin cant find the system command, is the bug of cygwin?

+ Reply to Thread