php with osu 3.10a and openvms 8.3 - VMS

This is a discussion on php with osu 3.10a and openvms 8.3 - VMS ; Will PHP run on OpenVMS 8.3 with the OSU 3.10a webserver or will PHP require CSWS?...

+ Reply to Thread
Results 1 to 9 of 9

Thread: php with osu 3.10a and openvms 8.3

  1. php with osu 3.10a and openvms 8.3

    Will PHP run on OpenVMS 8.3 with the OSU 3.10a
    webserver or will PHP require CSWS?


  2. Re: php with osu 3.10a and openvms 8.3

    In article , Chuck Aaron writes:
    >Will PHP run on OpenVMS 8.3 with the OSU 3.10a
    >webserver or will PHP require CSWS?
    >


    You can download PHP from the CSWS website, install and run PHP.
    MOD_PHP won't work with OSU, but you can set up a presentation script for
    ..PHP pages that runs the PHP interpreter.

    --- Alan


  3. Re: php with osu 3.10a and openvms 8.3

    Alan Winston - SSRL Central Computing wrote:
    > In article , Chuck Aaron writes:
    >> Will PHP run on OpenVMS 8.3 with the OSU 3.10a
    >> webserver or will PHP require CSWS?

    >
    > You can download PHP from the CSWS website, install and run PHP.
    > MOD_PHP won't work with OSU, but you can set up a presentation script for
    > .PHP pages that runs the PHP interpreter.


    But still PHP 4.3.10 that is very old and not supported
    any more by PHP development ?

    Arne

  4. Re: php with osu 3.10a and openvms 8.3

    In article <48409e11$0$90276$14726298@news.sunsite.dk>, =?ISO-8859-1?Q?Arne_Vajh=F8j?= writes:
    >Alan Winston - SSRL Central Computing wrote:
    >> In article , Chuck Aaron writes:
    >>> Will PHP run on OpenVMS 8.3 with the OSU 3.10a
    >>> webserver or will PHP require CSWS?

    >>
    >> You can download PHP from the CSWS website, install and run PHP.
    >> MOD_PHP won't work with OSU, but you can set up a presentation script for
    >> .PHP pages that runs the PHP interpreter.

    >
    >But still PHP 4.3.10 that is very old and not supported
    >any more by PHP development ?


    Yes, last I looked. I'd love to hear that HP plans an update and when the
    date for that would be, but I haven't heard anything.

    (It still works fine, and so far has met the needs of my site, but it would
    be very nice to get a VMS track in the main development stream, like Perl has.)

    -- Alan


  5. Re: php with osu 3.10a and openvms 8.3

    Alan Winston - SSRL Central Computing wrote:
    > In article <48409e11$0$90276$14726298@news.sunsite.dk>, =?ISO-8859-1?Q?Arne_Vajh=F8j?= writes:
    >> Alan Winston - SSRL Central Computing wrote:
    >>> In article , Chuck Aaron writes:
    >>>> Will PHP run on OpenVMS 8.3 with the OSU 3.10a
    >>>> webserver or will PHP require CSWS?
    >>> You can download PHP from the CSWS website, install and run PHP.
    >>> MOD_PHP won't work with OSU, but you can set up a presentation script for
    >>> .PHP pages that runs the PHP interpreter.

    >> But still PHP 4.3.10 that is very old and not supported
    >> any more by PHP development ?

    >
    > Yes, last I looked. I'd love to hear that HP plans an update and when the
    > date for that would be, but I haven't heard anything.
    >
    > (It still works fine, and so far has met the needs of my site, but it would
    > be very nice to get a VMS track in the main development stream, like Perl has.)


    It obviously works as well as it has always done.

    And for a reasonable protected intranet environment, then it will
    be fine for 10 years.

    But PHP has announce that there will be no more security fixes
    after 8-AUG-2008. And after that it would be questionable whether
    it should be used for general internet access.

    Unless ofcourse someone see security patches as a problem in which
    case it would be a great product after that. :-)

    Arne

  6. Re: php with osu 3.10a and openvms 8.3

    On May 31, 2:49*pm, Arne Vajh°j wrote:
    > Alan Winston - SSRL Central Computing wrote:
    >
    >
    >
    >
    >
    > > In article <48409e11$0$90276$14726...@news.sunsite.dk>, =?ISO-8859-1?Q?Arne_Vajh=F8j?= writes:
    > >> Alan Winston - SSRL Central Computing wrote:
    > >>> In article , Chuck Aaron writes:
    > >>>> Will PHP run on OpenVMS 8.3 with the OSU 3.10a
    > >>>> webserver or will PHP require CSWS?
    > >>> You can download PHP from the CSWS website, install and run PHP. *
    > >>> MOD_PHP won't work with OSU, but you can set up a presentation script for
    > >>> .PHP pages that runs the PHP interpreter.
    > >> But still PHP 4.3.10 that is very old and not supported
    > >> any more by PHP development ?

    >
    > > Yes, last I looked. *I'd love to hear that HP plans an update and whenthe
    > > date for that would be, but I haven't heard anything.

    >
    > > (It still works fine, and so far has met the needs of my site, but it would
    > > be very nice to get a VMS track in the main development stream, like Perl has.)

    >
    > It obviously works as well as it has always done.
    >
    > And for a reasonable protected intranet environment, then it will
    > be fine for 10 years.
    >
    > But PHP has announce that there will be no more security fixes
    > after 8-AUG-2008. And after that it would be questionable whether
    > it should be used for general internet access.
    >
    > Unless ofcourse someone see security patches as a problem in which
    > case it would be a great product after that. *:-)
    >
    > Arne- Hide quoted text -
    >
    > - Show quoted text -


    HP is working on a PHP v5 release, hopefully available towards the end
    of this year. They haven't said anything officially, but a few of us
    on the VMS ITRC have been pushing them to port PHP 5 over.

    Rob.

  7. Re: php with osu 3.10a and openvms 8.3

    In article <97498c8b-0588-494d-aeaa-7bcd9b501b9c@2g2000hsn.googlegroups.com>, Rob writes:
    >
    >HP is working on a PHP v5 release, hopefully available towards the end
    >of this year. They haven't said anything officially, but a few of us
    >on the VMS ITRC have been pushing them to port PHP 5 over.


    Excellent news!

    -- Alan

  8. Re: php with osu 3.10a and openvms 8.3

    Rob wrote:
    > On May 31, 2:49 pm, Arne Vajh°j wrote:
    >
    >>Alan Winston - SSRL Central Computing wrote:
    >>
    >>
    >>
    >>
    >>
    >>
    >>>In article <48409e11$0$90276$14726...@news.sunsite.dk>, =?ISO-8859-1?Q?Arne_Vajh=F8j?= writes:
    >>>
    >>>>Alan Winston - SSRL Central Computing wrote:
    >>>>
    >>>>>In article , Chuck Aaron writes:
    >>>>>
    >>>>>>Will PHP run on OpenVMS 8.3 with the OSU 3.10a
    >>>>>>webserver or will PHP require CSWS?
    >>>>>
    >>>>>You can download PHP from the CSWS website, install and run PHP.
    >>>>>MOD_PHP won't work with OSU, but you can set up a presentation script for
    >>>>>.PHP pages that runs the PHP interpreter.
    >>>>
    >>>>But still PHP 4.3.10 that is very old and not supported
    >>>>any more by PHP development ?

    >>
    >>>Yes, last I looked. I'd love to hear that HP plans an update and when the
    >>>date for that would be, but I haven't heard anything.

    >>
    >>>(It still works fine, and so far has met the needs of my site, but it would
    >>>be very nice to get a VMS track in the main development stream, like Perl has.)

    >>
    >>It obviously works as well as it has always done.
    >>
    >>And for a reasonable protected intranet environment, then it will
    >>be fine for 10 years.
    >>
    >>But PHP has announce that there will be no more security fixes
    >>after 8-AUG-2008. And after that it would be questionable whether
    >>it should be used for general internet access.
    >>
    >>Unless ofcourse someone see security patches as a problem in which
    >>case it would be a great product after that. :-)
    >>
    >>Arne- Hide quoted text -
    >>
    >>- Show quoted text -

    >
    >
    > HP is working on a PHP v5 release, hopefully available towards the end
    > of this year. They haven't said anything officially, but a few of us
    > on the VMS ITRC have been pushing them to port PHP 5 over.


    With open source you'll never get the required quality or timeliness
    until the user community kicks-in (cf. Python). PPO.

    And it's all well-and-good for the body corporate to mandate vendor
    supported releases but these are more often same ones with data centres
    packed full of blades running Linux distros. Go figure.

    > Rob.


    --
    Like computer viruses, successful mind viruses will tend to be hard for
    their victims to detect. If you are the victim of one, the chances are
    that you won't know it, and may even vigorously deny it.
    [Richard Dawkins; Viruses of the Mind]

  9. Re: php with osu 3.10a and openvms 8.3

    Alan Winston - SSRL Central Computing wrote:
    > In article <97498c8b-0588-494d-aeaa-7bcd9b501b9c@2g2000hsn.googlegroups.com>, Rob writes:
    >> HP is working on a PHP v5 release, hopefully available towards the end
    >> of this year. They haven't said anything officially, but a few of us
    >> on the VMS ITRC have been pushing them to port PHP 5 over.

    >
    > Excellent news!


    Sure is.

    And hopefully 5.2.x !

    Arne

+ Reply to Thread