530 5.7.1 and 554 5.5.0 - VMS

This is a discussion on 530 5.7.1 and 554 5.5.0 - VMS ; Hi, if remember well recently, someone else reported the following problem. I'm receiving a lot of connections that apparently doesn't recognize a 530 SMTP code answer after the RCPT TO command. The problem is that the connection is closed for ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: 530 5.7.1 and 554 5.5.0

  1. 530 5.7.1 and 554 5.5.0

    Hi,

    if remember well recently, someone else reported the following problem.

    I'm receiving a lot of connections that apparently doesn't recognize
    a 530 SMTP code answer after the RCPT TO command.

    The problem is that the connection is closed for
    os_smtp_read: [5] network read failed
    causing the TCP_LOCAL_SLAVE.LOG; versions to increase very fast.

    Here is an extract from the log:

    <...>
    7-JAN-2008 19:14:05.98: Received : "RCPT TO: "
    7-JAN-2008 19:14:06.53: Sending : "530 5.7.1 Dynamic IP Addresses See:
    http://www.sorbs.net/lookup.shtml?83.7.41.88 ....
    7-JAN-2008 19:14:06.53: Received : "DATA"
    7-JAN-2008 19:14:07.03: Sending : "554 5.5.0 No recipients have been
    specified."
    7-JAN-2008 19:14:07.95: os_smtp_read: [5] network read failed
    7-JAN-2008 19:14:07.96: Error: broken pipe
    7-JAN-2008 19:14:08.01: Shutting down SASL server context
    7-JAN-2008 19:14:08.01: smtpc_enqueue returning a status of 9

    How to solve the problem of the very fast version number growth ?

    Francesco

  2. Re: 530 5.7.1 and 554 5.5.0

    > Hi,

    > if remember well recently, someone else reported the following problem.


    > I'm receiving a lot of connections that apparently doesn't recognize
    > a 530 SMTP code answer after the RCPT TO command.


    > The problem is that the connection is closed for
    > os_smtp_read: [5] network read failed
    > causing the TCP_LOCAL_SLAVE.LOG; versions to increase very fast.


    > Here is an extract from the log:


    > <...>
    > 7-JAN-2008 19:14:05.98: Received : "RCPT TO: "
    > 7-JAN-2008 19:14:06.53: Sending : "530 5.7.1 Dynamic IP Addresses See:
    > http://www.sorbs.net/lookup.shtml?83.7.41.88 ....
    > 7-JAN-2008 19:14:06.53: Received : "DATA"
    > 7-JAN-2008 19:14:07.03: Sending : "554 5.5.0 No recipients have been
    > specified."
    > 7-JAN-2008 19:14:07.95: os_smtp_read: [5] network read failed
    > 7-JAN-2008 19:14:07.96: Error: broken pipe
    > 7-JAN-2008 19:14:08.01: Shutting down SASL server context
    > 7-JAN-2008 19:14:08.01: smtpc_enqueue returning a status of 9


    > How to solve the problem of the very fast version number growth ?


    Disable debugging. If that doesn't prevent debug logs from being created
    there's a bug Process needs to fix. If uou have debugging of any sort enabled
    you have to be prepared to deal with the resulting files.

    Ned

  3. Re: 530 5.7.1 and 554 5.5.0

    > > Hi,

    > > if remember well recently, someone else reported the following problem.


    > > I'm receiving a lot of connections that apparently doesn't recognize
    > > a 530 SMTP code answer after the RCPT TO command.


    > > The problem is that the connection is closed for
    > > os_smtp_read: [5] network read failed
    > > causing the TCP_LOCAL_SLAVE.LOG; versions to increase very fast.


    > > Here is an extract from the log:


    > > <...>
    > > 7-JAN-2008 19:14:05.98: Received : "RCPT TO: "
    > > 7-JAN-2008 19:14:06.53: Sending : "530 5.7.1 Dynamic IP Addresses See:
    > > http://www.sorbs.net/lookup.shtml?83.7.41.88 ....
    > > 7-JAN-2008 19:14:06.53: Received : "DATA"
    > > 7-JAN-2008 19:14:07.03: Sending : "554 5.5.0 No recipients have been
    > > specified."
    > > 7-JAN-2008 19:14:07.95: os_smtp_read: [5] network read failed
    > > 7-JAN-2008 19:14:07.96: Error: broken pipe
    > > 7-JAN-2008 19:14:08.01: Shutting down SASL server context
    > > 7-JAN-2008 19:14:08.01: smtpc_enqueue returning a status of 9


    > > How to solve the problem of the very fast version number growth ?


    > Disable debugging. If that doesn't prevent debug logs from being created
    > there's a bug Process needs to fix. If uou have debugging of any sort enabled
    > you have to be prepared to deal with the resulting files.


    I have debug disabled.

    All the TCP_LOCAL_SLAVE.LOG files contain only one line with

    8-JAN-2008 09:08:55.94: SMTP routine failure from SMTPC_ENQUEUE

    Is this error related to the above scenario ?
    If I remember well, the TCP_LOCAL_SLAVE.LOG is written if there is an error
    also if the debug is disabled.

    Francesco

    > Ned


  4. Re: 530 5.7.1 and 554 5.5.0

    > > > Hi,

    > > > if remember well recently, someone else reported the following problem.


    > > > I'm receiving a lot of connections that apparently doesn't recognize
    > > > a 530 SMTP code answer after the RCPT TO command.


    > > > The problem is that the connection is closed for
    > > > os_smtp_read: [5] network read failed
    > > > causing the TCP_LOCAL_SLAVE.LOG; versions to increase very fast.


    > > > Here is an extract from the log:


    > > > <...>
    > > > 7-JAN-2008 19:14:05.98: Received : "RCPT TO: "
    > > > 7-JAN-2008 19:14:06.53: Sending : "530 5.7.1 Dynamic IP Addresses See:
    > > > http://www.sorbs.net/lookup.shtml?83.7.41.88 ....
    > > > 7-JAN-2008 19:14:06.53: Received : "DATA"
    > > > 7-JAN-2008 19:14:07.03: Sending : "554 5.5.0 No recipients have been
    > > > specified."
    > > > 7-JAN-2008 19:14:07.95: os_smtp_read: [5] network read failed
    > > > 7-JAN-2008 19:14:07.96: Error: broken pipe
    > > > 7-JAN-2008 19:14:08.01: Shutting down SASL server context
    > > > 7-JAN-2008 19:14:08.01: smtpc_enqueue returning a status of 9


    > > > How to solve the problem of the very fast version number growth ?


    > > Disable debugging. If that doesn't prevent debug logs from being created
    > > there's a bug Process needs to fix. If uou have debugging of any sort enabled
    > > you have to be prepared to deal with the resulting files.


    > I have debug disabled.


    > All the TCP_LOCAL_SLAVE.LOG files contain only one line with


    > 8-JAN-2008 09:08:55.94: SMTP routine failure from SMTPC_ENQUEUE


    > Is this error related to the above scenario ?


    Probably. In any case, it should only appear when debugging is enabled. Process
    needs to conditionalize this statement (in tcp_smtp_slave.c, I have provided
    the necessary fix).

    > If I remember well, the TCP_LOCAL_SLAVE.LOG is written if there is an error
    > also if the debug is disabled.


    It shouldn't be.

    Ned

+ Reply to Thread