problems with SSH after last patches - VMS

This is a discussion on problems with SSH after last patches - VMS ; Hello, trough hollidays I've been applying last patches for multinet and found that after that I'm having problems with SSH, stop working after some time. the error in the SSHD.LOG says "Failed to get handed-off socket: errno 6" At the ...

+ Reply to Thread
Results 1 to 6 of 6

Thread: problems with SSH after last patches

  1. problems with SSH after last patches

    Hello, trough hollidays I've been applying last patches for multinet and
    found that after that I'm having problems with SSH, stop working after
    some time. the error in the SSHD.LOG says
    "Failed to get handed-off socket: errno 6"

    At the same time I've applied some VMS patches like:

    VMS83A_UPDATE V5.0
    VMS83A_SYS V6.0
    VMS83A_ACRTL V4.0

    The last Multinet applied patches have been:

    KERNEL-UPDATE V6.0
    UCX_LIBRARY_EMULATION V6.0

    I don't know if the problem was with Multinet or VMS patches, but prior
    to this changes SSH was working fine, and just after installing the
    patch was also working.

    Even if I stop SSH master server and Multinet Server and restart them
    SSH continues without working, I need to reboot the system and SSH works
    again for a time.

    Can I activate some DEBUG to check where is the problem.

    Regards
    Juan C. Blanco
    --
    +----------------------------------------------------------------+
    | Juan C. Blanco |
    | |
    | Centro de Calculo | |
    | Facultad de Informatica U.P.M. | E-mail: jcblanco@fi.upm.es |
    | Campus de Montegancedo | |
    | Boadilla del Monte | Tel.: (+34) 91 336 7466 |
    | 28660 MADRID (Spain) | Fax : (+34) 91 336 6913 |
    +----------------------------------------------------------------+

  2. Re: problems with SSH after last patches

    This message from the Info-MultiNet archive seems relevant:

    http://www.multinet.process.com/scri...ltinet.2007-12

    If that link doesn't work for you, it was a reply from Dan O'Reilly on
    Dec 5, in response to the original question posted by Yehavi on Nov 6.
    The subject of the thread was:

    SSH daemon fails with "Failed to get handed-off socket: errno 6"

    Sounds like a patch is in the works.

    -ken


    Juan C. Blanco wrote:
    > Hello, trough hollidays I've been applying last patches for multinet
    > and found that after that I'm having problems with SSH, stop working
    > after some time. the error in the SSHD.LOG says
    > "Failed to get handed-off socket: errno 6"
    >
    > At the same time I've applied some VMS patches like:
    >
    > VMS83A_UPDATE V5.0
    > VMS83A_SYS V6.0
    > VMS83A_ACRTL V4.0
    >
    > The last Multinet applied patches have been:
    >
    > KERNEL-UPDATE V6.0
    > UCX_LIBRARY_EMULATION V6.0
    >
    > I don't know if the problem was with Multinet or VMS patches, but
    > prior to this changes SSH was working fine, and just after installing
    > the patch was also working.
    >
    > Even if I stop SSH master server and Multinet Server and restart them
    > SSH continues without working, I need to reboot the system and SSH
    > works again for a time.
    >
    > Can I activate some DEBUG to check where is the problem.
    >
    > Regards
    > Juan C. Blanco


    --
    - Ken
    ================================================== ===============
    Ken Connelly Associate Director, Security and Systems
    ITS Network Services University of Northern Iowa
    email: Ken.Connelly@uni.edu p: (319) 273-5850 f: (319) 273-7373


  3. Re: problems with SSH after last patches

    This is a known problem, and the upcoming ECO's will address it. The
    source of the issue is with one of the VMS patches that increased the
    number of device unit #'s to 65535. Up to this time, they were limited to
    32767 (a signed word) and now, of course, it can go to an unsigned word.

    The only cure at this time is to reboot or to back out the offending VMS
    patch (the README for the ECO's should tell you which one caused the problem).

    At 03:24 AM 1/2/2008, Juan C. Blanco wrote:
    >Hello, trough hollidays I've been applying last patches for multinet and
    >found that after that I'm having problems with SSH, stop working after
    >some time. the error in the SSHD.LOG says
    >"Failed to get handed-off socket: errno 6"
    >
    >At the same time I've applied some VMS patches like:
    >
    >VMS83A_UPDATE V5.0
    >VMS83A_SYS V6.0
    >VMS83A_ACRTL V4.0
    >
    >The last Multinet applied patches have been:
    >
    >KERNEL-UPDATE V6.0
    >UCX_LIBRARY_EMULATION V6.0
    >
    >I don't know if the problem was with Multinet or VMS patches, but prior to
    >this changes SSH was working fine, and just after installing the patch was
    >also working.
    >
    >Even if I stop SSH master server and Multinet Server and restart them SSH
    >continues without working, I need to reboot the system and SSH works again
    >for a time.
    >
    >Can I activate some DEBUG to check where is the problem.
    >
    >Regards
    >Juan C. Blanco
    >--
    >+----------------------------------------------------------------+
    >| Juan C. Blanco |
    >| |
    >| Centro de Calculo | |
    >| Facultad de Informatica U.P.M. | E-mail: jcblanco@fi.upm.es |
    >| Campus de Montegancedo | |
    >| Boadilla del Monte | Tel.: (+34) 91 336 7466 |
    >| 28660 MADRID (Spain) | Fax : (+34) 91 336 6913 |
    >+----------------------------------------------------------------+


    ------
    +-------------------------------+----------------------------------------+
    | Dan O'Reilly | "There are 10 types of people in this |
    | Principal Engineer | world: those who understand binary |
    | Process Software | and those who don't." |
    | http://www.process.com | |
    +-------------------------------+----------------------------------------+


  4. Re: problems with SSH after last patches

    At the time, Yehavi solved by backing at VMS83A_SYS V5.0. If Juan
    skipped that one and just applied V6, presumably that could be backed
    out as well if there weren't things there that were crucial.

    Any guesses as to how far away the MultiNet ECO that addresses this is?

    -ken

    Dan O'Reilly wrote:
    > This is a known problem, and the upcoming ECO's will address it. The
    > source of the issue is with one of the VMS patches that increased the
    > number of device unit #'s to 65535. Up to this time, they were
    > limited to 32767 (a signed word) and now, of course, it can go to an
    > unsigned word.
    >
    > The only cure at this time is to reboot or to back out the offending
    > VMS patch (the README for the ECO's should tell you which one caused
    > the problem).
    >
    > At 03:24 AM 1/2/2008, Juan C. Blanco wrote:
    >> Hello, trough hollidays I've been applying last patches for multinet
    >> and found that after that I'm having problems with SSH, stop working
    >> after some time. the error in the SSHD.LOG says
    >> "Failed to get handed-off socket: errno 6"
    >>
    >> At the same time I've applied some VMS patches like:
    >>
    >> VMS83A_UPDATE V5.0
    >> VMS83A_SYS V6.0
    >> VMS83A_ACRTL V4.0
    >>
    >> The last Multinet applied patches have been:
    >>
    >> KERNEL-UPDATE V6.0
    >> UCX_LIBRARY_EMULATION V6.0
    >>
    >> I don't know if the problem was with Multinet or VMS patches, but
    >> prior to this changes SSH was working fine, and just after installing
    >> the patch was also working.
    >>
    >> Even if I stop SSH master server and Multinet Server and restart them
    >> SSH continues without working, I need to reboot the system and SSH
    >> works again for a time.
    >>
    >> Can I activate some DEBUG to check where is the problem.
    >>
    >> Regards
    >> Juan C. Blanco
    >> --
    >> +----------------------------------------------------------------+
    >> | Juan C. Blanco |
    >> | |
    >> | Centro de Calculo | |
    >> | Facultad de Informatica U.P.M. | E-mail: jcblanco@fi.upm.es |
    >> | Campus de Montegancedo | |
    >> | Boadilla del Monte | Tel.: (+34) 91 336 7466 |
    >> | 28660 MADRID (Spain) | Fax : (+34) 91 336 6913 |
    >> +----------------------------------------------------------------+

    >
    > ------
    > +-------------------------------+----------------------------------------+
    >
    > | Dan O'Reilly | "There are 10 types of people in
    > this |
    > | Principal Engineer | world: those who understand
    > binary |
    > | Process Software | and those who
    > don't." |
    > | http://www.process.com
    > | |
    > +-------------------------------+----------------------------------------+
    >
    >


    --
    - Ken
    ================================================== ===============
    Ken Connelly Associate Director, Security and Systems
    ITS Network Services University of Northern Iowa
    email: Ken.Connelly@uni.edu p: (319) 273-5850 f: (319) 273-7373


  5. Re: problems with SSH after last patches

    OK thanks, I'll try to find and undo te VMS patch until you have a new ECO.

    Regards
    Juan C. Blanco

    Juan C. Blanco

    Dan O'Reilly wrote:
    > This is a known problem, and the upcoming ECO's will address it. The
    > source of the issue is with one of the VMS patches that increased the
    > number of device unit #'s to 65535. Up to this time, they were limited
    > to 32767 (a signed word) and now, of course, it can go to an unsigned word.
    >
    > The only cure at this time is to reboot or to back out the offending VMS
    > patch (the README for the ECO's should tell you which one caused the
    > problem).
    >
    > At 03:24 AM 1/2/2008, Juan C. Blanco wrote:
    >> Hello, trough hollidays I've been applying last patches for multinet
    >> and found that after that I'm having problems with SSH, stop working
    >> after some time. the error in the SSHD.LOG says
    >> "Failed to get handed-off socket: errno 6"
    >>
    >> At the same time I've applied some VMS patches like:
    >>
    >> VMS83A_UPDATE V5.0
    >> VMS83A_SYS V6.0
    >> VMS83A_ACRTL V4.0
    >>
    >> The last Multinet applied patches have been:
    >>
    >> KERNEL-UPDATE V6.0
    >> UCX_LIBRARY_EMULATION V6.0
    >>
    >> I don't know if the problem was with Multinet or VMS patches, but
    >> prior to this changes SSH was working fine, and just after installing
    >> the patch was also working.
    >>
    >> Even if I stop SSH master server and Multinet Server and restart them
    >> SSH continues without working, I need to reboot the system and SSH
    >> works again for a time.
    >>
    >> Can I activate some DEBUG to check where is the problem.
    >>
    >> Regards
    >> Juan C. Blanco
    >> --
    >> +----------------------------------------------------------------+
    >> | Juan C. Blanco |
    >> | |
    >> | Centro de Calculo | |
    >> | Facultad de Informatica U.P.M. | E-mail: jcblanco@fi.upm.es |
    >> | Campus de Montegancedo | |
    >> | Boadilla del Monte | Tel.: (+34) 91 336 7466 |
    >> | 28660 MADRID (Spain) | Fax : (+34) 91 336 6913 |
    >> +----------------------------------------------------------------+

    >
    > ------
    > +-------------------------------+----------------------------------------+
    > | Dan O'Reilly | "There are 10 types of people in this |
    > | Principal Engineer | world: those who understand binary |
    > | Process Software | and those who don't." |
    > | http://www.process.com | |
    > +-------------------------------+----------------------------------------+
    >


    --
    +----------------------------------------------------------------+
    | Juan C. Blanco |
    | |
    | Centro de Calculo | |
    | Facultad de Informatica U.P.M. | E-mail: jcblanco@fi.upm.es |
    | Campus de Montegancedo | |
    | Boadilla del Monte | Tel.: (+34) 91 336 7466 |
    | 28660 MADRID (Spain) | Fax : (+34) 91 336 6913 |
    +----------------------------------------------------------------+

  6. Re: problems with SSH after last patches

    Soon (next few days), hopefully.

    At 07:29 AM 1/2/2008, Ken Connelly wrote:
    >At the time, Yehavi solved by backing at VMS83A_SYS V5.0. If Juan skipped
    >that one and just applied V6, presumably that could be backed out as well
    >if there weren't things there that were crucial.
    >
    >Any guesses as to how far away the MultiNet ECO that addresses this is?
    >
    >-ken
    >
    >Dan O'Reilly wrote:
    >>This is a known problem, and the upcoming ECO's will address it. The
    >>source of the issue is with one of the VMS patches that increased the
    >>number of device unit #'s to 65535. Up to this time, they were limited
    >>to 32767 (a signed word) and now, of course, it can go to an unsigned word.
    >>
    >>The only cure at this time is to reboot or to back out the offending VMS
    >>patch (the README for the ECO's should tell you which one caused the problem).
    >>
    >>At 03:24 AM 1/2/2008, Juan C. Blanco wrote:
    >>>Hello, trough hollidays I've been applying last patches for multinet and
    >>>found that after that I'm having problems with SSH, stop working after
    >>>some time. the error in the SSHD.LOG says
    >>>"Failed to get handed-off socket: errno 6"
    >>>
    >>>At the same time I've applied some VMS patches like:
    >>>
    >>>VMS83A_UPDATE V5.0
    >>>VMS83A_SYS V6.0
    >>>VMS83A_ACRTL V4.0
    >>>
    >>>The last Multinet applied patches have been:
    >>>
    >>>KERNEL-UPDATE V6.0
    >>>UCX_LIBRARY_EMULATION V6.0
    >>>
    >>>I don't know if the problem was with Multinet or VMS patches, but prior
    >>>to this changes SSH was working fine, and just after installing the
    >>>patch was also working.
    >>>
    >>>Even if I stop SSH master server and Multinet Server and restart them
    >>>SSH continues without working, I need to reboot the system and SSH works
    >>>again for a time.
    >>>
    >>>Can I activate some DEBUG to check where is the problem.
    >>>
    >>>Regards
    >>>Juan C. Blanco
    >>>--
    >>>+----------------------------------------------------------------+
    >>>| Juan C. Blanco |
    >>>| |
    >>>| Centro de Calculo | |
    >>>| Facultad de Informatica U.P.M. | E-mail: jcblanco@fi.upm.es |
    >>>| Campus de Montegancedo | |
    >>>| Boadilla del Monte | Tel.: (+34) 91 336 7466 |
    >>>| 28660 MADRID (Spain) | Fax : (+34) 91 336 6913 |
    >>>+----------------------------------------------------------------+

    >>
    >>------
    >>+-------------------------------+----------------------------------------+
    >>| Dan O'Reilly | "There are 10 types of people in this |
    >>| Principal Engineer | world: those who understand binary |
    >>| Process Software | and those who don't." |
    >>| http://www.process.com
    >>| |
    >>+-------------------------------+----------------------------------------+

    >
    >--
    >- Ken
    >================================================== ===============
    >Ken Connelly Associate Director, Security and Systems
    >ITS Network Services University of Northern Iowa
    >email: Ken.Connelly@uni.edu p: (319) 273-5850 f: (319) 273-7373
    >


    ------
    +-------------------------------+----------------------------------------+
    | Dan O'Reilly | "There are 10 types of people in this |
    | Principal Engineer | world: those who understand binary |
    | Process Software | and those who don't." |
    | http://www.process.com | |
    +-------------------------------+----------------------------------------+


+ Reply to Thread