http://h71000.www7.hp.com/openvms/pr...l.html#tcpware
has the complete instructions on what to extract where.

Don't forget to set your browser preferred language to english...

HTH,
Martin

Richard Whalen wrote:
> Did you extract UCX$ESMP_SHR.EXE from the TCP/IP Services kit and put it in
> SYS$LIBRARY:
> The management agents use code in this library to communicate with the SNMP
> Agent.
>
> You may want to add an AGENTX_PEER statement for the address of EWA-0 to the
> SNMPD.CONF file.
>
> Do the following to enable the SNMP AgentX debugging messages:
> $ define/system TCPWARE_SNMP_DEBUG 262144 !hex 40000
> $ @tcpware:restart snmp
>
>
> "Viswa" wrote in message
> news:1150974686.470084.269150@i40g2000cwc.googlegr oups.com...
> > hi,
> >
> > (SNMP not able to connect using AgentX)
> >
> > Environment: V7.3-2
> > TCPWARE5602
> > SNMP patch
> >
> > I've configured snmp using documents provided in TCPWare056

> document.
> > Started mgmt agents as specified in the mgmt agents

> document. I could
> > not see my agent connect to Master agent.
> >
> > (1.) Configured : LPB-0, EWA-0.
> >
> > configured snmp as per tcpware document
> > (2.) $ed SYS$COMMON:[TCPWARE]SNMPD.CONF and copied the same to
> > SYS$COMMON:[SYSMGR]SNMPD.CONF
> >
> > !
> > community public 127.0.0.1 READ
> > community elmginkgo 127.0.0.1 READ-WRITE
> > ! AGENTX_PEER
> > AGENTX_PEER 127.0.0.1
> >
> > (3.) configured SNMP server to enable AgentX
> >
> > $sh log *agent*
> >
> > "ACME$LATEST_ENABLED_AGENT_LIST" = "VMS"
> > "TCPIP$AGENTX_INET_PORT" = "705"
> > "TCPIP$AGENTX_LOCAL_PORT" = "705"
> > "TCPWARE_SNMP_AGENTX" = "1"
> >
> >
> > $ @tcpware:netstat -a
> > TCPware(R) for OpenVMS Active Internet Connections

> (including servers):
> >
> > ID RecvQ SendQ Local Address Foreign Address
> > State
> > -- ----- ----- ------------- ---------------
> > -----
> > INET56 0 0 *.ftp *.*
> > LISTEN
> > TCP74 0 0 send2..domain *.*
> > LISTEN
> > TCP75 0 0 localhost.domain *.*
> > LISTEN
> > INET59 0 0 *.iso-tsap *.*
> > LISTEN
> > INET60 0 0 *.iso-tsap-c2 *.*
> > LISTEN
> > INET63 0 0 *.telnet *.*
> > LISTEN
> > BG2575 0 0 *.agentx *.*
> > LISTEN
> > UDP117 0 0 send2..domain *.*
> > UDP118 0 0 localhost.domain *.*
> > UDP119 0 0 *.1173 *.*
> > UDP121 0 0 *.metric *.*
> > BG2573 0 0 *.snmp *.*
> > UDP138 0 0 *.1192 *.*
> >
> > Started sub-agent in trace mode:
> >
> > Sub agent is throws an error:-
> > $host :== "$sys$specific:[wbem.agents]cpqhost_mib.exe"
> > $host -trace
> > 22-JUN-2006 16:26:15.87 Initializing eSNMP connection...
> > 22-JUN-2006 16:26:15.88 Using localhost address: 127.0.0.1
> > 22-JUN-2006 16:26:15.88 Local port: 705
> > 22-JUN-2006 16:26:15.89 **ERROR ESNMP_INIT.C line 3866: Could not
> > connect to mas
> > ter: function not implemented
> > 22-JUN-2006 16:26:15.89 esnmp_init() returning -1
> > 22-JUN-2006 16:26:15.89 **ERROR CPQHOST_MIB.C line 366:

> eSNMP error: -1
> > Cannot s
> > end OPEN to Master Agent, restart after delay
> > 22-JUN-2006 16:26:18.89 Initializing eSNMP connection...
> > 22-JUN-2006 16:26:18.90 Using localhost address: 127.0.0.1
> > 22-JUN-2006 16:26:18.90 Local port: 705
> > 22-JUN-2006 16:26:18.90 **ERROR ESNMP_INIT.C line 3866: Could not
> > connect to mas
> > ter: function not implemented
> > 22-JUN-2006 16:26:18.91 esnmp_init() returning -1
> > 22-JUN-2006 16:26:18.91 **ERROR CPQHOST_MIB.C line 366:

> eSNMP error: -1
> > Cannot s
> > end OPEN to Master Agent, restart after delay
> > 22-JUN-2006 16:26:21.91 **ERROR CPQHOST_MIB.C line 377:

> Terminating...
> >
> > It is terminating with error saying unable to open Master agent.
> >
> > I want to run SNMP in trace mode, I could not run.
> > I enabled a logical: TCPWARE_SNMP_DEBUG AGENTX_DEBUG but not much
> > information to debug the problem.
> >
> >
> > Is there any such problem seen earlier?
> > How to run SNMPD in trace mode to know how it responding to AgentX
> > requests?
> > Are there any thing I'm missing here?
> >
> > Regards,
> > Viswanath.
> >

>
>
>