vxinstall fails for VVM 3.2 on Solaris 8 - Veritas Volume Manager

This is a discussion on vxinstall fails for VVM 3.2 on Solaris 8 - Veritas Volume Manager ; Hi I have a E450 running Solaris 8 (with the latest patches) and VVM 3.2. After I encapsulate the bootdisk using vxinstall, it reboots twice and comes us with this message. ld.so.1:vconfigd:fatal:libdevid:so.1 pen failed:No such file or dir. After this, ...

+ Reply to Thread
Results 1 to 4 of 4

Thread: vxinstall fails for VVM 3.2 on Solaris 8

  1. vxinstall fails for VVM 3.2 on Solaris 8


    Hi
    I have a E450 running Solaris 8 (with the latest patches) and VVM 3.2.
    After I encapsulate the bootdisk using vxinstall, it reboots twice and comes
    us with this message.

    ld.so.1:vconfigd:fatal:libdevid:so.1pen failed:No such file or dir.

    After this, it returns to hash or OK prompt. I selected just the bootdisk
    for encapsulation leaving all other 11 disks alone in custom install. Pl
    help. TIA
    Regards
    Ragu

  2. Re: vxinstall fails for VVM 3.2 on Solaris 8


    We are experiencing the same exact problem, anyone found a solution?


    "Ragu" wrote:
    >
    >Hi
    > I have a E450 running Solaris 8 (with the latest patches) and VVM 3.2.
    >After I encapsulate the bootdisk using vxinstall, it reboots twice and comes
    >us with this message.
    >
    >ld.so.1:vconfigd:fatal:libdevid:so.1pen failed:No such file or dir.
    >
    > After this, it returns to hash or OK prompt. I selected just the bootdisk
    >for encapsulation leaving all other 11 disks alone in custom install. Pl
    >help. TIA
    >Regards
    >Ragu



  3. Re: vxinstall fails for VVM 3.2 on Solaris 8


    I did the following:

    1. Boot from cdrom or network in single user mode.

    ok> boot cdrom -s

    2. Mount the root slice (s0) and /usr slice (s6) from the disk onto known
    good mount points.

    For example,

    # mkdir /tmp/rootvol
    # mkdir /tmp/usrvol
    # mount -F ufs /dev/dsk/c0t0d0s0 /tmp/rootvol
    # mount -F ufs /dev/dsk/c0t0d0s6 /tmp/usrvol

    3. Copy the missing libraries into /etc/vx/slib

    # cp /tmp/usrvol/lib/libdevid* /tmp/rootvol/etc/vx/slib/

    4. Reboot the machine. (The vxinstall reboot should continue)

    # reboot

    Thanks,
    Dave Melnik

    "Pete DiSanto" wrote:
    >
    >We are experiencing the same exact problem, anyone found a solution?
    >
    >
    >"Ragu" wrote:
    >>
    >>Hi
    >> I have a E450 running Solaris 8 (with the latest patches) and VVM 3.2.
    >>After I encapsulate the bootdisk using vxinstall, it reboots twice and

    comes
    >>us with this message.
    >>
    >>ld.so.1:vconfigd:fatal:libdevid:so.1pen failed:No such file or dir.
    >>
    >> After this, it returns to hash or OK prompt. I selected just the bootdisk
    >>for encapsulation leaving all other 11 disks alone in custom install. Pl
    >>help. TIA
    >>Regards
    >>Ragu

    >



  4. Re: vxinstall fails for VVM 3.2 on Solaris 8


    This happend when you have / and /usr not into the same file system....
    when vxconfigd start the firt time it con read only / and even if the LD_LIBRARY_PATH
    includes /usr/lib/ it can't reach it...

    I hope Veritas will fix it soon!!!

    Ciao
    DAmiano




    "Dave Melnik" wrote:
    >
    >I did the following:
    >
    >1. Boot from cdrom or network in single user mode.
    >
    >ok> boot cdrom -s
    >
    >2. Mount the root slice (s0) and /usr slice (s6) from the disk onto known
    >good mount points.
    >
    >For example,
    >
    ># mkdir /tmp/rootvol
    ># mkdir /tmp/usrvol
    ># mount -F ufs /dev/dsk/c0t0d0s0 /tmp/rootvol
    ># mount -F ufs /dev/dsk/c0t0d0s6 /tmp/usrvol
    >
    >3. Copy the missing libraries into /etc/vx/slib
    >
    ># cp /tmp/usrvol/lib/libdevid* /tmp/rootvol/etc/vx/slib/
    >
    >4. Reboot the machine. (The vxinstall reboot should continue)
    >
    ># reboot
    >
    >Thanks,
    >Dave Melnik
    >
    >"Pete DiSanto" wrote:
    >>
    >>We are experiencing the same exact problem, anyone found a solution?
    >>
    >>
    >>"Ragu" wrote:
    >>>
    >>>Hi
    >>> I have a E450 running Solaris 8 (with the latest patches) and VVM 3.2.
    >>>After I encapsulate the bootdisk using vxinstall, it reboots twice and

    >comes
    >>>us with this message.
    >>>
    >>>ld.so.1:vconfigd:fatal:libdevid:so.1pen failed:No such file or dir.
    >>>
    >>> After this, it returns to hash or OK prompt. I selected just the bootdisk
    >>>for encapsulation leaving all other 11 disks alone in custom install.

    Pl
    >>>help. TIA
    >>>Regards
    >>>Ragu

    >>

    >



+ Reply to Thread