vxfen startup error - Veritas Cluster Server

This is a discussion on vxfen startup error - Veritas Cluster Server ; Hi all, could anyone help me. error msg come up when run /sbin/vxfen-startup script. err msg as below ================ root@CTKRAC02 # awk: syntax error near line 4 awk: illegal statement near line 4 =============== thx alot for ur help in ...

+ Reply to Thread
Results 1 to 5 of 5

Thread: vxfen startup error

  1. vxfen startup error


    Hi all,
    could anyone help me. error msg come up when run /sbin/vxfen-startup script.

    err msg as below

    ================
    root@CTKRAC02 # awk: syntax error near line 4
    awk: illegal statement near line 4
    ===============
    thx alot for ur help in advance.

    VCS:5.0 MP1
    OS:solaris 10 11/6

    Thanks!

  2. Re: vxfen startup error


    Sing,

    I have the same problem, did you resolve the issue and how?
    VCS 5.0 MP1, Solaris 9 09/05

    Andy


    "Sing" wrote:
    >
    >Hi all,
    > could anyone help me. error msg come up when run /sbin/vxfen-startup script.
    >
    >err msg as below
    >
    >================
    >root@CTKRAC02 # awk: syntax error near line 4
    >awk: illegal statement near line 4
    >===============
    >thx alot for ur help in advance.
    >
    >VCS:5.0 MP1
    >OS:solaris 10 11/6
    >
    >Thanks!



  3. Re: vxfen startup error

    ok, this is a known issue and will be fixed in the next release. They
    have assigned the incident number 1025561 to it.


    Now, the fix itself is actually very simple. Look at he startup script
    and search for awk. The script should be using /usr/xpg4/bin/awk

    The message will not effect the way efncing starts up

    Andy wrote:
    > Sing,
    >
    > I have the same problem, did you resolve the issue and how?
    > VCS 5.0 MP1, Solaris 9 09/05
    >
    > Andy
    >
    >
    > "Sing" wrote:
    >
    >>Hi all,
    >>could anyone help me. error msg come up when run /sbin/vxfen-startup script.
    >>
    >>err msg as below
    >>
    >>================
    >>root@CTKRAC02 # awk: syntax error near line 4
    >>awk: illegal statement near line 4
    >>===============
    >>thx alot for ur help in advance.
    >>
    >>VCS:5.0 MP1
    >>OS:solaris 10 11/6
    >>
    >>Thanks!

    >
    >


  4. Re: vxfen startup error


    Me wrote:
    >ok, this is a known issue and will be fixed in the next release. They
    >have assigned the incident number 1025561 to it.
    >
    >
    >Now, the fix itself is actually very simple. Look at he startup script
    >and search for awk. The script should be using /usr/xpg4/bin/awk


    Did this then got another error.

    /sbin/vxfen-startup: random_number[0]=0: not found
    /sbin/vxfen-startup: random_number[1]=2: not found
    /sbin/vxfen-startup: random_number[2]=2: not found
    /sbin/vxfen-startup: random_number[3]=10: not found
    /sbin/vxfen-startup: random_number[4]=3: not found
    /sbin/vxfen-startup: random_number[5]=33: not found
    /sbin/vxfen-startup: random_number[6]=62: not found
    /sbin/vxfen-startup: random_number[7]=154: not found
    /sbin/vxfen-startup: random_number[8]=189: not found
    /sbin/vxfen-startup: random_number[9]=263: not found

    I run the same awk code under cygwin all is OK


    >The message will not effect the way efncing starts up


    I've testing fencing, it all works OK, I'm just trying to get a clean installation.

    The code in question looks to manage a retry sleep time, which doesn't look
    critical to me.

    Thanks for the help

    Andy



    >
    >Andy wrote:
    >> Sing,
    >>
    >> I have the same problem, did you resolve the issue and how?
    >> VCS 5.0 MP1, Solaris 9 09/05
    >>
    >> Andy
    >>
    >>
    >> "Sing" wrote:
    >>
    >>>Hi all,
    >>>could anyone help me. error msg come up when run /sbin/vxfen-startup script.
    >>>
    >>>err msg as below
    >>>
    >>>================
    >>>root@CTKRAC02 # awk: syntax error near line 4
    >>>awk: illegal statement near line 4
    >>>===============
    >>>thx alot for ur help in advance.
    >>>
    >>>VCS:5.0 MP1
    >>>OS:solaris 10 11/6
    >>>
    >>>Thanks!

    >>
    >>



  5. Re: vxfen startup error


    "Andy" wrote:
    >
    >Me wrote:
    >>ok, this is a known issue and will be fixed in the next release. They
    >>have assigned the incident number 1025561 to it.
    >>
    >>
    >>Now, the fix itself is actually very simple. Look at he startup script


    >>and search for awk. The script should be using /usr/xpg4/bin/awk

    >
    >Did this then got another error.
    >
    >/sbin/vxfen-startup: random_number[0]=0: not found
    >/sbin/vxfen-startup: random_number[1]=2: not found
    >/sbin/vxfen-startup: random_number[2]=2: not found
    >/sbin/vxfen-startup: random_number[3]=10: not found
    >/sbin/vxfen-startup: random_number[4]=3: not found
    >/sbin/vxfen-startup: random_number[5]=33: not found
    >/sbin/vxfen-startup: random_number[6]=62: not found
    >/sbin/vxfen-startup: random_number[7]=154: not found
    >/sbin/vxfen-startup: random_number[8]=189: not found
    >/sbin/vxfen-startup: random_number[9]=263: not found
    >
    >I run the same awk code under cygwin all is OK


    The bourne shell doesn't support arrays, change the script to use Korn Shell.
    Change first line of /sbin/vfen-startup to read
    #!/bin/ksh

    Note to also to replace awk with /usr/xpg4/bin/awk

    >>The message will not effect the way efncing starts up

    >
    >I've testing fencing, it all works OK, I'm just trying to get a clean installation.
    >
    >The code in question looks to manage a retry sleep time, which doesn't look
    >critical to me.
    >
    >Thanks for the help
    >
    >Andy
    >
    >
    >
    >>
    >>Andy wrote:
    >>> Sing,
    >>>
    >>> I have the same problem, did you resolve the issue and how?
    >>> VCS 5.0 MP1, Solaris 9 09/05
    >>>
    >>> Andy
    >>>
    >>>
    >>> "Sing" wrote:
    >>>
    >>>>Hi all,
    >>>>could anyone help me. error msg come up when run /sbin/vxfen-startup

    script.
    >>>>
    >>>>err msg as below
    >>>>
    >>>>================
    >>>>root@CTKRAC02 # awk: syntax error near line 4
    >>>>awk: illegal statement near line 4
    >>>>===============
    >>>>thx alot for ur help in advance.
    >>>>
    >>>>VCS:5.0 MP1
    >>>>OS:solaris 10 11/6
    >>>>
    >>>>Thanks!
    >>>
    >>>

    >



+ Reply to Thread