In.mpathd error while enabling active active IPMP config - Veritas Cluster Server

This is a discussion on In.mpathd error while enabling active active IPMP config - Veritas Cluster Server ; Hello There, I have solaris 9 9/04 with SFO 4.1. I have IPMP configured as active-active. But once I configure MultiNicB resource and enable it's monitor error out MultiNICB:NIC_IPMP:monitor:The mpathd process (/usr/lib/inet/in. mpathd) does not exist Although it does exist. ...

+ Reply to Thread
Results 1 to 3 of 3

Thread: In.mpathd error while enabling active active IPMP config

  1. In.mpathd error while enabling active active IPMP config


    Hello There,

    I have solaris 9 9/04 with SFO 4.1. I have IPMP configured as active-active.

    But once I configure MultiNicB resource and enable it's monitor error out

    MultiNICB:NIC_IPMP:monitor:The mpathd process (/usr/lib/inet/in.
    mpathd) does not exist
    Although it does exist. No matter what i mention in the attribute - /sbin/in.mpathd
    or /usr/lib/inet/in.mpathd it does not accept the value.

    root@prometheus # cd /sbin
    root@prometheus # ls -al in.mpathd
    lrwxrwxrwx 1 root other 25 May 11 12:38 in.mpathd -> ../usr/lib/inet/in.mpathd

    Can somebody help me in configuring this part.

    Sandeep


  2. Re: In.mpathd error while enabling active active IPMP config

    do the following:

    ps -ef | grep in.mpathd



    You'll see that mpathd does not run from /sbin , but actually from
    somewhere else.


    Whatever it says there (in the ps) configure VCS to point to that




    sandeep wrote:
    > Hello There,
    >
    > I have solaris 9 9/04 with SFO 4.1. I have IPMP configured as active-active.
    >
    > But once I configure MultiNicB resource and enable it's monitor error out
    >
    > MultiNICB:NIC_IPMP:monitor:The mpathd process (/usr/lib/inet/in.
    > mpathd) does not exist
    > Although it does exist. No matter what i mention in the attribute - /sbin/in.mpathd
    > or /usr/lib/inet/in.mpathd it does not accept the value.
    >
    > root@prometheus # cd /sbin
    > root@prometheus # ls -al in.mpathd
    > lrwxrwxrwx 1 root other 25 May 11 12:38 in.mpathd -> ../usr/lib/inet/in.mpathd
    >
    > Can somebody help me in configuring this part.
    >
    > Sandeep
    >


  3. Re: In.mpathd error while enabling active active IPMP config



    I modify the inetinit file at line 52 and remove the "-a" option after "/usr/lib/inet/in.mpathd"
    the resource MultiNICB did not sent me alarm messages


    Me wrote:
    >do the following:
    >
    >ps -ef | grep in.mpathd
    >
    >
    >
    >You'll see that mpathd does not run from /sbin , but actually from
    >somewhere else.
    >
    >
    >Whatever it says there (in the ps) configure VCS to point to that
    >
    >
    >
    >
    >sandeep wrote:
    >> Hello There,
    >>
    >> I have solaris 9 9/04 with SFO 4.1. I have IPMP configured as active-active.
    >>
    >> But once I configure MultiNicB resource and enable it's monitor error

    out
    >>
    >> MultiNICB:NIC_IPMP:monitor:The mpathd process (/usr/lib/inet/in.
    >> mpathd) does not exist
    >> Although it does exist. No matter what i mention in the attribute - /sbin/in.mpathd
    >> or /usr/lib/inet/in.mpathd it does not accept the value.
    >>
    >> root@prometheus # cd /sbin
    >> root@prometheus # ls -al in.mpathd
    >> lrwxrwxrwx 1 root other 25 May 11 12:38 in.mpathd -> ../usr/lib/inet/in.mpathd
    >>
    >> Can somebody help me in configuring this part.
    >>
    >> Sandeep
    >>



+ Reply to Thread